summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-13 18:58:55 +0000
committerSam James <sam@gentoo.org>2022-12-13 19:36:55 +0000
commit0042496ebae91879fa9747f92320cebfeed83fc2 (patch)
treea732afbf63e4d8e494a7c47f096e53a252fd7783 /app-shells/bash/bash-9999.ebuild
parentdev-ruby/rails-html-sanitizer: add 1.4.4 (diff)
downloadgentoo-0042496ebae91879fa9747f92320cebfeed83fc2.tar.gz
gentoo-0042496ebae91879fa9747f92320cebfeed83fc2.tar.bz2
gentoo-0042496ebae91879fa9747f92320cebfeed83fc2.zip
app-shells/bash: wire up verify-sig for patches
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-shells/bash/bash-9999.ebuild')
-rw-r--r--app-shells/bash/bash-9999.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/app-shells/bash/bash-9999.ebuild b/app-shells/bash/bash-9999.ebuild
index 6f6be5e13621..5fecc6b0353c 100644
--- a/app-shells/bash/bash-9999.ebuild
+++ b/app-shells/bash/bash-9999.ebuild
@@ -130,6 +130,11 @@ src_unpack() {
else
if use verify-sig ; then
verify-sig_verify_detached "${DISTDIR}"/${MY_P}.tar.gz{,.sig}
+
+ local patch
+ for patch in "${MY_PATCHES[@]}" ; do
+ verify-sig_verify_detached ${patch}{,.sig}
+ done
fi
unpack ${MY_P}.tar.gz