summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-04-19 20:04:20 +0100
committerSam James <sam@gentoo.org>2022-04-19 20:04:20 +0100
commit74cb61be3fbf283a61a4d1bbd8467af4609ae1e0 (patch)
tree8a6a751dc8a2de54954904d076d84516d65f0cac /app-shells/bash
parentsys-libs/readline: add 9999 (diff)
downloadgentoo-74cb61be3fbf283a61a4d1bbd8467af4609ae1e0.tar.gz
gentoo-74cb61be3fbf283a61a4d1bbd8467af4609ae1e0.tar.bz2
gentoo-74cb61be3fbf283a61a4d1bbd8467af4609ae1e0.zip
app-shells/bash: sync 5.2_beta w/ live
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-shells/bash')
-rw-r--r--app-shells/bash/bash-5.2_beta.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/app-shells/bash/bash-5.2_beta.ebuild b/app-shells/bash/bash-5.2_beta.ebuild
index c5b8657f7f0d..c93d31e357b8 100644
--- a/app-shells/bash/bash-5.2_beta.ebuild
+++ b/app-shells/bash/bash-5.2_beta.ebuild
@@ -5,8 +5,6 @@ EAPI=7
# TODO on release:
# - check READLINE_VER, obviously
-# - remove autotools/eautoreconf from readline ebuild
-# - tidy up is_release check in this ebuild for using system readline
# (presumably there weren't always readline releases for bash RCs etc)
VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/chetramey.asc
@@ -20,8 +18,8 @@ MY_PV="${MY_PV/_/-}"
MY_P="${PN}-${MY_PV}"
is_release() {
case ${PV} in
- 9999|*_alpha*|*_beta*|*_rc*) return 1 ;;
- *) return 0 ;;
+ 9999|*_alpha*|*_beta*|*_rc*) return 1 ;;
+ *) return 0 ;;
esac
}
[[ ${PV} != *_p* ]] && PLEVEL=0
@@ -48,6 +46,7 @@ DESCRIPTION="The standard GNU Bourne again shell"
HOMEPAGE="https://tiswww.case.edu/php/chet/bash/bashtop.html"
if [[ ${PV} == 9999 ]] ; then
EGIT_REPO_URI="https://git.savannah.gnu.org/git/bash.git"
+ EGIT_BRANCH=devel
inherit git-r3
elif is_release ; then
SRC_URI="mirror://gnu/bash/${MY_P}.tar.gz $(patches)"