summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-05-13 15:55:08 +0200
committerDavid Seifert <soap@gentoo.org>2021-05-13 15:55:08 +0200
commit137cdb5311f615f0c72bab5d9304a38612239f49 (patch)
tree773e6926e05639eb7798a30d5e397c514982a01d /app-shells
parentapp-arch/unrar: drop unused flag-o-matic inherit (diff)
downloadgentoo-137cdb5311f615f0c72bab5d9304a38612239f49.tar.gz
gentoo-137cdb5311f615f0c72bab5d9304a38612239f49.tar.bz2
gentoo-137cdb5311f615f0c72bab5d9304a38612239f49.zip
app-shells/bash: drop unused multilib inherit, tidy up ebuild
* Drop unused multilib inherit * Move lost/orphaned ncurses comment to its rightful place * Normalise bug references * Add whitespace to aid readability Closes: https://github.com/gentoo/gentoo/pull/20538 Signed-off-by: Sam James <sam@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash/bash-2.05b_p13.ebuild26
-rw-r--r--app-shells/bash/bash-3.0_p22.ebuild34
-rw-r--r--app-shells/bash/bash-3.1_p23.ebuild26
-rw-r--r--app-shells/bash/bash-3.2_p57.ebuild28
-rw-r--r--app-shells/bash/bash-4.0_p44.ebuild26
-rw-r--r--app-shells/bash/bash-4.1_p17.ebuild25
-rw-r--r--app-shells/bash/bash-4.2_p53.ebuild22
-rw-r--r--app-shells/bash/bash-4.3_p48-r2.ebuild33
-rw-r--r--app-shells/bash/bash-4.4_p23-r2.ebuild35
-rw-r--r--app-shells/bash/bash-5.0_p18.ebuild39
-rw-r--r--app-shells/bash/bash-5.1_p4.ebuild39
-rw-r--r--app-shells/bash/bash-5.1_p8.ebuild41
12 files changed, 229 insertions, 145 deletions
diff --git a/app-shells/bash/bash-2.05b_p13.ebuild b/app-shells/bash/bash-2.05b_p13.ebuild
index cdacaa870073..5d27c8bf42fa 100644
--- a/app-shells/bash/bash-2.05b_p13.ebuild
+++ b/app-shells/bash/bash-2.05b_p13.ebuild
@@ -47,18 +47,19 @@ S="${WORKDIR}/${MY_P}"
PATCHES=(
"${FILESDIR}"/${PN}-2.05b-destdir.patch
- "${FILESDIR}"/autoconf-mktime-2.53.patch #220040
+ "${FILESDIR}"/autoconf-mktime-2.53.patch # bug #220040
"${FILESDIR}"/${PN}-2.05b-protos.patch
"${FILESDIR}"/${PN}-2.05b-empty-herestring.patch
- "${FILESDIR}"/${PN}-2.05b-rbash.patch #26854
- "${FILESDIR}"/${PN}-2.05b-parallel-build.patch #41002
+ "${FILESDIR}"/${PN}-2.05b-rbash.patch # bug #26854
+ "${FILESDIR}"/${PN}-2.05b-parallel-build.patch # bug #41002
"${FILESDIR}"/${PN}-2.05b-jobs.patch
"${FILESDIR}"/${PN}-2.05b-fix-job-warning.patch
- "${FILESDIR}"/${PN}-3.1-dev-fd-buffer-overflow.patch #431850
+ "${FILESDIR}"/${PN}-3.1-dev-fd-buffer-overflow.patch # bug #431850
)
pkg_setup() {
- if is-flag -malign-double ; then #7332
+ # bug #7332
+ if is-flag -malign-double ; then
eerror "Detected bad CFLAGS '-malign-double'. Do not use this"
eerror "as it breaks LFS (struct stat64) on x86."
die "remove -malign-double from your CFLAGS mr ricer"
@@ -84,7 +85,13 @@ src_prepare() {
src_configure() {
local myconf=(
--with-installed-readline=.
+
+ # Force linking with system curses ... the bundled termcap lib
+ # sucks bad compared to ncurses. For the most part, ncurses
+ # is here because readline needs it. But bash itself calls
+ # ncurses in one or two small places :(.
--with-curses
+
$(use_with afs)
$(use_enable net net-redirections)
--disable-profiling
@@ -121,16 +128,13 @@ src_configure() {
# is at least what's in the DEPEND up above.
export ac_cv_rl_version=6.2
- # Force linking with system curses ... the bundled termcap lib
- # sucks bad compared to ncurses. For the most part, ncurses
- # is here because readline needs it. But bash itself calls
- # ncurses in one or two small places :(.
+ # bug #444070
+ tc-export AR
- tc-export AR #444070
# This old autoconf script does not re-exec itself properly and fails when
# /bin/sh is not bash. Rather than try to regen everything, just force the
# use of bash directly.
- CONFIG_SHELL="/bin/bash" econf "${myconf[@]}"
+ CONFIG_SHELL="${BROOT}/bin/bash" econf "${myconf[@]}"
}
src_install() {
diff --git a/app-shells/bash/bash-3.0_p22.ebuild b/app-shells/bash/bash-3.0_p22.ebuild
index 9cb8f4f7c86e..1b23a376b371 100644
--- a/app-shells/bash/bash-3.0_p22.ebuild
+++ b/app-shells/bash/bash-3.0_p22.ebuild
@@ -46,22 +46,25 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MY_P}"
PATCHES=(
- "${FILESDIR}"/autoconf-mktime-2.53.patch #220040
+ "${FILESDIR}"/autoconf-mktime-2.53.patch
"${FILESDIR}"/${PN}-3.0-protos.patch
- "${FILESDIR}"/${PN}-3.0-rbash.patch #26854
- "${FILESDIR}"/${PN}-2.05b-parallel-build.patch #41002
- "${FILESDIR}"/${PN}-3.0-darwin-conn.patch #79124
- # read patch headers for more info ... many ripped from Fedora/Debian[17]/SuSe/upstream
+ "${FILESDIR}"/${PN}-3.0-rbash.patch # bug #26854
+ "${FILESDIR}"/${PN}-2.05b-parallel-build.patch # bug #41002
+ "${FILESDIR}"/${PN}-3.0-darwin-conn.patch # bug #79124
+
+ # Read patch headers for more info ... many ripped from Fedora/Debian[17]/SuSe/upstream
"${FILESDIR}"/${PN}-3.0-{afs,crash,jobs,manpage,pwd,ulimit,histtimeformat,locale,multibyteifs,subshell,volatile-command}.patch
- "${FILESDIR}"/${PN}-3.0-read-builtin-pipe.patch #87093
+
+ "${FILESDIR}"/${PN}-3.0-read-builtin-pipe.patch # bug #87093
"${FILESDIR}"/${PN}-3.0-trap-fg-signals.patch
- "${FILESDIR}"/${PN}-3.0-pgrp-pipe-fix.patch #92349
+ "${FILESDIR}"/${PN}-3.0-pgrp-pipe-fix.patch # bug #92349
"${FILESDIR}"/${PN}-3.0-strnlen.patch
- "${FILESDIR}"/${PN}-3.1-dev-fd-buffer-overflow.patch #431850
+ "${FILESDIR}"/${PN}-3.1-dev-fd-buffer-overflow.patch # bug #431850
)
pkg_setup() {
- if is-flag -malign-double ; then #7332
+ # bug #7332
+ if is-flag -malign-double ; then
eerror "Detected bad CFLAGS '-malign-double'. Do not use this"
eerror "as it breaks LFS (struct stat64) on x86."
die "remove -malign-double from your CFLAGS mr ricer"
@@ -87,7 +90,13 @@ src_prepare() {
src_configure() {
local myconf=(
--with-installed-readline=.
+
+ # Force linking with system curses ... the bundled termcap lib
+ # sucks bad compared to ncurses. For the most part, ncurses
+ # is here because readline needs it. But bash itself calls
+ # ncurses in one or two small places :(.
--with-curses
+
$(use_with afs)
$(use_enable net net-redirections)
--disable-profiling
@@ -124,12 +133,9 @@ src_configure() {
# is at least what's in the DEPEND up above.
export ac_cv_rl_version=6.2
- # Force linking with system curses ... the bundled termcap lib
- # sucks bad compared to ncurses. For the most part, ncurses
- # is here because readline needs it. But bash itself calls
- # ncurses in one or two small places :(.
+ # bug #444070
+ tc-export AR
- tc-export AR #444070
econf "${myconf[@]}"
}
diff --git a/app-shells/bash/bash-3.1_p23.ebuild b/app-shells/bash/bash-3.1_p23.ebuild
index 1b7c72acdbfd..dc0a34675c7b 100644
--- a/app-shells/bash/bash-3.1_p23.ebuild
+++ b/app-shells/bash/bash-3.1_p23.ebuild
@@ -46,19 +46,20 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MY_P}"
PATCHES=(
- "${FILESDIR}"/autoconf-mktime-2.53.patch #220040
- "${FILESDIR}"/${PN}-2.05b-parallel-build.patch #41002
+ "${FILESDIR}"/autoconf-mktime-2.53.patch # bug #220040
+ "${FILESDIR}"/${PN}-2.05b-parallel-build.patch # bug #41002
"${FILESDIR}"/${PN}-3.1-protos.patch
"${FILESDIR}"/${PN}-3.1-ulimit.patch
"${FILESDIR}"/${PN}-3.0-read-memleak.patch
"${FILESDIR}"/${PN}-3.0-trap-fg-signals.patch
- "${FILESDIR}"/${PN}-3.1-fix-dash-login-shell.patch #118257
- "${FILESDIR}"/${PN}-3.1-dev-fd-test-as-user.patch #131875
- "${FILESDIR}"/${PN}-3.1-dev-fd-buffer-overflow.patch #431850
+ "${FILESDIR}"/${PN}-3.1-fix-dash-login-shell.patch # bug #118257
+ "${FILESDIR}"/${PN}-3.1-dev-fd-test-as-user.patch # bug #131875
+ "${FILESDIR}"/${PN}-3.1-dev-fd-buffer-overflow.patch # bug #431850
)
pkg_setup() {
- if is-flag -malign-double ; then #7332
+ # bug #7332
+ if is-flag -malign-double ; then
eerror "Detected bad CFLAGS '-malign-double'. Do not use this"
eerror "as it breaks LFS (struct stat64) on x86."
die "remove -malign-double from your CFLAGS mr ricer"
@@ -84,7 +85,13 @@ src_prepare() {
src_configure() {
local myconf=(
--with-installed-readline=.
+
+ # Force linking with system curses ... the bundled termcap lib
+ # sucks bad compared to ncurses. For the most part, ncurses
+ # is here because readline needs it. But bash itself calls
+ # ncurses in one or two small places :(.
--with-curses
+
$(use_with afs)
$(use_enable net net-redirections)
--disable-profiling
@@ -121,12 +128,9 @@ src_configure() {
# is at least what's in the DEPEND up above.
export ac_cv_rl_version=6.2
- # Force linking with system curses ... the bundled termcap lib
- # sucks bad compared to ncurses. For the most part, ncurses
- # is here because readline needs it. But bash itself calls
- # ncurses in one or two small places :(.
+ # bug #444070
+ tc-export AR
- tc-export AR #444070
econf "${myconf[@]}"
}
diff --git a/app-shells/bash/bash-3.2_p57.ebuild b/app-shells/bash/bash-3.2_p57.ebuild
index be7420d869e7..b1de2bcaee50 100644
--- a/app-shells/bash/bash-3.2_p57.ebuild
+++ b/app-shells/bash/bash-3.2_p57.ebuild
@@ -46,21 +46,22 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MY_P}"
PATCHES=(
- "${FILESDIR}"/autoconf-mktime-2.59.patch #220040
+ "${FILESDIR}"/autoconf-mktime-2.59.patch # bug #220040
"${FILESDIR}"/${PN}-3.2-loadables.patch
- "${FILESDIR}"/${PN}-2.05b-parallel-build.patch #41002
+ "${FILESDIR}"/${PN}-2.05b-parallel-build.patch # bug #41002
"${FILESDIR}"/${PN}-3.2-protos.patch
- "${FILESDIR}"/${PN}-3.2-session-leader.patch #231775
- "${FILESDIR}"/${PN}-3.2-ldflags-for-build.patch #211947
+ "${FILESDIR}"/${PN}-3.2-session-leader.patch # bug #231775
+ "${FILESDIR}"/${PN}-3.2-ldflags-for-build.patch # bug #211947
"${FILESDIR}"/${PN}-3.2-process-subst.patch
"${FILESDIR}"/${PN}-3.2-ulimit.patch
"${FILESDIR}"/${PN}-3.0-trap-fg-signals.patch
- "${FILESDIR}"/${PN}-3.2-dev-fd-test-as-user.patch #131875
- "${FILESDIR}"/${PN}-4.2-dev-fd-buffer-overflow.patch #431850
+ "${FILESDIR}"/${PN}-3.2-dev-fd-test-as-user.patch # bug #131875
+ "${FILESDIR}"/${PN}-4.2-dev-fd-buffer-overflow.patch # bug #431850
)
pkg_setup() {
- if is-flag -malign-double ; then #7332
+ # bug #7332
+ if is-flag -malign-double ; then
eerror "Detected bad CFLAGS '-malign-double'. Do not use this"
eerror "as it breaks LFS (struct stat64) on x86."
die "remove -malign-double from your CFLAGS mr ricer"
@@ -86,7 +87,13 @@ src_prepare() {
src_configure() {
local myconf=(
--with-installed-readline=.
+
+ # Force linking with system curses ... the bundled termcap lib
+ # sucks bad compared to ncurses. For the most part, ncurses
+ # is here because readline needs it. But bash itself calls
+ # ncurses in one or two small places :(.
--with-curses
+
$(use_with afs)
$(use_enable net net-redirections)
--disable-profiling
@@ -123,12 +130,9 @@ src_configure() {
# is at least what's in the DEPEND up above.
export ac_cv_rl_version=6.2
- # Force linking with system curses ... the bundled termcap lib
- # sucks bad compared to ncurses. For the most part, ncurses
- # is here because readline needs it. But bash itself calls
- # ncurses in one or two small places :(.
+ # bug #444070
+ tc-export AR
- tc-export AR #444070
econf "${myconf[@]}"
}
diff --git a/app-shells/bash/bash-4.0_p44.ebuild b/app-shells/bash/bash-4.0_p44.ebuild
index 2814366f9f94..c66b53fb1d0c 100644
--- a/app-shells/bash/bash-4.0_p44.ebuild
+++ b/app-shells/bash/bash-4.0_p44.ebuild
@@ -46,18 +46,19 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MY_P}"
PATCHES=(
- "${FILESDIR}"/${PN}-4.0-configure.patch #304901
+ "${FILESDIR}"/${PN}-4.0-configure.patch # bug #304901
"${FILESDIR}"/${PN}-4.x-deferred-heredocs.patch
- "${FILESDIR}"/${PN}-2.05b-parallel-build.patch #41002
- "${FILESDIR}"/${PN}-4.0-ldflags-for-build.patch #211947
+ "${FILESDIR}"/${PN}-2.05b-parallel-build.patch # bug #41002
+ "${FILESDIR}"/${PN}-4.0-ldflags-for-build.patch # bug #211947
"${FILESDIR}"/${PN}-4.0-negative-return.patch
- "${FILESDIR}"/${PN}-4.0-parallel-build.patch #267613
+ "${FILESDIR}"/${PN}-4.0-parallel-build.patch # bug #267613
"${FILESDIR}"/${PN}-4.2-dev-fd-buffer-overflow.patch #431850
)
pkg_setup() {
- if is-flag -malign-double ; then #7332
+ # bug #7332
+ if is-flag -malign-double ; then
eerror "Detected bad CFLAGS '-malign-double'. Do not use this"
eerror "as it breaks LFS (struct stat64) on x86."
die "remove -malign-double from your CFLAGS mr ricer"
@@ -80,13 +81,19 @@ src_prepare() {
default
sed -i '1i#define NEED_FPURGE_DECL' execute_cmd.c || die # needs fpurge() decl
- sed -i '/\.o: .*shell\.h/s:$: pathnames.h:' Makefile.in || die #267613
+ sed -i '/\.o: .*shell\.h/s:$: pathnames.h:' Makefile.in || die # bug #267613
}
src_configure() {
local myconf=(
--with-installed-readline=.
+
+ # Force linking with system curses ... the bundled termcap lib
+ # sucks bad compared to ncurses. For the most part, ncurses
+ # is here because readline needs it. But bash itself calls
+ # ncurses in one or two small places :(.
--with-curses
+
$(use_with afs)
$(use_enable net net-redirections)
--disable-profiling
@@ -120,12 +127,9 @@ src_configure() {
# is at least what's in the DEPEND up above.
export ac_cv_rl_version=6.2
- # Force linking with system curses ... the bundled termcap lib
- # sucks bad compared to ncurses. For the most part, ncurses
- # is here because readline needs it. But bash itself calls
- # ncurses in one or two small places :(.
+ # bug #444070
+ tc-export AR
- tc-export AR #444070
econf "${myconf[@]}"
}
diff --git a/app-shells/bash/bash-4.1_p17.ebuild b/app-shells/bash/bash-4.1_p17.ebuild
index da915e1f0dd5..7ae8ac6934df 100644
--- a/app-shells/bash/bash-4.1_p17.ebuild
+++ b/app-shells/bash/bash-4.1_p17.ebuild
@@ -46,14 +46,15 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MY_P}"
PATCHES=(
- "${FILESDIR}"/${PN}-4.1-fbsd-eaccess.patch #303411
+ "${FILESDIR}"/${PN}-4.1-fbsd-eaccess.patch #bug #303411
"${FILESDIR}"/${PN}-4.1-parallel-build.patch
- "${FILESDIR}"/${PN}-4.2-dev-fd-buffer-overflow.patch #431850
+ "${FILESDIR}"/${PN}-4.2-dev-fd-buffer-overflow.patch #bug #431850
)
pkg_setup() {
- if is-flag -malign-double ; then #7332
+ # bug #7332
+ if is-flag -malign-double ; then
eerror "Detected bad CFLAGS '-malign-double'. Do not use this"
eerror "as it breaks LFS (struct stat64) on x86."
die "remove -malign-double from your CFLAGS mr ricer"
@@ -81,7 +82,16 @@ src_prepare() {
src_configure() {
local myconf=(
--with-installed-readline=.
+
+ # Force linking with system curses ... the bundled termcap lib
+ # sucks bad compared to ncurses. For the most part, ncurses
+ # is here because readline needs it. But bash itself calls
+ # ncurses in one or two small places :(.
--with-curses
+
+ # bug #335896
+ --without-lispdir
+
$(use_with afs)
$(use_enable net net-redirections)
--disable-profiling
@@ -92,8 +102,6 @@ src_configure() {
$(use_enable readline bang-history)
)
- myconf+=( --without-lispdir ) #335896
-
# For descriptions of these, see config-top.h
# bashrc/#26952 bash_logout/#90488 ssh/#24762 mktemp/#574426
append-cppflags \
@@ -117,12 +125,9 @@ src_configure() {
# is at least what's in the DEPEND up above.
export ac_cv_rl_version=6.2
- # Force linking with system curses ... the bundled termcap lib
- # sucks bad compared to ncurses. For the most part, ncurses
- # is here because readline needs it. But bash itself calls
- # ncurses in one or two small places :(.
+ # bug #444070
+ tc-export AR
- tc-export AR #444070
econf "${myconf[@]}"
}
diff --git a/app-shells/bash/bash-4.2_p53.ebuild b/app-shells/bash/bash-4.2_p53.ebuild
index 30c860c3ff58..44b74704aa85 100644
--- a/app-shells/bash/bash-4.2_p53.ebuild
+++ b/app-shells/bash/bash-4.2_p53.ebuild
@@ -42,21 +42,22 @@ LIB_DEPEND=">=sys-libs/ncurses-5.2-r2[static-libs(+)]
RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
DEPEND="${RDEPEND}
static? ( ${LIB_DEPEND} )"
-# we only need yacc when the .y files get patched (bash42-005)
+# We only need yacc when the .y files get patched (bash42-005)
BDEPEND="virtual/yacc"
S="${WORKDIR}/${MY_P}"
PATCHES=(
- "${FILESDIR}"/${PN}-4.2-execute-job-control.patch #383237
+ "${FILESDIR}"/${PN}-4.2-execute-job-control.patch # bug #383237
"${FILESDIR}"/${PN}-4.2-parallel-build.patch
"${FILESDIR}"/${PN}-4.2-no-readline.patch
- "${FILESDIR}"/${PN}-4.2-read-retry.patch #447810
+ "${FILESDIR}"/${PN}-4.2-read-retry.patch # bug #447810
"${FILESDIR}"/${PN}-4.2-speed-up-read-N.patch
)
pkg_setup() {
- if is-flag -malign-double ; then #7332
+ # bug #7332
+ if is-flag -malign-double ; then
eerror "Detected bad CFLAGS '-malign-double'. Do not use this"
eerror "as it breaks LFS (struct stat64) on x86."
die "remove -malign-double from your CFLAGS mr ricer"
@@ -86,7 +87,13 @@ src_prepare() {
src_configure() {
local myconf=(
--with-installed-readline=.
+
+ # Force linking with system curses ... the bundled termcap lib
+ # sucks bad compared to ncurses. For the most part, ncurses
+ # is here because readline needs it. But bash itself calls
+ # ncurses in one or two small places :(.
--with-curses
+
$(use_with afs)
$(use_enable net net-redirections)
--disable-profiling
@@ -120,12 +127,9 @@ src_configure() {
# is at least what's in the DEPEND up above.
export ac_cv_rl_version=6.2
- # Force linking with system curses ... the bundled termcap lib
- # sucks bad compared to ncurses. For the most part, ncurses
- # is here because readline needs it. But bash itself calls
- # ncurses in one or two small places :(.
+ # bug #444070
+ tc-export AR
- tc-export AR #444070
econf "${myconf[@]}"
}
diff --git a/app-shells/bash/bash-4.3_p48-r2.ebuild b/app-shells/bash/bash-4.3_p48-r2.ebuild
index 14f08b6aed1d..d013a6fda2ae 100644
--- a/app-shells/bash/bash-4.3_p48-r2.ebuild
+++ b/app-shells/bash/bash-4.3_p48-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit flag-o-matic toolchain-funcs multilib
+inherit flag-o-matic toolchain-funcs
# Official patchlevel
# See ftp://ftp.cwru.edu/pub/bash/bash-4.3-patches/
@@ -45,24 +45,26 @@ DEPEND=">=sys-libs/ncurses-5.2-r2:0=
nls? ( virtual/libintl )"
RDEPEND="${DEPEND}
!<sys-apps/portage-2.1.6.7_p1"
-# we only need yacc when the .y files get patched (bash42-005)
+# We only need yacc when the .y files get patched (bash42-005)
BDEPEND="virtual/yacc"
PATCHES=(
"${FILESDIR}"/${PN}-4.3-mapfile-improper-array-name-validation.patch
"${FILESDIR}"/${PN}-4.3-arrayfunc.patch
"${FILESDIR}"/${PN}-4.3-protos.patch
- "${FILESDIR}"/${PN}-4.4-popd-offset-overflow.patch #600174
+ "${FILESDIR}"/${PN}-4.4-popd-offset-overflow.patch # bug #600174
)
S="${WORKDIR}/${MY_P}"
pkg_setup() {
- if is-flag -malign-double ; then #7332
+ # bug #7332
+ if is-flag -malign-double ; then
eerror "Detected bad CFLAGS '-malign-double'. Do not use this"
eerror "as it breaks LFS (struct stat64) on x86."
die "remove -malign-double from your CFLAGS mr ricer"
fi
+
if use bashlogger ; then
ewarn "The logging patch should ONLY be used in restricted (i.e. honeypot) envs."
ewarn "This will log ALL output you enter into the shell, you have been warned."
@@ -84,7 +86,7 @@ src_prepare() {
sed -ri -e 's:\$[{(](RL|HIST)_LIBSRC[)}]/[[:alpha:]_-]*\.h::g' Makefile.in || die
fi
- # Avoid regenerating docs after patches #407985
+ # Avoid regenerating docs after patches, bug #407985
sed -i -r '/^(HS|RL)USER/s:=.*:=:' doc/Makefile.in || die
touch -r . doc/* || die
@@ -95,7 +97,13 @@ src_configure() {
local myconf=(
--docdir='$(datarootdir)'/doc/${PF}
--htmldir='$(docdir)/html'
+
+ # Force linking with system curses ... the bundled termcap lib
+ # sucks bad compared to ncurses. For the most part, ncurses
+ # is here because readline needs it. But bash itself calls
+ # ncurses in one or two small places :(.
--with-curses
+
$(use_with afs)
$(use_enable net net-redirections)
--disable-profiling
@@ -119,7 +127,7 @@ src_configure() {
$(use bashlogger && echo -DSYSLOG_HISTORY)
# Don't even think about building this statically without
- # reading Bug 7714 first. If you still build it statically,
+ # reading bug #7714 first. If you still build it statically,
# don't come crying to us with bugs ;).
#use static && export LDFLAGS="${LDFLAGS} -static"
use nls || myconf+=( --disable-nls )
@@ -133,28 +141,27 @@ src_configure() {
# is at least what's in the DEPEND up above.
export ac_cv_rl_version=${READLINE_VER}
- # Force linking with system curses ... the bundled termcap lib
- # sucks bad compared to ncurses. For the most part, ncurses
- # is here because readline needs it. But bash itself calls
- # ncurses in one or two small places :(.
-
if [[ ${PV} != *_rc* ]] ; then
# Use system readline only with released versions.
myconf+=( --with-installed-readline=. )
fi
- if use plugins; then
+ if use plugins ; then
append-ldflags -Wl,-rpath,/usr/$(get_libdir)/bash
else
# Disable the plugins logic by hand since bash doesn't
# provide a way of doing it.
export ac_cv_func_dl{close,open,sym}=no \
ac_cv_lib_dl_dlopen=no ac_cv_header_dlfcn_h=no
+
sed -i \
-e '/LOCAL_LDFLAGS=/s:-rdynamic::' \
configure || die
fi
- tc-export AR #444070
+
+ # bug #444070
+ tc-export AR
+
econf "${myconf[@]}"
}
diff --git a/app-shells/bash/bash-4.4_p23-r2.ebuild b/app-shells/bash/bash-4.4_p23-r2.ebuild
index 3badc1359f27..d7671fb9e0cb 100644
--- a/app-shells/bash/bash-4.4_p23-r2.ebuild
+++ b/app-shells/bash/bash-4.4_p23-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit flag-o-matic toolchain-funcs multilib prefix
+inherit flag-o-matic toolchain-funcs prefix
# Official patchlevel
# See ftp://ftp.cwru.edu/pub/bash/bash-4.4-patches/
@@ -57,17 +57,19 @@ DEPEND="
RDEPEND="
${DEPEND}
"
-# we only need yacc when the .y files get patched (bash42-005)
+# We only need yacc when the .y files get patched (bash42-005)
#BDEPEND="virtual/yacc"
S="${WORKDIR}/${MY_P}"
pkg_setup() {
- if is-flag -malign-double ; then #7332
+ # bug #7332
+ if is-flag -malign-double ; then
eerror "Detected bad CFLAGS '-malign-double'. Do not use this"
eerror "as it breaks LFS (struct stat64) on x86."
die "remove -malign-double from your CFLAGS mr ricer"
fi
+
if use bashlogger ; then
ewarn "The logging patch should ONLY be used in restricted (i.e. honeypot) envs."
ewarn "This will log ALL output you enter into the shell, you have been warned."
@@ -82,8 +84,8 @@ src_prepare() {
# Include official patches
[[ ${PLEVEL} -gt 0 ]] && eapply -p0 $(patches -s)
- eapply "${FILESDIR}/${PN}-4.4-jobs_overflow.patch" #644720
- eapply "${FILESDIR}/${PN}-4.4-set-SHOBJ_STATUS.patch" #644720
+ eapply "${FILESDIR}/${PN}-4.4-jobs_overflow.patch" # bug #644720
+ eapply "${FILESDIR}/${PN}-4.4-set-SHOBJ_STATUS.patch" # bug #644720
# Clean out local libs so we know we use system ones w/releases.
if is_release ; then
@@ -95,7 +97,7 @@ src_prepare() {
# Prefixify hardcoded path names. No-op for non-prefix.
hprefixify pathnames.h.in
- # Avoid regenerating docs after patches #407985
+ # Avoid regenerating docs after patches, bug #407985
sed -i -r '/^(HS|RL)USER/s:=.*:=:' doc/Makefile.in || die
touch -r . doc/* || die
@@ -105,7 +107,13 @@ src_prepare() {
src_configure() {
local myconf=(
--disable-profiling
+
+ # Force linking with system curses ... the bundled termcap lib
+ # sucks bad compared to ncurses. For the most part, ncurses
+ # is here because readline needs it. But bash itself calls
+ # ncurses in one or two small places :(.
--with-curses
+
$(use_enable mem-scramble)
$(use_enable net net-redirections)
$(use_enable readline)
@@ -127,7 +135,7 @@ src_configure() {
$(use bashlogger && echo -DSYSLOG_HISTORY)
# Don't even think about building this statically without
- # reading Bug 7714 first. If you still build it statically,
+ # reading bug #7714 first. If you still build it statically,
# don't come crying to us with bugs ;).
#use static && export LDFLAGS="${LDFLAGS} -static"
use nls || myconf+=( --disable-nls )
@@ -141,28 +149,27 @@ src_configure() {
# is at least what's in the DEPEND up above.
export ac_cv_rl_version=${READLINE_VER%%_*}
- # Force linking with system curses ... the bundled termcap lib
- # sucks bad compared to ncurses. For the most part, ncurses
- # is here because readline needs it. But bash itself calls
- # ncurses in one or two small places :(.
-
if is_release ; then
# Use system readline only with released versions.
myconf+=( --with-installed-readline=. )
fi
- if use plugins; then
+ if use plugins ; then
append-ldflags -Wl,-rpath,/usr/$(get_libdir)/bash
else
# Disable the plugins logic by hand since bash doesn't
# provide a way of doing it.
export ac_cv_func_dl{close,open,sym}=no \
ac_cv_lib_dl_dlopen=no ac_cv_header_dlfcn_h=no
+
sed -i \
-e '/LOCAL_LDFLAGS=/s:-rdynamic::' \
configure || die
fi
- tc-export AR #444070
+
+ # bug #444070
+ tc-export AR
+
econf "${myconf[@]}"
}
diff --git a/app-shells/bash/bash-5.0_p18.ebuild b/app-shells/bash/bash-5.0_p18.ebuild
index 80582cbf2ae4..3ea29fe66b10 100644
--- a/app-shells/bash/bash-5.0_p18.ebuild
+++ b/app-shells/bash/bash-5.0_p18.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit flag-o-matic toolchain-funcs multilib prefix
+inherit flag-o-matic toolchain-funcs prefix
# Official patchlevel
# See ftp://ftp.cwru.edu/pub/bash/bash-5.0-patches/
@@ -57,7 +57,7 @@ DEPEND="
RDEPEND="
${DEPEND}
"
-# we only need yacc when the .y files get patched (bash42-005)
+# We only need yacc when the .y files get patched (bash42-005)
#BDEPEND="virtual/yacc"
S="${WORKDIR}/${MY_P}"
@@ -69,11 +69,13 @@ PATCHES=(
)
pkg_setup() {
- if is-flag -malign-double ; then #7332
+ # bug #7332
+ if is-flag -malign-double ; then
eerror "Detected bad CFLAGS '-malign-double'. Do not use this"
eerror "as it breaks LFS (struct stat64) on x86."
die "remove -malign-double from your CFLAGS mr ricer"
fi
+
if use bashlogger ; then
ewarn "The logging patch should ONLY be used in restricted (i.e. honeypot) envs."
ewarn "This will log ALL output you enter into the shell, you have been warned."
@@ -98,7 +100,7 @@ src_prepare() {
# Prefixify hardcoded path names. No-op for non-prefix.
hprefixify pathnames.h.in
- # Avoid regenerating docs after patches #407985
+ # Avoid regenerating docs after patches, bug #407985
sed -i -r '/^(HS|RL)USER/s:=.*:=:' doc/Makefile.in || die
touch -r . doc/* || die
@@ -109,7 +111,13 @@ src_prepare() {
src_configure() {
local myconf=(
--disable-profiling
+
+ # Force linking with system curses ... the bundled termcap lib
+ # sucks bad compared to ncurses. For the most part, ncurses
+ # is here because readline needs it. But bash itself calls
+ # ncurses in one or two small places :(.
--with-curses
+
$(use_enable mem-scramble)
$(use_enable net net-redirections)
$(use_enable readline)
@@ -131,7 +139,7 @@ src_configure() {
$(use bashlogger && echo -DSYSLOG_HISTORY)
# Don't even think about building this statically without
- # reading Bug 7714 first. If you still build it statically,
+ # reading bug #7714 first. If you still build it statically,
# don't come crying to us with bugs ;).
#use static && export LDFLAGS="${LDFLAGS} -static"
use nls || myconf+=( --disable-nls )
@@ -145,28 +153,27 @@ src_configure() {
# is at least what's in the DEPEND up above.
export ac_cv_rl_version=${READLINE_VER%%_*}
- # Force linking with system curses ... the bundled termcap lib
- # sucks bad compared to ncurses. For the most part, ncurses
- # is here because readline needs it. But bash itself calls
- # ncurses in one or two small places :(.
-
if is_release ; then
# Use system readline only with released versions.
myconf+=( --with-installed-readline=. )
fi
- if use plugins; then
+ if use plugins ; then
append-ldflags -Wl,-rpath,/usr/$(get_libdir)/bash
else
# Disable the plugins logic by hand since bash doesn't
# provide a way of doing it.
export ac_cv_func_dl{close,open,sym}=no \
ac_cv_lib_dl_dlopen=no ac_cv_header_dlfcn_h=no
+
sed -i \
-e '/LOCAL_LDFLAGS=/s:-rdynamic::' \
configure || die
fi
- tc-export AR #444070
+
+ # bug #444070
+ tc-export AR
+
econf "${myconf[@]}"
}
@@ -190,7 +197,9 @@ src_install() {
insinto /etc/bash
doins "${FILESDIR}"/bash_logout
doins "$(prefixify_ro "${FILESDIR}"/bashrc)"
+
keepdir /etc/bash/bashrc.d
+
insinto /etc/skel
for f in bash{_logout,_profile,rc} ; do
newins "${FILESDIR}"/dot-${f} .${f}
@@ -200,12 +209,15 @@ src_install() {
-e "s:#${USERLAND}#@::"
-e '/#@/d'
)
+
if ! use readline ; then
- sed_args+=( #432338
+ # bug #432338
+ sed_args+=(
-e '/^shopt -s histappend/s:^:#:'
-e 's:use_color=true:use_color=false:'
)
fi
+
sed -i \
"${sed_args[@]}" \
"${ED}"/etc/skel/.bashrc \
@@ -214,6 +226,7 @@ src_install() {
if use plugins ; then
exeinto /usr/$(get_libdir)/bash
doexe $(echo examples/loadables/*.o | sed 's:\.o::g')
+
insinto /usr/include/bash-plugins
doins *.h builtins/*.h include/*.h lib/{glob/glob.h,tilde/tilde.h}
fi
diff --git a/app-shells/bash/bash-5.1_p4.ebuild b/app-shells/bash/bash-5.1_p4.ebuild
index d3193239c760..127eaee6e722 100644
--- a/app-shells/bash/bash-5.1_p4.ebuild
+++ b/app-shells/bash/bash-5.1_p4.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit flag-o-matic toolchain-funcs multilib prefix
+inherit flag-o-matic toolchain-funcs prefix
# Official patchlevel
# See ftp://ftp.cwru.edu/pub/bash/bash-5.0-patches/
@@ -58,7 +58,7 @@ DEPEND="
RDEPEND="
${DEPEND}
"
-# we only need yacc when the .y files get patched (bash42-005)
+# We only need yacc when the .y files get patched (bash42-005)
#BDEPEND="virtual/yacc"
S="${WORKDIR}/${MY_P}"
@@ -69,11 +69,13 @@ PATCHES=(
)
pkg_setup() {
- if is-flag -malign-double ; then #7332
+ # bug #7332
+ if is-flag -malign-double ; then
eerror "Detected bad CFLAGS '-malign-double'. Do not use this"
eerror "as it breaks LFS (struct stat64) on x86."
die "remove -malign-double from your CFLAGS mr ricer"
fi
+
if use bashlogger ; then
ewarn "The logging patch should ONLY be used in restricted (i.e. honeypot) envs."
ewarn "This will log ALL output you enter into the shell, you have been warned."
@@ -98,7 +100,7 @@ src_prepare() {
# Prefixify hardcoded path names. No-op for non-prefix.
hprefixify pathnames.h.in
- # Avoid regenerating docs after patches #407985
+ # Avoid regenerating docs after patches, bug #407985
sed -i -r '/^(HS|RL)USER/s:=.*:=:' doc/Makefile.in || die
touch -r . doc/* || die
@@ -109,7 +111,13 @@ src_prepare() {
src_configure() {
local myconf=(
--disable-profiling
+
+ # Force linking with system curses ... the bundled termcap lib
+ # sucks bad compared to ncurses. For the most part, ncurses
+ # is here because readline needs it. But bash itself calls
+ # ncurses in one or two small places :(.
--with-curses
+
$(use_enable mem-scramble)
$(use_enable net net-redirections)
$(use_enable readline)
@@ -131,7 +139,7 @@ src_configure() {
$(use bashlogger && echo -DSYSLOG_HISTORY)
# Don't even think about building this statically without
- # reading Bug 7714 first. If you still build it statically,
+ # reading bug #7714 first. If you still build it statically,
# don't come crying to us with bugs ;).
#use static && export LDFLAGS="${LDFLAGS} -static"
use nls || myconf+=( --disable-nls )
@@ -145,28 +153,27 @@ src_configure() {
# is at least what's in the DEPEND up above.
export ac_cv_rl_version=${READLINE_VER%%_*}
- # Force linking with system curses ... the bundled termcap lib
- # sucks bad compared to ncurses. For the most part, ncurses
- # is here because readline needs it. But bash itself calls
- # ncurses in one or two small places :(.
-
if is_release ; then
# Use system readline only with released versions.
myconf+=( --with-installed-readline=. )
fi
- if use plugins; then
+ if use plugins ; then
append-ldflags -Wl,-rpath,/usr/$(get_libdir)/bash
else
# Disable the plugins logic by hand since bash doesn't
# provide a way of doing it.
export ac_cv_func_dl{close,open,sym}=no \
ac_cv_lib_dl_dlopen=no ac_cv_header_dlfcn_h=no
+
sed -i \
-e '/LOCAL_LDFLAGS=/s:-rdynamic::' \
configure || die
fi
- tc-export AR #444070
+
+ # bug #444070
+ tc-export AR
+
econf "${myconf[@]}"
}
@@ -190,7 +197,9 @@ src_install() {
insinto /etc/bash
doins "${FILESDIR}"/bash_logout
doins "$(prefixify_ro "${FILESDIR}"/bashrc)"
+
keepdir /etc/bash/bashrc.d
+
insinto /etc/skel
for f in bash{_logout,_profile,rc} ; do
newins "${FILESDIR}"/dot-${f} .${f}
@@ -200,12 +209,15 @@ src_install() {
-e "s:#${USERLAND}#@::"
-e '/#@/d'
)
+
if ! use readline ; then
- sed_args+=( #432338
+ # bug #432338
+ sed_args+=(
-e '/^shopt -s histappend/s:^:#:'
-e 's:use_color=true:use_color=false:'
)
fi
+
sed -i \
"${sed_args[@]}" \
"${ED}"/etc/skel/.bashrc \
@@ -214,6 +226,7 @@ src_install() {
if use plugins ; then
exeinto /usr/$(get_libdir)/bash
doexe $(echo examples/loadables/*.o | sed 's:\.o::g')
+
insinto /usr/include/bash-plugins
doins *.h builtins/*.h include/*.h lib/{glob/glob.h,tilde/tilde.h}
fi
diff --git a/app-shells/bash/bash-5.1_p8.ebuild b/app-shells/bash/bash-5.1_p8.ebuild
index d3193239c760..7f04890a179a 100644
--- a/app-shells/bash/bash-5.1_p8.ebuild
+++ b/app-shells/bash/bash-5.1_p8.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit flag-o-matic toolchain-funcs multilib prefix
+inherit flag-o-matic toolchain-funcs prefix
# Official patchlevel
# See ftp://ftp.cwru.edu/pub/bash/bash-5.0-patches/
@@ -58,7 +58,7 @@ DEPEND="
RDEPEND="
${DEPEND}
"
-# we only need yacc when the .y files get patched (bash42-005)
+# We only need yacc when the .y files get patched (bash42-005)
#BDEPEND="virtual/yacc"
S="${WORKDIR}/${MY_P}"
@@ -69,11 +69,13 @@ PATCHES=(
)
pkg_setup() {
- if is-flag -malign-double ; then #7332
+ # bug #7332
+ if is-flag -malign-double ; then
eerror "Detected bad CFLAGS '-malign-double'. Do not use this"
eerror "as it breaks LFS (struct stat64) on x86."
die "remove -malign-double from your CFLAGS mr ricer"
fi
+
if use bashlogger ; then
ewarn "The logging patch should ONLY be used in restricted (i.e. honeypot) envs."
ewarn "This will log ALL output you enter into the shell, you have been warned."
@@ -98,7 +100,7 @@ src_prepare() {
# Prefixify hardcoded path names. No-op for non-prefix.
hprefixify pathnames.h.in
- # Avoid regenerating docs after patches #407985
+ # Avoid regenerating docs after patches, bug #407985
sed -i -r '/^(HS|RL)USER/s:=.*:=:' doc/Makefile.in || die
touch -r . doc/* || die
@@ -109,7 +111,13 @@ src_prepare() {
src_configure() {
local myconf=(
--disable-profiling
+
+ # Force linking with system curses ... the bundled termcap lib
+ # sucks bad compared to ncurses. For the most part, ncurses
+ # is here because readline needs it. But bash itself calls
+ # ncurses in one or two small places :(.
--with-curses
+
$(use_enable mem-scramble)
$(use_enable net net-redirections)
$(use_enable readline)
@@ -131,7 +139,7 @@ src_configure() {
$(use bashlogger && echo -DSYSLOG_HISTORY)
# Don't even think about building this statically without
- # reading Bug 7714 first. If you still build it statically,
+ # reading bug #7714 first. If you still build it statically,
# don't come crying to us with bugs ;).
#use static && export LDFLAGS="${LDFLAGS} -static"
use nls || myconf+=( --disable-nls )
@@ -145,28 +153,27 @@ src_configure() {
# is at least what's in the DEPEND up above.
export ac_cv_rl_version=${READLINE_VER%%_*}
- # Force linking with system curses ... the bundled termcap lib
- # sucks bad compared to ncurses. For the most part, ncurses
- # is here because readline needs it. But bash itself calls
- # ncurses in one or two small places :(.
-
if is_release ; then
# Use system readline only with released versions.
myconf+=( --with-installed-readline=. )
fi
- if use plugins; then
+ if use plugins ; then
append-ldflags -Wl,-rpath,/usr/$(get_libdir)/bash
else
# Disable the plugins logic by hand since bash doesn't
# provide a way of doing it.
export ac_cv_func_dl{close,open,sym}=no \
ac_cv_lib_dl_dlopen=no ac_cv_header_dlfcn_h=no
+
sed -i \
-e '/LOCAL_LDFLAGS=/s:-rdynamic::' \
configure || die
fi
- tc-export AR #444070
+
+ # bug #444070
+ tc-export AR
+
econf "${myconf[@]}"
}
@@ -190,7 +197,9 @@ src_install() {
insinto /etc/bash
doins "${FILESDIR}"/bash_logout
doins "$(prefixify_ro "${FILESDIR}"/bashrc)"
+
keepdir /etc/bash/bashrc.d
+
insinto /etc/skel
for f in bash{_logout,_profile,rc} ; do
newins "${FILESDIR}"/dot-${f} .${f}
@@ -200,12 +209,15 @@ src_install() {
-e "s:#${USERLAND}#@::"
-e '/#@/d'
)
+
if ! use readline ; then
- sed_args+=( #432338
+ # bug #432338
+ sed_args+=(
-e '/^shopt -s histappend/s:^:#:'
-e 's:use_color=true:use_color=false:'
)
fi
+
sed -i \
"${sed_args[@]}" \
"${ED}"/etc/skel/.bashrc \
@@ -214,6 +226,7 @@ src_install() {
if use plugins ; then
exeinto /usr/$(get_libdir)/bash
doexe $(echo examples/loadables/*.o | sed 's:\.o::g')
+
insinto /usr/include/bash-plugins
doins *.h builtins/*.h include/*.h lib/{glob/glob.h,tilde/tilde.h}
fi
@@ -244,7 +257,7 @@ pkg_preinst() {
fi
if [[ -L ${EROOT}/bin/sh ]] ; then
- # rewrite the symlink to ensure that its mtime changes. having /bin/sh
+ # Rewrite the symlink to ensure that its mtime changes. Having /bin/sh
# missing even temporarily causes a fatal error with paludis.
local target=$(readlink "${EROOT}"/bin/sh)
local tmp="${T}"/sh