summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-06-06 20:28:12 -0400
committerJoonas Niilola <juippis@gentoo.org>2024-06-07 09:25:25 +0300
commit98e81e7861e498580203c1cad322d63ce98f65c4 (patch)
tree71b9a266b3a28398a6fbe72e41d4b5311fd756ef /app-shells
parentapp-shells/gentoo-bashcomp: Stabilize 20240511 sparc, #933700 (diff)
downloadgentoo-98e81e7861e498580203c1cad322d63ce98f65c4.tar.gz
gentoo-98e81e7861e498580203c1cad322d63ce98f65c4.tar.bz2
gentoo-98e81e7861e498580203c1cad322d63ce98f65c4.zip
app-shells/bash-completion: sync live
Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash-completion/bash-completion-9999.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/app-shells/bash-completion/bash-completion-9999.ebuild b/app-shells/bash-completion/bash-completion-9999.ebuild
index 322f3a72d214..61c35185dad9 100644
--- a/app-shells/bash-completion/bash-completion-9999.ebuild
+++ b/app-shells/bash-completion/bash-completion-9999.ebuild
@@ -29,7 +29,6 @@ BDEPEND="
$(python_gen_any_dep '
dev-python/pexpect[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-forked[${PYTHON_USEDEP}]
dev-python/pytest-xdist[${PYTHON_USEDEP}]
')
)
@@ -38,6 +37,10 @@ PDEPEND="
>=app-shells/gentoo-bashcomp-20140911
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.14.0-optimize-kernel-modules.patch
+)
+
strip_completions() {
# Remove unwanted completions.
local strip_completions=(
@@ -72,7 +75,6 @@ strip_completions() {
python_check_deps() {
python_has_version "dev-python/pexpect[${PYTHON_USEDEP}]" &&
python_has_version "dev-python/pytest[${PYTHON_USEDEP}]" &&
- python_has_version "dev-python/pytest-forked[${PYTHON_USEDEP}]" &&
python_has_version "dev-python/pytest-xdist[${PYTHON_USEDEP}]"
}
@@ -96,7 +98,7 @@ src_prepare() {
eapply "${WORKDIR}"/bashcomp2/bash-completion-blacklist-support.patch
fi
- eapply_user
+ default
eautoreconf
}
@@ -123,7 +125,7 @@ src_test() {
# used in pytest tests
local -x NETWORK=none
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=xdist.plugin,pytest_forked
+ local -x PYTEST_PLUGINS=xdist.plugin
emake -C completions check
epytest
}