summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-10-17 17:44:36 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-10-17 17:51:22 +0200
commitc6bd4e39cf8dd86ca89211dd1f43a666213e1c4d (patch)
treee8cf9318965bc8afb3f17d740fbe0ee2652e5b7f /app-shells
parentdev-dotnet/netcoredbg: drop old 3.0.0.1018-r1 (diff)
downloadgentoo-c6bd4e39cf8dd86ca89211dd1f43a666213e1c4d.tar.gz
gentoo-c6bd4e39cf8dd86ca89211dd1f43a666213e1c4d.tar.bz2
gentoo-c6bd4e39cf8dd86ca89211dd1f43a666213e1c4d.zip
app-shells/ugit: bump to 0.4.5
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/ugit/Manifest1
-rw-r--r--app-shells/ugit/ugit-0.4.5.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/app-shells/ugit/Manifest b/app-shells/ugit/Manifest
index 5ea217a7adf2..872320caa9dc 100644
--- a/app-shells/ugit/Manifest
+++ b/app-shells/ugit/Manifest
@@ -1 +1,2 @@
DIST ugit-0.4.4.tar.gz 149708 BLAKE2B 5cc59d36c0647f472cbb4787cca400684d0dcb1ead476a733aa3fed49b5bf4392d33c206aae912f6e67af6bbe8732f9bfd6870b6c0a6c14b6cebcc2cadb0a2a1 SHA512 a01ba28186c68671817e71b0cc33f191cc22abea9c8ceedc881de573bfdc8c13c81ec4fb03e964be2e39b84a32dfeee61c6d11e7595b8e8fa50912b117f41e77
+DIST ugit-0.4.5.tar.gz 165899 BLAKE2B 906fa38c3d10a68368ec9e8a3a395e68c73b0bab8d4a9e75043266f84604dbda1501823f2782ee550319d1f5064a36bac40299729c101509b72681bd7566553a SHA512 a3008f651ab3bd418631b35eeba32bd4cfa2fbcf050360032d94fe84082e59e8a26fe044c473b61f0cf6f05cdecedf03c7df050f9062b266a3a1c0140c05a224
diff --git a/app-shells/ugit/ugit-0.4.5.ebuild b/app-shells/ugit/ugit-0.4.5.ebuild
new file mode 100644
index 000000000000..f321df3b91f8
--- /dev/null
+++ b/app-shells/ugit/ugit-0.4.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="PowerShell wrapper for git, automate repos and output git as objects"
+HOMEPAGE="https://ugit.start-automating.com/
+ https://github.com/StartAutomating/ugit/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/StartAutomating/${PN}.git"
+else
+ SRC_URI="https://github.com/StartAutomating/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="${PV}"
+
+RDEPEND="
+ dev-vcs/git
+ virtual/pwsh:*
+"
+
+src_install() {
+ insinto "/usr/share/GentooPowerShell/Modules/${PN}/${PV}"
+ doins "${PN}.psd1"
+ doins *.ps1 *.ps1xml *.psm1
+ doins -r Commands Extensions Types en-us
+
+ dodoc *.md
+}