summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/getxbook
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/getxbook')
-rw-r--r--app-text/getxbook/Manifest1
-rw-r--r--app-text/getxbook/files/getxbook-1.0.patch42
-rw-r--r--app-text/getxbook/getxbook-1.0-r1.ebuild46
-rw-r--r--app-text/getxbook/metadata.xml18
4 files changed, 107 insertions, 0 deletions
diff --git a/app-text/getxbook/Manifest b/app-text/getxbook/Manifest
new file mode 100644
index 000000000000..c19fd2f2a1a2
--- /dev/null
+++ b/app-text/getxbook/Manifest
@@ -0,0 +1 @@
+DIST getxbook-1.0.tar.bz2 22314 SHA256 ce0f7d0bcd9002d31c94617cecde8145cbc138a2ab3aed1a75af26b26e3e9521 SHA512 df912e67ddd823e4b1ce1539522ef0804f74758aa27baa0c568790859fac97d40dbc8f574be936fdf3ba8a1135bcc3d9af1bedf0205353d7a12f8993393fe941 WHIRLPOOL 863b3c21b7c79166d3ac14cc7e11971b6aee4ba724eef48362bdf56b58fba21fd61a9162a2839b4f981cf6e2dd61228b69ea00adad8b84a62cf14530dd45d580
diff --git a/app-text/getxbook/files/getxbook-1.0.patch b/app-text/getxbook/files/getxbook-1.0.patch
new file mode 100644
index 000000000000..50da6328bf8a
--- /dev/null
+++ b/app-text/getxbook/files/getxbook-1.0.patch
@@ -0,0 +1,42 @@
+ Makefile | 17 ++++++++++++-----
+ 1 file changed, 12 insertions(+), 5 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index f6507b5..d080f2b 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,5 +1,12 @@
+ # See COPYING file for copyright and license details.
+-include config.mk
++VERSION = 1.0
++RELDATE = 2012-08-19
++PREFIX = /usr
++MANPREFIX = $(PREFIX)/share/man
++CFLAGS += -std=c99 -pedantic -Wall -Wextra \
++ -D_POSIX_C_SOURCE=200112L -DVERSION=\"$(VERSION)\"
++CC ?= cc
++LD = $(CC)
+
+ NAME = getxbook
+
+@@ -20,16 +27,16 @@ $(BIN): util.a
+
+ .o:
+ @echo LD $@
+- @$(LD) -o $@ $< util.a $(LDFLAGS)
++ $(LD) $(LDFLAGS) -o $@ $< util.a
+
+ .c.o:
+ @echo CC $<
+- @$(CC) -c $(CFLAGS) $<
++ $(CC) -c $(CFLAGS) $<
+
+ util.a: $(LIB)
+ @echo AR $@
+- @$(AR) -r -c $@ $(LIB)
+- @ranlib $@
++ $(AR) -r -c $@ $(LIB)
++ $(RANLIB) $@
+
+ install: all
+ mkdir -p $(DESTDIR)$(PREFIX)/bin
diff --git a/app-text/getxbook/getxbook-1.0-r1.ebuild b/app-text/getxbook/getxbook-1.0-r1.ebuild
new file mode 100644
index 000000000000..b8af2fec4a3e
--- /dev/null
+++ b/app-text/getxbook/getxbook-1.0-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Download books from google, amazon, barnes and noble"
+HOMEPAGE="http://njw.me.uk/software/getxbook/"
+SRC_URI="http://njw.me.uk/software/getxbook/${P}.tar.bz2"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="pdf djvu ocr tk"
+
+DEPEND=""
+RDEPEND="
+ djvu? ( app-text/djvu )
+ pdf? ( media-gfx/imagemagick )
+ ocr? (
+ app-text/tesseract
+ pdf? ( media-gfx/exact-image app-text/pdftk )
+ )
+ tk? ( dev-lang/tk:0= )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}.patch
+ tc-export CC AR RANLIB
+}
+
+src_install() {
+ DOCS=( README LEGAL )
+ default
+
+ use pdf && dobin extras/mkpdf.sh
+ use djvu && dobin extras/mkdjvu.sh
+
+ if use ocr; then
+ dobin extras/mkocrtxt.sh
+ use pdf && dobin extras/mkocrpdf.sh
+ use djvu && dobin extras/mkocrdjvu.sh
+ fi
+ use tk && dobin getxbookgui.tcl
+}
diff --git a/app-text/getxbook/metadata.xml b/app-text/getxbook/metadata.xml
new file mode 100644
index 000000000000..5569be9d2239
--- /dev/null
+++ b/app-text/getxbook/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>grozin@gentoo.org</email>
+ <name>Andrey Grozin</name>
+ </maintainer>
+ <longdescription lang="en">
+ A collection of tools to download books from
+ google books' "book preview",
+ amazon's "look inside the book",
+ barnes and noble's "book viewer",
+ optionally using tesseract to produce OCRed pdf or djvu.
+ </longdescription>
+ <use>
+ <flag name="ocr">Use <pkg>app-text/tesseract</pkg> for optical character recognition</flag>
+ </use>
+</pkgmetadata>