summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2022-03-31 09:46:12 -0500
committerBen Kohler <bkohler@gentoo.org>2022-03-31 09:46:57 -0500
commit5c2d773e025c827af755b1635653390dd133c0a0 (patch)
tree7bbd08d608e7a104770c84737796de777921a026 /app-text/grip/grip-4.6.1.ebuild
parentprofiles/arch/arm: drop pyside2 mask on QtPy (diff)
downloadgentoo-5c2d773e025c827af755b1635653390dd133c0a0.tar.gz
gentoo-5c2d773e025c827af755b1635653390dd133c0a0.tar.bz2
gentoo-5c2d773e025c827af755b1635653390dd133c0a0.zip
app-text/grip: add 4.6.1
Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'app-text/grip/grip-4.6.1.ebuild')
-rw-r--r--app-text/grip/grip-4.6.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-text/grip/grip-4.6.1.ebuild b/app-text/grip/grip-4.6.1.ebuild
new file mode 100644
index 000000000000..1dc8182a71d1
--- /dev/null
+++ b/app-text/grip/grip-4.6.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Preview GitHub Markdown files like Readme locally before committing them"
+HOMEPAGE="https://github.com/joeyespo/grip"
+LICENSE="MIT"
+
+SLOT="0"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ !media-sound/grip
+ >=dev-python/docopt-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/flask-0.10.1[${PYTHON_USEDEP}]
+ >=dev-python/markdown-2.5.1[${PYTHON_USEDEP}]
+ >=dev-python/path-and-address-2.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pygments-1.6[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.4.1[${PYTHON_USEDEP}]
+"