summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-04-15 07:32:37 +0100
committerSam James <sam@gentoo.org>2024-04-15 07:51:30 +0100
commitf7b15433f1327fc6092e8fdf6628b32caa19bba9 (patch)
tree887d1e7bdcb4eacb9ef2f5885df7562e243bcbd1 /app-text/lesspipe
parentapp-text/lesspipe: drop 2.10, 2.11 (diff)
downloadgentoo-f7b15433f1327fc6092e8fdf6628b32caa19bba9.tar.gz
gentoo-f7b15433f1327fc6092e8fdf6628b32caa19bba9.tar.bz2
gentoo-f7b15433f1327fc6092e8fdf6628b32caa19bba9.zip
app-text/lesspipe: add 2.12
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/lesspipe')
-rw-r--r--app-text/lesspipe/Manifest1
-rw-r--r--app-text/lesspipe/lesspipe-2.12.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/app-text/lesspipe/Manifest b/app-text/lesspipe/Manifest
index e3cdae40bc16..2deb7f2d7be7 100644
--- a/app-text/lesspipe/Manifest
+++ b/app-text/lesspipe/Manifest
@@ -1 +1,2 @@
DIST lesspipe-2.11.tar.gz 171212 BLAKE2B aa7cf35f00d9db4ad7cb48ae89089a4d0c5d6c6e41ec902bc7ba6d4fd218f8ea90e1fdf3d6fcbac1dd1f86eb841a0daa6838b0086905fd4b0535d91040ef85aa SHA512 ed75d8529bd24876b11a50d0ada476299569d0fe716c390de84a0630ae475594f96370ffbed64fc5d9e2417dcbaa7b2f68630e32f665dff799667c2653b0265f
+DIST lesspipe-2.12.tar.gz 171915 BLAKE2B b1181cc5ca6ec8ca918bff31def6d6fde5f6bcfde9d48e0a23a088ee9ff178e3e9ff330b1c27a3d74b63d227c94292141414bec8c25d0035f9fec01c6760b8b9 SHA512 9c6945b0f5a5672e3b9b0035ebc63ab3197c1b3d1dfc3d4a2280c1f11421d98ccc5c016273a308a96f61a47f4da6d6658502534284fff81fd75365a4ba91c27e
diff --git a/app-text/lesspipe/lesspipe-2.12.ebuild b/app-text/lesspipe/lesspipe-2.12.ebuild
new file mode 100644
index 000000000000..9e0fa293f993
--- /dev/null
+++ b/app-text/lesspipe/lesspipe-2.12.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit edo
+
+DESCRIPTION="Preprocessor for less"
+HOMEPAGE="https://github.com/wofr06/lesspipe"
+SRC_URI="https://github.com/wofr06/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="test"
+
+# Please check again on bumps! (bug #734896)
+RESTRICT="!test? ( test ) test"
+
+RDEPEND="
+ dev-lang/perl
+ dev-perl/Text-CSV
+"
+BDEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ test? ( app-editors/vim )
+"
+
+src_configure() {
+ # Not an autoconf script.
+ #
+ # PG0301
+ # By default, only completions for installed shells are installed.
+ # Unconditionally install zsh too.
+ edo ./configure --prefix="${EPREFIX}"/usr --all-completions
+}
+
+src_compile() {
+ # Nothing to build (avoids the "all" target)
+ :
+}
+
+src_install() {
+ emake PREFIX="${EPREFIX}/usr" DESTDIR="${D}" install
+ einstalldocs
+
+ # The upstream Makefile intentionally installs to the wrong directory, then prints:
+ # In bash, please preload the completion, dynamic invocation does not work
+ # . /usr/share/bash-completion/less_completion
+ # Or consider installing the file less_completion in /etc/bashcompletion.d
+ rm "${ED}"/usr/share/bash-completion/less_completion || die
+ insinto /etc/bash_completion.d
+ doins less_completion
+}
+
+pkg_preinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog "This package installs 'lesspipe.sh' which is distinct from 'lesspipe'."
+ elog "The latter is the Gentoo-specific version. Make sure to update your"
+ elog "LESSOPEN environment variable if you wish to use this copy."
+ fi
+}