summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoao Santos <joaompssantos@gmail.com>2022-02-22 15:02:58 +0000
committerSam James <sam@gentoo.org>2022-02-26 02:29:10 +0000
commit355c5bfe2533b9710a52404ddf18f9b0e106fc80 (patch)
tree8a1cb4ac1256ee139bc81563af4a6d86b17d12fb /app-text/master-pdf-editor/master-pdf-editor-5.8.33.ebuild
parentprofiles/features/musl: mask binary app-text/master-pdf-editor (diff)
downloadgentoo-355c5bfe2533b9710a52404ddf18f9b0e106fc80.tar.gz
gentoo-355c5bfe2533b9710a52404ddf18f9b0e106fc80.tar.bz2
gentoo-355c5bfe2533b9710a52404ddf18f9b0e106fc80.zip
app-text/master-pdf-editor: bump to 5.8.33
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: João Santos <joaompssantos@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/24316 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/master-pdf-editor/master-pdf-editor-5.8.33.ebuild')
-rw-r--r--app-text/master-pdf-editor/master-pdf-editor-5.8.33.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-text/master-pdf-editor/master-pdf-editor-5.8.33.ebuild b/app-text/master-pdf-editor/master-pdf-editor-5.8.33.ebuild
new file mode 100644
index 000000000000..f944cce74811
--- /dev/null
+++ b/app-text/master-pdf-editor/master-pdf-editor-5.8.33.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop xdg
+
+DESCRIPTION="A complete solution for viewing and editing PDF files"
+HOMEPAGE="https://code-industry.net/free-pdf-editor/"
+SRC_URI="https://code-industry.net/public/${P}-qt5.x86_64.tar.gz"
+S="${WORKDIR}/${PN}-${PV%%.*}"
+
+LICENSE="master-pdf-editor"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="mirror"
+
+RDEPEND="
+ sys-libs/glibc
+ >=dev-qt/qtcore-5.12.9:5
+ >=dev-qt/qtgui-5.12.9:5
+ >=dev-qt/qtnetwork-5.12.9:5
+ >=dev-qt/qtprintsupport-5.12.9:5
+ >=dev-qt/qtsvg-5.12.9:5
+ dev-qt/qtwidgets:5
+ media-libs/libglvnd
+ >=media-gfx/sane-backends-1.0
+"
+
+QA_PREBUILT="opt/${PN}/masterpdfeditor5"
+
+src_install() {
+ insinto /opt/${PN}
+ doins -r fonts lang stamps templates masterpdfeditor5.png
+
+ exeinto /opt/${PN}
+ doexe masterpdfeditor5
+ dosym ../${PN}/masterpdfeditor5 /opt/bin/masterpdfeditor5
+
+ make_desktop_entry "masterpdfeditor5 %f" \
+ "Master PDF Editor ${PV}" /opt/${PN}/masterpdfeditor5.png \
+ "Office;Graphics;Viewer" \
+ "MimeType=application/pdf;application/x-bzpdf;application/x-gzpdf;\nTerminal=false"
+}