summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-02-22 20:42:13 +0100
committerSam James <sam@gentoo.org>2021-02-22 22:19:28 +0000
commitdc827d90d6259b3c925844812e0a54ca79dcdb91 (patch)
treef457e597dc9e450b41ab38ba7a727887b73571c6 /app-text/pdfminer
parentdev-python/funcparserlib: Mark ALLARCHES (diff)
downloadgentoo-dc827d90d6259b3c925844812e0a54ca79dcdb91.tar.gz
gentoo-dc827d90d6259b3c925844812e0a54ca79dcdb91.tar.bz2
gentoo-dc827d90d6259b3c925844812e0a54ca79dcdb91.zip
app-text/pdfminer: Port to python 3.{8,9}
Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/pdfminer')
-rw-r--r--app-text/pdfminer/pdfminer-20191020.ebuild9
1 files changed, 3 insertions, 6 deletions
diff --git a/app-text/pdfminer/pdfminer-20191020.ebuild b/app-text/pdfminer/pdfminer-20191020.ebuild
index 9f77fd732f32..7e7b3e5ce079 100644
--- a/app-text/pdfminer/pdfminer-20191020.ebuild
+++ b/app-text/pdfminer/pdfminer-20191020.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_7 )
-
+PYTHON_COMPAT=( python3_{7..9} )
inherit distutils-r1
DESCRIPTION="Python tool for extracting information from PDF documents"
@@ -14,10 +13,8 @@ SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="doc examples test"
-RESTRICT="!test? ( test )"
+IUSE="doc examples"
-BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND="dev-python/pycryptodome[${PYTHON_USEDEP}]"
python_compile_all() {