summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-12 11:39:55 +0100
committerSam James <sam@gentoo.org>2022-07-12 11:39:55 +0100
commit29f373ce050a3b589f1e6e395a7ef56dd277402e (patch)
treefe1188d9912f7ade9227a16d51da0b6e8964e4b7 /app-text/pelican
parentapp-text/pelican: docinto (diff)
downloadgentoo-29f373ce050a3b589f1e6e395a7ef56dd277402e.tar.gz
gentoo-29f373ce050a3b589f1e6e395a7ef56dd277402e.tar.bz2
gentoo-29f373ce050a3b589f1e6e395a7ef56dd277402e.zip
app-text/pelican: drop 9999
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/pelican')
-rw-r--r--app-text/pelican/pelican-9999.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/app-text/pelican/pelican-9999.ebuild b/app-text/pelican/pelican-9999.ebuild
deleted file mode 100644
index aa9807867aa1..000000000000
--- a/app-text/pelican/pelican-9999.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8,9,10} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1 git-r3
-
-DESCRIPTION="A tool to generate a static blog, with restructured text or markdown input files"
-HOMEPAGE="https://blog.getpelican.com/ https://pypi.org/project/pelican/"
-EGIT_REPO_URI="https://github.com/getpelican/pelican.git"
-EGIT_CHECKOUT_DIR="${WORKDIR}/${P}"
-
-LICENSE="AGPL-3"
-SLOT="0"
-IUSE="doc examples markdown"
-
-RESTRICT="test"
-RDEPEND=">=dev-python/docutils-0.16[${PYTHON_USEDEP}]
- >=dev-python/blinker-1.4[${PYTHON_USEDEP}]
- >=dev-python/feedgenerator-1.9[${PYTHON_USEDEP}]
- >=dev-python/jinja-2.7[${PYTHON_USEDEP}]
- >=dev-python/pygments-2.6[${PYTHON_USEDEP}]
- >=dev-python/python-dateutil-2.8[${PYTHON_USEDEP}]
- >=dev-python/pytz-2020.1[${PYTHON_USEDEP}]
- >=dev-python/rich-10.1[${PYTHON_USEDEP}]
- >=dev-python/unidecode-1.1[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- markdown? ( >=dev-python/markdown-3.1[${PYTHON_USEDEP}] )"
-BDEPEND="test? ( >=dev-python/markdown-3.1[${PYTHON_USEDEP}] )"
-
-DOCS=( README.rst )
-
-distutils_enable_tests nose
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- if use examples; then
- insinto "/usr/share/doc/${PF}"
- docompress -x "/usr/share/doc/${PF}/samples"
- doins -r samples
- fi
- distutils-r1_python_install_all
-}