summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-02 10:55:59 +0000
committerSam James <sam@gentoo.org>2021-06-02 10:58:10 +0000
commitefd1346188b3cc708f685261a97a6d3ee60739c1 (patch)
tree39c7fd1bd9d45e5738374cdbb2b027564a3f4655 /app-text/recode
parentgames-rpg/wastesedge: add python3_9 compat (diff)
downloadgentoo-efd1346188b3cc708f685261a97a6d3ee60739c1.tar.gz
gentoo-efd1346188b3cc708f685261a97a6d3ee60739c1.tar.bz2
gentoo-efd1346188b3cc708f685261a97a6d3ee60739c1.zip
app-text/recode: add 3.7.9
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/recode')
-rw-r--r--app-text/recode/Manifest1
-rw-r--r--app-text/recode/recode-3.7.9.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/app-text/recode/Manifest b/app-text/recode/Manifest
index 7aa40eb5c34a..9e411606aca9 100644
--- a/app-text/recode/Manifest
+++ b/app-text/recode/Manifest
@@ -1,2 +1,3 @@
DIST recode-3.7.6.tar.gz 2210564 BLAKE2B 8c99b6d2eb93482785fe7e36063514e4c153516cc8059a9b98fc9f1b08704314b7933390a5fd7921525648ef58e9f995242182b8de23b7db33cbf94383e28f29 SHA512 ababefc445fcc47b6bf9ed640b767aed374bb8ce93cdccb641dd1ba5d298360583dd79070a0bb458f1190a8d6f1ddeb3b04eec34a61305b69def0963cec5843f
DIST recode-3.7.8.tar.gz 2230154 BLAKE2B 853a53d86a3a3600e5d70a8dc67bab9b0fa7a9dfab79e3f4ae8611f54c955802862689077774f7b21ce360f2d91c65ee238406ffa137a84545157e3a70853f42 SHA512 e6cd9c7d3eb5c179d3f62804018d1d19b71a3fae72b0d76aec730c36e64c50a571cbfda5340ac50244a16ccdd9265f5610deadb8908067c3866fa68cbbf0ac70
+DIST recode-3.7.9.tar.gz 2230259 BLAKE2B 36039ba9e62c5113231764dfa9cffa73b7ff5cd91bab622a0daf0a48a73ab8a62afd16132cec2590eed14623ce5b86ad057e8ca8454cf8185869f0780b3523e7 SHA512 277074dee63cdc7f1a1be2acca67481b8fb816bd4319fe8e882696e42d15309750b930fa9e8d6286e714132a976f0eaf87f718560d6cb86eeaa79b86f0700a6c
diff --git a/app-text/recode/recode-3.7.9.ebuild b/app-text/recode/recode-3.7.9.ebuild
new file mode 100644
index 000000000000..163176ef093c
--- /dev/null
+++ b/app-text/recode/recode-3.7.9.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit flag-o-matic python-any-r1 toolchain-funcs
+
+DESCRIPTION="Convert files between various character sets"
+HOMEPAGE="https://github.com/rrthomas/recode"
+SRC_URI="https://github.com/rrthomas/recode/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+# librecode soname version
+SLOT="0/3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x86-solaris"
+IUSE="nls test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="virtual/libiconv"
+DEPEND="
+ ${RDEPEND}
+ sys-devel/flex
+"
+BDEPEND="
+ nls? ( sys-devel/gettext )
+ test? (
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep '
+ dev-python/cython[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+python_check_deps() {
+ if use test ; then
+ has_version -b "dev-python/cython[${PYTHON_USEDEP}]" || return 1
+ fi
+}
+
+src_configure() {
+ tc-export CC LD
+
+ # on solaris -lintl is needed to compile
+ [[ ${CHOST} == *-solaris* ]] && append-libs "-lintl"
+
+ # --without-included-gettext means we always use system headers
+ # and library
+ econf \
+ $(use_enable nls) \
+ --disable-static
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}