summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2023-02-28 15:49:05 +0100
committerFlorian Schmaus <flow@gentoo.org>2023-03-01 09:18:27 +0100
commitc6d321c915a0986da8c616536d1d0fce90013b57 (patch)
tree980989de307cb7027f359fea2c5c7f7fcc9ccfe8 /app-text/texlive-core
parentmedia-libs/libdiscid: bump to 0.6.3 + eapi8 (diff)
downloadgentoo-c6d321c915a0986da8c616536d1d0fce90013b57.tar.gz
gentoo-c6d321c915a0986da8c616536d1d0fce90013b57.tar.bz2
gentoo-c6d321c915a0986da8c616536d1d0fce90013b57.zip
app-text/texlive-core: only ewarn on upgrade
Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'app-text/texlive-core')
-rw-r--r--app-text/texlive-core/texlive-core-2021-r6.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/app-text/texlive-core/texlive-core-2021-r6.ebuild b/app-text/texlive-core/texlive-core-2021-r6.ebuild
index 0b463ff9a7ff..6ef89fc8bfd5 100644
--- a/app-text/texlive-core/texlive-core-2021-r6.ebuild
+++ b/app-text/texlive-core/texlive-core-2021-r6.ebuild
@@ -363,6 +363,24 @@ pkg_postinst() {
elog "If you have configuration files in ${EPREFIX}/etc/texmf to merge,"
elog "please update them and run ${EPREFIX}/usr/sbin/texmf-update."
elog
+
+ local display_migration_hint=false
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ local new_texlive_ver=$(ver_cut 1)
+ local replaced_version
+ for replaced_version in ${REPLACING_VERSIONS}; do
+ replaced_version=$(ver_cut 1 ${replaced_version})
+ if (( replaced_version < new_texlive_version )); then
+ display_migration_hint=true
+ break
+ fi
+ done
+ fi
+
+ if ! ${display_migration_hint}; then
+ return
+ fi
+
ewarn "If you are migrating from an older TeX distribution"
ewarn "Please make sure you have read:"
ewarn "https://wiki.gentoo.org/wiki/Project:TeX/Tex_Live_Migration_Guide"