summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2023-10-02 01:46:38 -0400
committerZac Medico <zmedico@gentoo.org>2023-10-17 21:25:59 -0700
commit25c6c42bad25b01571cbcfad087e4ad8080173f6 (patch)
treeb87555d804286b92c7b00e9120da09aa2c07361a /app-text
parentapp-text/calibre: avoid setting useless variables at install time (diff)
downloadgentoo-25c6c42bad25b01571cbcfad087e4ad8080173f6.tar.gz
gentoo-25c6c42bad25b01571cbcfad087e4ad8080173f6.tar.bz2
gentoo-25c6c42bad25b01571cbcfad087e4ad8080173f6.zip
app-text/calibre: Use upstream buildsystem to integrate system fonts
The liberation fonts are removed and replaced with symlinks to the system fonts. I've put quite a bit of work in upstream to make this work in a supported manner; let's use that instead of fragile, unchecked shell code. In particular, upstream's buildsystem dies if the expected fonts do not exist. Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/calibre/calibre-5.44.0-r2.ebuild17
1 files changed, 10 insertions, 7 deletions
diff --git a/app-text/calibre/calibre-5.44.0-r2.ebuild b/app-text/calibre/calibre-5.44.0-r2.ebuild
index 598bb98f4356..67eb556626cd 100644
--- a/app-text/calibre/calibre-5.44.0-r2.ebuild
+++ b/app-text/calibre/calibre-5.44.0-r2.ebuild
@@ -186,6 +186,16 @@ src_compile() {
export QMAKE="$(qt5_get_bindir)/qmake"
${EPYTHON} setup.py build || die
+ ${EPYTHON} setup.py gui || die
+
+ # A few different resources are bundled in the distfile by default, because
+ # not all systems necessarily have them. We un-vendor them, using the
+ # upstream integrated approach if possible. See setup/revendor.py and
+ # consider migrating other resources to this if they do not use it, in
+ # *preference* over manual rm'ing.
+ ${EPYTHON} setup.py liberation_fonts \
+ --path-to-liberation_fonts "${EPREFIX}"/usr/share/fonts/liberation-fonts \
+ --system-liberation_fonts || die
}
src_test() {
@@ -233,13 +243,6 @@ src_install() {
find "${ED}"/usr/share -type d -empty -delete
- cd "${ED}"/usr/share/calibre/fonts/liberation || die
- local x
- for x in * ; do
- [[ -f ${EPREFIX}/usr/share/fonts/liberation-fonts/${x} ]] || continue
- ln -sf "../../../fonts/liberation-fonts/${x}" "${x}" || die
- done
-
einfo "Converting python shebangs"
python_fix_shebang --force "${ED}"