summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Stein <jstein@gentoo.org>2023-09-01 05:57:43 +0200
committerJonas Stein <jstein@gentoo.org>2023-09-01 05:58:36 +0200
commit2e4d5c79e043fe451f0c523895609dac6f3cb833 (patch)
tree7d9e2208f80580f8294a5f19d901abee334025d2 /app-text
parentdev-ruby/multipart-parser: Keyword 0.1.1 arm, #913388 (diff)
downloadgentoo-2e4d5c79e043fe451f0c523895609dac6f3cb833.tar.gz
gentoo-2e4d5c79e043fe451f0c523895609dac6f3cb833.tar.bz2
gentoo-2e4d5c79e043fe451f0c523895609dac6f3cb833.zip
app-text/tree: add 2.1.1
Closes: https://bugs.gentoo.org/913352 Signed-off-by: Jonas Stein <jstein@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/tree/Manifest1
-rw-r--r--app-text/tree/tree-2.1.1.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/app-text/tree/Manifest b/app-text/tree/Manifest
index bdbfe971a219..eeaf1383c522 100644
--- a/app-text/tree/Manifest
+++ b/app-text/tree/Manifest
@@ -1,2 +1,3 @@
DIST unix-tree-2.0.4.tar.gz 59497 BLAKE2B c55f8f64f2dfc6364ce3ab5ec26e59860f958eacbf681d1d53848172d474605f71864c1eb7db27be15f3df2fc2979787685e80de76ff817c5cdfafb9c52af203 SHA512 59f391de5792ce9990153c2de06bc545813f9e7aea635c574ef21f1603203146cdad4dbed821266715d716241d7153276aa220626ce8354446dd85df47e75fa6
DIST unix-tree-2.1.0.tar.bz2 51401 BLAKE2B 89b15df0268c03ba66827c7e6d234d1f5c4f6a5d9788e30bf6859d477b340393acbeec9ad7afc1909fdc7beb81ef7934917206066e0875d9f1662fca170f4127 SHA512 0f3a6ecb450bb3d683804667d4f15aecf9c9765578d47a62e39a8ff69cbe1c2a0a4a922fef3728359060338f4f9cd2de7ab8eb0f992a4c32949278bb47d17edc
+DIST unix-tree-2.1.1.tar.bz2 52550 BLAKE2B 0f20009a6c64b07a0742637bf32366b038f5c9bb025755a0aa45edb8c92741dfbff1486179caeeb73cfa8f10de3ed8678b948c7416ee0463e785cf153e808ff0 SHA512 ed34b1d0df049986295e7f5539491acd6134fbe69050ac2634037d700a878b4937700bed777ef0624e2bb0fc8c2815bb5139272ffe575ecc9362b84e0fafc9c2
diff --git a/app-text/tree/tree-2.1.1.ebuild b/app-text/tree/tree-2.1.1.ebuild
new file mode 100644
index 000000000000..a8aa448762ab
--- /dev/null
+++ b/app-text/tree/tree-2.1.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs flag-o-matic bash-completion-r1
+
+DESCRIPTION="Lists directories recursively, and produces an indented listing of files"
+HOMEPAGE="https://mama.indstate.edu/users/ice/tree/ https://gitlab.com/OldManProgrammer/unix-tree"
+SRC_URI="https://gitlab.com/OldManProgrammer/unix-${PN}/-/archive/${PV}/unix-${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~x64-macos"
+
+S=${WORKDIR}/unix-${P}
+
+src_compile() {
+ append-lfs-flags
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} ${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin tree
+ doman doc/tree*.1
+ einstalldocs
+ newbashcomp "${FILESDIR}"/${PN}.bashcomp ${PN}
+}