summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Joliet <marcec@gmx.de>2021-10-25 17:18:42 +0200
committerSam James <sam@gentoo.org>2021-12-29 01:58:18 +0000
commit4bde8884d1abdcc0273b632884e438a82edd0169 (patch)
tree7c6ffd7992d017e175924a4ccd330ab6c3d28e83 /app-text
parentnet-p2p/go-ipfs: verbump to 0.11.0 (diff)
downloadgentoo-4bde8884d1abdcc0273b632884e438a82edd0169.tar.gz
gentoo-4bde8884d1abdcc0273b632884e438a82edd0169.tar.bz2
gentoo-4bde8884d1abdcc0273b632884e438a82edd0169.zip
app-text/asciidoc: version bump to 9.1.1
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Marc Joliet <marcec@gmx.de> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/asciidoc/Manifest1
-rw-r--r--app-text/asciidoc/asciidoc-9.1.1.ebuild84
2 files changed, 85 insertions, 0 deletions
diff --git a/app-text/asciidoc/Manifest b/app-text/asciidoc/Manifest
index 064d9296ad3a..c97699418f3f 100644
--- a/app-text/asciidoc/Manifest
+++ b/app-text/asciidoc/Manifest
@@ -2,3 +2,4 @@ DIST asciidoc-9.0.2.new.tar.gz 1269444 BLAKE2B 0041073c572267628b8bbfd56258d86c3
DIST asciidoc-9.0.4.new.tar.gz 1233878 BLAKE2B 506a2c82d95ce0d522f45b20eee31f7ce2b114e0ad43c78bb313f34b210a7bdd282a8a3779a3ea29025e865847eb8298bd5a6ddac7ee338e4b878ae79bdf149e SHA512 59be96514d0c4c82e5842ddea412ddd6e06647ebe09e0f1828b7c07e787d890896bab4271e7566ed038eb2da6755a67c725bee07bcfbd7aa31475f39c3abc089
DIST asciidoc-9.0.5.new.tar.gz 1225334 BLAKE2B c3e428098dc4d71704ed13b54fd5f640b9de81d12939facb5faaf38a3123794e57201ecd9c312a22c220a2ec6b06c88a76ab47f05ffa972fc8751089b3471cfc SHA512 9125631fdee464f96f7e3c76a60fe37331905e9e55a81db27aece4065b246dc05a35db4c157dc7dbb2345eb95c153b474251d6a447d65774bf1b3f57e1883895
DIST asciidoc-9.1.0.new.tar.gz 1249958 BLAKE2B 0a98f58f7604f84d704092313c38563634bad5d697d60d02760f3be1d2a78a97ee2488dda3a9918b02e0062710175c6513d600f3fbd850fe700bf3fa917a3980 SHA512 c30854a936228fe5bcf2f9305741fbc4b17ef088b2fa637d5f3b19c7803306085634fb71146f0b089c2fad01f986da71a4fae364139f520c0906525317c0c4a6
+DIST asciidoc-9.1.1.new.tar.gz 1259206 BLAKE2B da274d3a9389ee2e42ad1be70467f11d0164df3e6f9102e6ef1be6a802dbeb12898786fa1fe37a95755d0db8c9df5d5dd3faf000dfb73b701a83af3cc0261606 SHA512 74b83e8c8904fd761783c2f572d353656fc0794c6cb427f61e9179c9f80b6fc3b3ee8d028baba4e25eafe5f8cf5318f9984a5828849a793a7520f83e6fe50d66
diff --git a/app-text/asciidoc/asciidoc-9.1.1.ebuild b/app-text/asciidoc/asciidoc-9.1.1.ebuild
new file mode 100644
index 000000000000..f3c86d982e94
--- /dev/null
+++ b/app-text/asciidoc/asciidoc-9.1.1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit autotools optfeature python-single-r1 readme.gentoo-r1
+
+DESCRIPTION="A plain text human readable/writable document format"
+HOMEPAGE="https://asciidoc.org/ https://github.com/asciidoc-py/asciidoc-py/"
+SRC_URI="https://github.com/asciidoc-py/asciidoc-py/releases/download/${PV}/${P}.tar.gz -> ${P}.new.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="${PYTHON_DEPS}
+ app-text/docbook-xml-dtd:4.5
+ >=app-text/docbook-xsl-stylesheets-1.75
+ dev-libs/libxslt
+ dev-libs/libxml2:2
+ "
+DEPEND="
+ test? (
+ ${PYTHON_DEPS}
+ app-text/dvipng
+ app-text/dvisvgm
+ dev-texlive/texlive-latex
+ dev-util/source-highlight
+ media-gfx/graphviz
+ media-gfx/imagemagick[png]
+ media-sound/lilypond
+ )"
+
+DOC_CONTENTS="
+If you are going to use a2x, please also look at a2x(1) under
+REQUISITES for a list of runtime dependencies.
+"
+
+DOCS=( BUGS.txt CHANGELOG.txt README.asciidoc
+ docbook-xsl/asciidoc-docbook-xsl.txt dblatex/dblatex-readme.txt
+ filters/code/code-filter-readme.txt )
+
+src_prepare() {
+ default
+ # Only needed for prefix - harmless (does nothing) otherwise
+ sed -i -e "s:^CONF_DIR=.*:CONF_DIR='${EPREFIX}/etc/asciidoc':" \
+ asciidoc.py || die
+
+ # enforce usage of the configured version of Python
+ sed -i -e "s:python3:${EPYTHON}:" Makefile.in || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf --sysconfdir="${EPREFIX}"/usr/share
+}
+
+src_install() {
+ default
+
+ if use doc; then
+ emake DESTDIR="${D}" docs
+ fi
+
+ python_fix_shebang "${ED}"/usr/bin/*.py
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+
+ optfeature "\"music\" filter support" "media-sound/lilypond media-gfx/imagemagick"
+ optfeature "\"source\" filter support" dev-util/source-highlight dev-python/pygments app-text/highlight
+ optfeature "\"latex\" filter support" "dev-texlive/texlive-latex app-text/dvipng" "dev-texlive/texlive-latex app-text/dvisvgm"
+ optfeature "\"graphviz\" filter support" media-gfx/graphviz
+}