summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2024-11-22 15:14:40 +0100
committerFlorian Schmaus <flow@gentoo.org>2024-11-22 15:32:29 +0100
commitd67afabd5c8216d369e26e8619c807387ed667fb (patch)
tree378a6ccf50c05d613bd58b4dcd0342fcdffde982 /app-text
parentRevert "dev-db/firebird: build w/ gnu++03" (diff)
downloadgentoo-d67afabd5c8216d369e26e8619c807387ed667fb.tar.gz
gentoo-d67afabd5c8216d369e26e8619c807387ed667fb.tar.bz2
gentoo-d67afabd5c8216d369e26e8619c807387ed667fb.zip
app-text/teckit: add 2.5.12
Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/teckit/Manifest1
-rw-r--r--app-text/teckit/teckit-2.5.12.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/app-text/teckit/Manifest b/app-text/teckit/Manifest
index fac64127da87..ca6c81b83619 100644
--- a/app-text/teckit/Manifest
+++ b/app-text/teckit/Manifest
@@ -1 +1,2 @@
DIST teckit-2.5.10.tar.gz 2112617 BLAKE2B fe38bbecfeec61f2c926fc033230a753ce1435fdf77bebe3c6d6c427a46bd5019d23605ee3d73f733d6345301a26ad3b1fd207daa46fdf66a7728be4569758aa SHA512 c2d3bcf1245723bb3bbe9c147fc3024e667ab4d1280aa0f8b5394b2dd9bb75e3f2bf42f057744fa86ed551ebf3e0f13300072a0325888cb8f9501d874c356f34
+DIST teckit-2.5.12.tar.gz 2361827 BLAKE2B 7ec764d2a471b0d275060c61bbc624e845260ccab063cf7d0facf56983e6f0a26b0923d94f589e44932368c25b196e7f2caaa1c4583d47b805cc16eee2ec6131 SHA512 52b87a887c37015f2fd52d31e2f2615775463e3cc1978aebcf35816f259693b04d47cfe437f102b0f6c72ab990b6513e3589581eb6e66f145aaf48fcaefa859d
diff --git a/app-text/teckit/teckit-2.5.12.ebuild b/app-text/teckit/teckit-2.5.12.ebuild
new file mode 100644
index 000000000000..cb2bb65d5c42
--- /dev/null
+++ b/app-text/teckit/teckit-2.5.12.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Text Encoding Conversion toolkit"
+HOMEPAGE="https://scripts.sil.org/cms/scripts/page.php?site_id=nrsi&cat_id=TECkit"
+SRC_URI="https://github.com/silnrsi/teckit/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="|| ( CPL-0.5 LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ dev-libs/expat
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ rm -f configure || die
+
+ sed -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" -i configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-static
+}
+
+src_test() {
+ cd "${S}/test" || die
+ chmod +x dotests.pl || die
+ ./dotests.pl || die "tests failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS README NEWS
+ find "${ED}" -name '*.la' -delete || die
+}