summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-vim/reload
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-vim/reload')
-rw-r--r--app-vim/reload/Manifest1
-rw-r--r--app-vim/reload/metadata.xml8
-rw-r--r--app-vim/reload/reload-0.6.17.ebuild23
3 files changed, 32 insertions, 0 deletions
diff --git a/app-vim/reload/Manifest b/app-vim/reload/Manifest
new file mode 100644
index 000000000000..29b569277c7c
--- /dev/null
+++ b/app-vim/reload/Manifest
@@ -0,0 +1 @@
+DIST reload-0.6.17.tar.gz 7028 SHA256 4a51350effee39a13296111e5156559aa4031046ed03102ed8c4a9a9579df3f3 SHA512 639ffcea9bf94b0a8346850078f59ff332ff6180b042d2c22662d5c637307969644607ca3f19e2648a1ef9a019788ef1f83be52b627ca6784e16d1b7bddc39cd WHIRLPOOL b55a7dfa9da13ccc9c0159a43d3048ae2eed717b0f0944e6dd70aed8783ed6bcbfe8b625998c8672fc15e6313d41f3e7a24910c25bfbec41da7be6cc392d313a
diff --git a/app-vim/reload/metadata.xml b/app-vim/reload/metadata.xml
new file mode 100644
index 000000000000..5eb0db4f75db
--- /dev/null
+++ b/app-vim/reload/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>vim</herd>
+ <upstream>
+ <remote-id type="github">xolox/vim-reload</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-vim/reload/reload-0.6.17.ebuild b/app-vim/reload/reload-0.6.17.ebuild
new file mode 100644
index 000000000000..5af977603170
--- /dev/null
+++ b/app-vim/reload/reload-0.6.17.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: automatic reloading of vim scripts"
+HOMEPAGE="http://peterodding.com/code/vim/reload/"
+SRC_URI="https://github.com/xolox/vim-${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+KEYWORDS="amd64 x86"
+
+RDEPEND=">=app-vim/vim-misc-1.8.5"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+S=${WORKDIR}/vim-${P}
+
+src_prepare() {
+ rm addon-info.json *.md || die
+}