summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-vim/unite
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-vim/unite')
-rw-r--r--app-vim/unite/Manifest2
-rw-r--r--app-vim/unite/metadata.xml14
-rw-r--r--app-vim/unite/unite-2.0.ebuild20
-rw-r--r--app-vim/unite/unite-4.0.ebuild15
4 files changed, 51 insertions, 0 deletions
diff --git a/app-vim/unite/Manifest b/app-vim/unite/Manifest
new file mode 100644
index 000000000000..4cdb3fcafb07
--- /dev/null
+++ b/app-vim/unite/Manifest
@@ -0,0 +1,2 @@
+DIST unite-2.0.tar.bz2 56031 SHA256 ede13c053933f633d7050b6f7866a413d9e2f54949f6a3322e016db5d5ee91d8 SHA512 f537a4a7c399555efec01fb165d4ad7b984bc94e7596e86e93bd5ef378e3bc7c539d54f5d8f886f8b88315283960c9deb4d35b41046a3e212ba9139d9cc9c414 WHIRLPOOL 11e1cd224a10d369da9216d6320d20cb48e10ff8e701a36d3b13720c32b30a50c24529651b6b0a97b256370f4993789ccd562e501e32fc714f6767377996a852
+DIST unite-4.0.tar.bz2 80472 SHA256 46e3cc1439e6d9d581975c2b742a53ab2c076c01ebdf0d0dbebe1fdf425adc39 SHA512 e554e48d740b0ce6406d8512a0c769e25f78b763d267bbbf8228197835b724154f33452571c771fede1415a9b3108deb096e3bc90291a95e8a3b00d216287928 WHIRLPOOL 0244c1d7da2d9b0e474a429f9d3ebf012635981f7a0b8437172cebcf6c560a584f86143738532d2d9af8609a025ed92aeb31a2839c343496edc2bb3823785e0f
diff --git a/app-vim/unite/metadata.xml b/app-vim/unite/metadata.xml
new file mode 100644
index 000000000000..ef7e62c357fc
--- /dev/null
+++ b/app-vim/unite/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>vim</herd>
+ <longdescription lang="en">
+ Unite searches and displays information from arbitrary sources like files,
+ buffers, recently used files or registers. You can run one of defined action
+ on a target displayed.
+
+ The differences between unite and similar plugins like fuzzyfinder or ku are
+ that unite doesn't use the built-in completion interface of Vim, and integrates
+ sources at the same time.
+ </longdescription>
+</pkgmetadata>
diff --git a/app-vim/unite/unite-2.0.ebuild b/app-vim/unite/unite-2.0.ebuild
new file mode 100644
index 000000000000..91a5178c4cd4
--- /dev/null
+++ b/app-vim/unite/unite-2.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: unite all sources"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=3396"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+VIM_PLUGIN_HELPFILES="unite.txt"
+
+src_prepare() {
+ # remove unused tests
+ rm -rf test
+}
diff --git a/app-vim/unite/unite-4.0.ebuild b/app-vim/unite/unite-4.0.ebuild
new file mode 100644
index 000000000000..fb5505999254
--- /dev/null
+++ b/app-vim/unite/unite-4.0.ebuild
@@ -0,0 +1,15 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: unite all sources"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=3396"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"