summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-06-26 16:47:37 +0200
committerMichał Górny <mgorny@gentoo.org>2017-06-27 21:17:38 +0200
commit54fd4d7c4197dd4d971f4bce76b9e03144783670 (patch)
tree12aadb4c37880e59ccea3b722a39a4691a1674e7 /app-vim
parentapp-office/calligra: Drop USE=vc and disable it (diff)
downloadgentoo-54fd4d7c4197dd4d971f4bce76b9e03144783670.tar.gz
gentoo-54fd4d7c4197dd4d971f4bce76b9e03144783670.tar.bz2
gentoo-54fd4d7c4197dd4d971f4bce76b9e03144783670.zip
app-vim/llvm-vim: Bump to 4.0.1
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/llvm-vim/Manifest1
-rw-r--r--app-vim/llvm-vim/llvm-vim-4.0.1.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/app-vim/llvm-vim/Manifest b/app-vim/llvm-vim/Manifest
index fc11f231595a..a0a5bf2ee812 100644
--- a/app-vim/llvm-vim/Manifest
+++ b/app-vim/llvm-vim/Manifest
@@ -1 +1,2 @@
DIST llvm-4.0.0.src.tar.xz 21016340 SHA256 8d10511df96e73b8ff9e7abbfb4d4d432edbdbe965f1f4f07afaf370b8a533be SHA512 cf681f0626ef6d568d951cdc3e143471a1d7715a0ba11e52aa273cf5d8d421e1357ef2645cc85879eaefcd577e99e74d07b01566825b3d0461171ef2cbfc7704 WHIRLPOOL 9783e8f47306c1deb2e114d4b46a7db9b0260b4965076345c88765413c5fc8e73fab5f88ae4903adbdea31406022948b16d32ae47d98f5def074509d5d794579
+DIST llvm-4.0.1.src.tar.xz 21065652 SHA256 da783db1f82d516791179fe103c71706046561f7972b18f0049242dee6712b51 SHA512 16adc39b34ddb628f81b171119a8e2a0e9138b25011e803ef0b688e2fbea116fc4953d3a1b61b90a98a75e33619f81566b7cb06a9a2ea4d04ac5e0eb303a2d1d WHIRLPOOL 1626ff270f7ce4801d02a0797b227fda9314ff5c0c01d653111599e9a4d2854c4d9edc3c698a7abee8d79d6bce8b18dc619fbced3c07ca610d44a248d65830cc
diff --git a/app-vim/llvm-vim/llvm-vim-4.0.1.ebuild b/app-vim/llvm-vim/llvm-vim-4.0.1.ebuild
new file mode 100644
index 000000000000..bd68c2ceeccb
--- /dev/null
+++ b/app-vim/llvm-vim/llvm-vim-4.0.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Vim support files for LLVM"
+HOMEPAGE="http://llvm.org/"
+SRC_URI="http://releases.llvm.org/${PV/_//}/llvm-${PV/_/}.src.tar.xz"
+
+LICENSE="UoI-NCSA"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="!sys-devel/llvm:0"
+
+S=${WORKDIR}/llvm-${PV/_/}.src/utils/vim
+
+src_install() {
+ insinto /usr/share/vim/vimfiles
+ doins -r */
+ # some users may find it useful
+ dodoc README vimrc
+}