summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorsin-ack <sin-ack@protonmail.com>2024-11-10 21:02:20 +0100
committerSam James <sam@gentoo.org>2024-11-11 22:24:18 +0000
commit1e1a45bc7091da593dd8b9ec4e19c0df60c3c69b (patch)
treed0345f541dfa94df461dc13fbfbd939edbc804fa /dev-cpp
parentdev-cpp/fbthrift: new package, add 2024.11.04.00 (diff)
downloadgentoo-1e1a45bc7091da593dd8b9ec4e19c0df60c3c69b.tar.gz
gentoo-1e1a45bc7091da593dd8b9ec4e19c0df60c3c69b.tar.bz2
gentoo-1e1a45bc7091da593dd8b9ec4e19c0df60c3c69b.zip
dev-cpp/fb303: new package, add 2024.11.04.00
Signed-off-by: sin-ack <sin-ack@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/fb303/Manifest1
-rw-r--r--dev-cpp/fb303/fb303-2024.11.04.00.ebuild51
-rw-r--r--dev-cpp/fb303/metadata.xml15
3 files changed, 67 insertions, 0 deletions
diff --git a/dev-cpp/fb303/Manifest b/dev-cpp/fb303/Manifest
new file mode 100644
index 000000000000..78209c541e02
--- /dev/null
+++ b/dev-cpp/fb303/Manifest
@@ -0,0 +1 @@
+DIST fb303-2024.11.04.00.gh.tar.gz 256825 BLAKE2B a7cb9b56f38f0a8f20a860b4b288f37cb59315242b50ac757bcd472e0310491a575149b2580a67a837a52badaf7ca4b72a769293d248830f90a0cf48f351835a SHA512 4ec54931f23267197e74cc0c3a0dd500f443221d5c4a6bb6a4d707feb6fbc377ef6c16f8fa94f2162e2c0a192fce01016f249890f7384a6c042b5f94b657dc11
diff --git a/dev-cpp/fb303/fb303-2024.11.04.00.ebuild b/dev-cpp/fb303/fb303-2024.11.04.00.ebuild
new file mode 100644
index 000000000000..915f3bcf8459
--- /dev/null
+++ b/dev-cpp/fb303/fb303-2024.11.04.00.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# These must be bumped together:
+# dev-cpp/edencommon
+# dev-cpp/fb303
+# dev-cpp/fbthrift
+# dev-cpp/fizz
+# dev-cpp/folly
+# dev-cpp/mvfst
+# dev-cpp/wangle
+# dev-util/watchman
+
+inherit cmake
+
+DESCRIPTION="Core set of Thrift functions querying stats and other information from a service"
+HOMEPAGE="https://github.com/facebook/fb303"
+SRC_URI="https://github.com/facebook/fb303/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="test"
+
+# See https://github.com/facebook/fb303/issues/61
+RESTRICT="test"
+
+RDEPEND="
+ ~dev-cpp/fbthrift-${PV}:=
+ ~dev-cpp/fizz-${PV}:=
+ ~dev-cpp/folly-${PV}:=
+ dev-cpp/gflags:=
+ dev-cpp/glog:=[gflags]
+ ~dev-cpp/wangle-${PV}:=
+ dev-libs/libfmt:=
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-cpp/gtest )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_DIR="$(get_libdir)/cmake/${PN}"
+ -DLIB_INSTALL_DIR="$(get_libdir)"
+ )
+
+ cmake_src_configure
+}
diff --git a/dev-cpp/fb303/metadata.xml b/dev-cpp/fb303/metadata.xml
new file mode 100644
index 000000000000..9ccd45cef63b
--- /dev/null
+++ b/dev-cpp/fb303/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>sin-ack@protonmail.com</email>
+ <name>sin-ack</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">facebook/fb303</remote-id>
+ </upstream>
+</pkgmetadata>