summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-04-27 23:45:55 -0700
committerMatt Turner <mattst88@gentoo.org>2020-04-28 09:38:16 -0700
commitb5f213a353266a5a4cd501c8177ed643db591555 (patch)
treed596c060f46c578f8c7dd3a87f3478d11fc88f87 /dev-cpp
parentsys-process/systemd-cron-1.5.14: x86 stable, bug 719880 (diff)
downloadgentoo-b5f213a353266a5a4cd501c8177ed643db591555.tar.gz
gentoo-b5f213a353266a5a4cd501c8177ed643db591555.tar.bz2
gentoo-b5f213a353266a5a4cd501c8177ed643db591555.zip
dev-cpp/mm-common: Version bump to 1.0.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/mm-common/Manifest1
-rw-r--r--dev-cpp/mm-common/mm-common-1.0.0.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-cpp/mm-common/Manifest b/dev-cpp/mm-common/Manifest
index 3db09611a731..898ab40de92b 100644
--- a/dev-cpp/mm-common/Manifest
+++ b/dev-cpp/mm-common/Manifest
@@ -1 +1,2 @@
DIST mm-common-0.9.12.tar.xz 304588 BLAKE2B 8fd443b4077d803bb1513c897aa44965e50591cf36518469f1f2f74c40ff2b4f687152f9fc31e2d543ac97ae7a5a0a58efdc8c362959e015eee54b8bd518809e SHA512 99701d91994ca2783fe5b8bfd44cdea9f14e16dbbc116f894d9f3df746912cdbcdbdb0d5fdf6e235c9d22621a314de7aaac9b87a18f3ab742a0ad2ebbaad8ec7
+DIST mm-common-1.0.0.tar.xz 269312 BLAKE2B 549708486f3c7df699b966e818dde4888048f30db94a78b721b8ba0e6cffa949f0c6b32e3f03861a3646f4547724997441a2f4eee1a597fb78c28e89882344e6 SHA512 5f90964ae7f47ef16919c5ae20fa38436d04e0cf6eb4b868c3a498631e1995dc5363728ebfed2678266de08adbd1c326d1a77755b232d98d02acc034f08412db
diff --git a/dev-cpp/mm-common/mm-common-1.0.0.ebuild b/dev-cpp/mm-common/mm-common-1.0.0.ebuild
new file mode 100644
index 000000000000..fd9115ced9e8
--- /dev/null
+++ b/dev-cpp/mm-common/mm-common-1.0.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org meson
+
+DESCRIPTION="Build infrastructure and utilities for GNOME C++ bindings"
+HOMEPAGE="https://www.gtkmm.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+
+src_prepare() {
+ default
+
+ # Include project version in docdir name
+ sed -i -e "s:^install_docdir.*:& + '-' + meson.project_version():" meson.build || die
+}