summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-08-30 05:51:18 +0000
committerSam James <sam@gentoo.org>2020-08-30 05:51:18 +0000
commite80822e8f1fb71bcb7faec08eade7ba7171cb29b (patch)
tree5f03fe91bfcfcd9f13f0ef900ed3b930524dff55 /dev-cpp
parentdev-cpp/yaml-cpp: Stabilize 0.6.3-r3 ppc64, #719150 (diff)
downloadgentoo-e80822e8f1fb71bcb7faec08eade7ba7171cb29b.tar.gz
gentoo-e80822e8f1fb71bcb7faec08eade7ba7171cb29b.tar.bz2
gentoo-e80822e8f1fb71bcb7faec08eade7ba7171cb29b.zip
dev-cpp/yaml-cpp: security cleanup
Closes: https://bugs.gentoo.org/719150 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/yaml-cpp/yaml-cpp-0.6.3-r2.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/dev-cpp/yaml-cpp/yaml-cpp-0.6.3-r2.ebuild b/dev-cpp/yaml-cpp/yaml-cpp-0.6.3-r2.ebuild
deleted file mode 100644
index 98223343eb1e..000000000000
--- a/dev-cpp/yaml-cpp/yaml-cpp-0.6.3-r2.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-CMAKE_ECLASS="cmake"
-inherit cmake-multilib
-
-DESCRIPTION="YAML parser and emitter in C++"
-HOMEPAGE="https://github.com/jbeder/yaml-cpp"
-SRC_URI="https://github.com/jbeder/${PN}/archive/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0/0.6"
-KEYWORDS="amd64 ~arm arm64 ~hppa ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-# test breaks build
-# RESTRICT="!test? ( test )"
-RESTRICT+="test"
-
-DEPEND="test? ( dev-cpp/gtest )"
-
-S="${WORKDIR}/${PN}-${P}"
-
-PATCHES=(
- "${FILESDIR}/${P}-abi-breakage.patch"
- "${FILESDIR}/${P}-CVE-2017-11692.patch"
-)
-
-src_prepare() {
- sed -i \
- -e 's:INCLUDE_INSTALL_ROOT_DIR:INCLUDE_INSTALL_DIR:g' \
- yaml-cpp.pc.cmake || die
-
- cmake_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_SHARED_LIBS=ON
- -DYAML_BUILD_SHARED_LIBS=ON
- -DYAML_CPP_BUILD_TOOLS=OFF # Don't have install rule
- -DYAML_CPP_BUILD_TESTS=$(usex test)
- )
-
- cmake-multilib_src_configure
-}