summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Raschbacher <lordvan@gentoo.org>2021-03-13 01:06:32 +0100
committerThomas Raschbacher <lordvan@gentoo.org>2021-03-13 01:06:43 +0100
commit180702f8e140f7e0052a68ecb6fc39779c513808 (patch)
tree5be8fcd6bc27ff8118692e53301018c8a7f8022f /dev-db/libzdb
parentgames-misc/opengfx: fix compilation with -native-symlinks (diff)
downloadgentoo-180702f8e140f7e0052a68ecb6fc39779c513808.tar.gz
gentoo-180702f8e140f7e0052a68ecb6fc39779c513808.tar.bz2
gentoo-180702f8e140f7e0052a68ecb6fc39779c513808.zip
dev-db/libzdb: fix postgresql dep and remove unneded sed from 3.2
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Thomas Raschbacher <lordvan@gentoo.org>
Diffstat (limited to 'dev-db/libzdb')
-rw-r--r--dev-db/libzdb/libzdb-3.1-r1.ebuild4
-rw-r--r--dev-db/libzdb/libzdb-3.2.2.ebuild4
2 files changed, 3 insertions, 5 deletions
diff --git a/dev-db/libzdb/libzdb-3.1-r1.ebuild b/dev-db/libzdb/libzdb-3.1-r1.ebuild
index b3ba017bb1ad..2e86113710c8 100644
--- a/dev-db/libzdb/libzdb-3.1-r1.ebuild
+++ b/dev-db/libzdb/libzdb-3.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -18,7 +18,7 @@ REQUIRED_USE=" || ( postgres mysql sqlite )"
RESTRICT=test
RDEPEND="mysql? ( dev-db/mysql-connector-c:0= )
- postgres? ( dev-db/postgresql )
+ postgres? ( dev-db/postgresql:* )
sqlite? ( >=dev-db/sqlite-3.7:3[unlock-notify(+)] )
ssl? ( dev-libs/openssl:0= )"
DEPEND="${RDEPEND}
diff --git a/dev-db/libzdb/libzdb-3.2.2.ebuild b/dev-db/libzdb/libzdb-3.2.2.ebuild
index cc039a65aee6..eda97e8cd4e3 100644
--- a/dev-db/libzdb/libzdb-3.2.2.ebuild
+++ b/dev-db/libzdb/libzdb-3.2.2.ebuild
@@ -18,7 +18,7 @@ REQUIRED_USE=" || ( postgres mysql sqlite )"
RESTRICT=test
RDEPEND="mysql? ( dev-db/mysql-connector-c:0= )
- postgres? ( dev-db/postgresql )
+ postgres? ( dev-db/postgresql:* )
sqlite? ( >=dev-db/sqlite-3.7:3[unlock-notify(+)] )
ssl? ( dev-libs/openssl:0= )"
DEPEND="${RDEPEND}
@@ -28,8 +28,6 @@ DEPEND="${RDEPEND}
src_prepare() {
default
sed -i -e "s|&& ./pool||g" test/Makefile.in || die
- # Fix detection of openssl 1.1
- sed -i -e "s|SSL_library_init|SSL_CTX_new|" configure || die
}
src_configure() {