summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2022-09-21 15:39:54 +0200
committerAgostino Sarubbo <ago@gentoo.org>2022-09-21 15:39:54 +0200
commit8f7e6fac8e9721761d7e7c73450028f54a8c2be1 (patch)
treebba3a678d6b4aa76faa082b5c0c5b23b758fb3b1 /dev-db/pg_activity
parentapp-editors/gnome-text-editor: Version bump to 43.0 (diff)
downloadgentoo-8f7e6fac8e9721761d7e7c73450028f54a8c2be1.tar.gz
gentoo-8f7e6fac8e9721761d7e7c73450028f54a8c2be1.tar.bz2
gentoo-8f7e6fac8e9721761d7e7c73450028f54a8c2be1.zip
dev-db/pg_activity: version bump to 3.0.0
Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Diffstat (limited to 'dev-db/pg_activity')
-rw-r--r--dev-db/pg_activity/Manifest1
-rw-r--r--dev-db/pg_activity/pg_activity-3.0.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-db/pg_activity/Manifest b/dev-db/pg_activity/Manifest
index 519fe54ea21c..0fe9b195f6f9 100644
--- a/dev-db/pg_activity/Manifest
+++ b/dev-db/pg_activity/Manifest
@@ -1 +1,2 @@
DIST pg_activity-2.3.1.tar.gz 283216 BLAKE2B d8a7382f3343b0e339e69e31a19bdc628d3c79ff12b037500f67900c6875272dffec3fdda8f51e20dd05a2e4e917cdac1562a8e2a9e80362358ba43ba3bdf44f SHA512 26c29ec1701cd2eead8314d2a4df247557164231c53323fb3bed12fbf346e14247addfa508af94cee685a2f0084a26c26118896c4c3395e41fb0eee4a4da2d27
+DIST pg_activity-3.0.0.tar.gz 293891 BLAKE2B 59e96c56ad0d315440b7fb62f3c9cb1c5131f4cf0a9dc6b0ccb153c4047d31edd47bc1711e151c070eeb965331397aa5f11545ba3bcd8e57e34764ddb1117544 SHA512 33ac8f9f143701a80c014e8067c547f9a998ff2fa0576fac1728162762d8542593d18718c89d23655a3c8270475933193a46af3bbf5856a4990d8efae0cc0732
diff --git a/dev-db/pg_activity/pg_activity-3.0.0.ebuild b/dev-db/pg_activity/pg_activity-3.0.0.ebuild
new file mode 100644
index 000000000000..6389027fa3a9
--- /dev/null
+++ b/dev-db/pg_activity/pg_activity-3.0.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+PYTHON_COMPAT=( python3_{9..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Realtime PostgreSQL database server monitoring tool"
+HOMEPAGE="https://github.com/dalibo/pg_activity"
+SRC_URI="https://github.com/dalibo/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+SLOT="0"
+LICENSE="POSTGRESQL"
+
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/blessed[${PYTHON_USEDEP}]
+ dev-python/humanize[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/psycopg:0[${PYTHON_USEDEP}]
+ dev-python/psycopg:2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # https://github.com/dalibo/pg_activity/issues/201
+ export COLUMNS="80"
+ epytest -k 'not test_ui.txt and not test_data.py'
+}
+
+src_install() {
+ distutils-r1_src_install
+ doman docs/man/${PN}.1
+}