summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2018-03-21 07:09:23 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2018-03-21 07:09:55 -0400
commit90665fc12ab36100aa4540faf0ac6f7c488a1df4 (patch)
tree577cd0e38dabda336bd89c8efd8a87bc7b57de1a /dev-db/pgadmin3/pgadmin3-1.22.1-r1.ebuild
parentnet-misc/ntp-4.2.8_p11: arm64 stable (diff)
downloadgentoo-90665fc12ab36100aa4540faf0ac6f7c488a1df4.tar.gz
gentoo-90665fc12ab36100aa4540faf0ac6f7c488a1df4.tar.bz2
gentoo-90665fc12ab36100aa4540faf0ac6f7c488a1df4.zip
dev-db/pgadmin3: Cleanup
Closes: https://bugs.gentoo.org/629422 Closes: https://bugs.gentoo.org/630448 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-db/pgadmin3/pgadmin3-1.22.1-r1.ebuild')
-rw-r--r--dev-db/pgadmin3/pgadmin3-1.22.1-r1.ebuild59
1 files changed, 0 insertions, 59 deletions
diff --git a/dev-db/pgadmin3/pgadmin3-1.22.1-r1.ebuild b/dev-db/pgadmin3/pgadmin3-1.22.1-r1.ebuild
deleted file mode 100644
index f2ebdc7e46e5..000000000000
--- a/dev-db/pgadmin3/pgadmin3-1.22.1-r1.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-inherit eutils multilib versionator wxwidgets
-
-DESCRIPTION="wxWidgets GUI for PostgreSQL"
-HOMEPAGE="http://www.pgadmin.org/"
-SRC_URI="mirror://postgresql/${PN}/release/v${PV}/src/${P}.tar.gz"
-
-LICENSE="POSTGRESQL"
-KEYWORDS="amd64 ppc x86 ~x86-fbsd"
-SLOT="0"
-IUSE="debug +databasedesigner"
-
-DEPEND="
- x11-libs/wxGTK:3.0=[X]
- >=dev-db/postgresql-8.4.0:=
- >=dev-libs/libxml2-2.6.18
- >=dev-libs/libxslt-1.1"
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
- local pgslot=$(postgresql-config show)
-
- if [[ ${pgslot//.} < 84 ]] ; then
- eerror "PostgreSQL slot must be set to 8.4 or higher."
- eerror " postgresql-config set 8.4"
- die "PostgreSQL slot is not set to 8.4 or higher."
- fi
-}
-
-src_prepare() {
- epatch "${FILESDIR}/pgadmin3-desktop.patch"
-
- epatch_user
-}
-
-src_configure() {
- WX_GTK_VER="3.0"
-
- setup-wxwidgets
-
- econf --with-wx-version=${WX_GTK_VER} \
- $(use_enable debug) \
- $(use_enable databasedesigner)
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- newicon "${S}/pgadmin/include/images/pgAdmin3.png" ${PN}.png
-
- domenu "${S}/pkg/pgadmin3.desktop"
-
- # Fixing world-writable files
- fperms -R go-w /usr/share
-}