summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-17 19:44:06 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-18 15:27:39 +0100
commit80e5a8d46b53ba38858b4ae645c01ce91b350939 (patch)
tree978183d4fd6b7004808798466bdb2b82d79451df /dev-debug
parentnet-libs/accounts-qml: fix bug# 922194 (diff)
downloadgentoo-80e5a8d46b53ba38858b4ae645c01ce91b350939.tar.gz
gentoo-80e5a8d46b53ba38858b4ae645c01ce91b350939.tar.bz2
gentoo-80e5a8d46b53ba38858b4ae645c01ce91b350939.zip
Move {dev-util → dev-debug}/ald
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-debug')
-rw-r--r--dev-debug/ald/Manifest1
-rw-r--r--dev-debug/ald/ald-0.1.7-r2.ebuild31
-rw-r--r--dev-debug/ald/metadata.xml15
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-debug/ald/Manifest b/dev-debug/ald/Manifest
new file mode 100644
index 000000000000..6b18c1b6f8e6
--- /dev/null
+++ b/dev-debug/ald/Manifest
@@ -0,0 +1 @@
+DIST ald-0.1.7.tar.gz 665998 BLAKE2B 52cdd01f5927a4fedc2bdd7728cd063aa3b48fda7dd3af36c4b9299b62d7cbd199f2a8ebb06457bf29c62a5024fb158944d82260b4aac77838e4338acdd33a25 SHA512 dbde0929beebe51ef5f77055b5f396630e16fd01ded4210d828f9ce97c676e7863700a98bf02d26e10cc2d8481adf329d8c8cb11c866302361221f072dbf45bf
diff --git a/dev-debug/ald/ald-0.1.7-r2.ebuild b/dev-debug/ald/ald-0.1.7-r2.ebuild
new file mode 100644
index 000000000000..008890acfa6f
--- /dev/null
+++ b/dev-debug/ald/ald-0.1.7-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit autotools
+
+DESCRIPTION="Assembly Language Debugger"
+HOMEPAGE="http://ald.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ald/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="debug ncurses"
+
+DEPEND="ncurses? ( sys-libs/ncurses:= )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # respect CFLAGS (bug #240268)
+ sed -i -e "/^CFLAGS/d" configure.ac || die 'sed on CFLAGS failed'
+ eapply_user
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable ncurses curses) \
+ $(use_enable debug assert)
+}
diff --git a/dev-debug/ald/metadata.xml b/dev-debug/ald/metadata.xml
new file mode 100644
index 000000000000..5ea1805417d5
--- /dev/null
+++ b/dev-debug/ald/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>bircoph@gentoo.org</email>
+ <name>Andrew Savchenko</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">ald</remote-id>
+ </upstream>
+ <longdescription>
+ Assembly Language Debugger --- a tool for debugging executable programs at the assembly level.
+ It currently runs only on Intel x86 platforms.
+ </longdescription>
+</pkgmetadata>