summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2024-11-08 21:08:03 +0100
committerFlorian Schmaus <flow@gentoo.org>2024-11-08 21:20:46 +0100
commitea32dd45a3103dcac4dcab04396080bff7a204ec (patch)
tree337fdb9a36586d87df57e55cee202b2584d14bf6 /dev-erlang/xmpp
parentdev-erlang/p1_mysql: add 1.0.25 (diff)
downloadgentoo-ea32dd45a3103dcac4dcab04396080bff7a204ec.tar.gz
gentoo-ea32dd45a3103dcac4dcab04396080bff7a204ec.tar.bz2
gentoo-ea32dd45a3103dcac4dcab04396080bff7a204ec.zip
dev-erlang/xmpp: add 1.9.0
Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-erlang/xmpp')
-rw-r--r--dev-erlang/xmpp/Manifest1
-rw-r--r--dev-erlang/xmpp/xmpp-1.9.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-erlang/xmpp/Manifest b/dev-erlang/xmpp/Manifest
index 707dc7b43f80..c2afdee4852c 100644
--- a/dev-erlang/xmpp/Manifest
+++ b/dev-erlang/xmpp/Manifest
@@ -1,2 +1,3 @@
DIST xmpp-1.8.1.tar.gz 626750 BLAKE2B 76f4eca77f38cb862f5e231cae403c38e0dfa100af26918756aab26a2624e019efef661381de26542bea57eafe80b91bd20d77e158a5921081d976b2d445d39c SHA512 fc53c0480e8547080cdd1c3fa3ba13736a511e2a61a14a69d2e92249d0aa127c59450b37c0b45c585ccae9fe19cf7070c6b61bad1e214a48d830935424f049cc
DIST xmpp-1.8.3.tar.gz 629078 BLAKE2B a74d624e3f9996cec8dd2bdb3c6cf1e57a5f7c7ebbad3ae9784e92d77901099a7f3444d5986ea4185a490344b2f551e00fcb8ab1e27d236a9b23814da246823d SHA512 4f925a611258617c8a49feb90b174dc8889e91beb1b3bf091527e1fb32d6a8ed5b167a8fd51778745d71de67efec1615dbbd6a539b49f0af216c6822472c9b54
+DIST xmpp-1.9.0.tar.gz 632957 BLAKE2B e9b4a6c9c079e99b50cc75eaf9f194cd2a8ff200951b7b5d03c99919c27a90bd6ad691a5fc9ddd72302711051b9284670b8e1c5b6773f7f7133bf482a8b29df0 SHA512 19005703c6b4d3f1bc8e411632a16417261e9dff5a31787faad9fbc323ac9dc034d4bc03a76f0b4fb6d51d1f96593286710a6f998bce732deac39e207dcbb1b2
diff --git a/dev-erlang/xmpp/xmpp-1.9.0.ebuild b/dev-erlang/xmpp/xmpp-1.9.0.ebuild
new file mode 100644
index 000000000000..0dbf26c3fb93
--- /dev/null
+++ b/dev-erlang/xmpp/xmpp-1.9.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit rebar
+
+DESCRIPTION="XMPP parsing and serialization library on top of Fast XML"
+HOMEPAGE="https://github.com/processone/xmpp"
+SRC_URI="https://github.com/processone/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~sparc ~x86"
+
+RDEPEND="
+ >=dev-erlang/ezlib-1.0.13
+ >=dev-erlang/fast_tls-1.1.22
+ >=dev-erlang/fast_xml-1.1.53
+ >=dev-erlang/p1_utils-1.0.26
+ >=dev-erlang/stringprep-1.0.30
+ >=dev-erlang/idna-6.0.0-r1
+"
+DEPEND="${RDEPEND}"
+
+DOCS=( CHANGELOG.md README.md )
+
+src_prepare() {
+ rebar_src_prepare
+ rebar_fix_include_path fast_xml
+}