summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <alexey+gentoo@asokolov.org>2021-08-09 17:51:00 +0100
committerJoonas Niilola <juippis@gentoo.org>2021-08-16 11:30:19 +0300
commit02986e4be05522eb9a453b2afa7c2a5058ef20e7 (patch)
treee5d49df19eba9d43ec7b4348a1d87f58ab322920 /dev-games/recastnavigation
parentx11-misc/copyq: add missing deps (diff)
downloadgentoo-02986e4be05522eb9a453b2afa7c2a5058ef20e7.tar.gz
gentoo-02986e4be05522eb9a453b2afa7c2a5058ef20e7.tar.bz2
gentoo-02986e4be05522eb9a453b2afa7c2a5058ef20e7.zip
dev-games/recastnavigation: version bump to 1.5.1_p20210305
Unbundle catch dep Closes: https://bugs.gentoo.org/806950 Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-games/recastnavigation')
-rw-r--r--dev-games/recastnavigation/Manifest1
-rw-r--r--dev-games/recastnavigation/recastnavigation-1.5.1_p20210305.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-games/recastnavigation/Manifest b/dev-games/recastnavigation/Manifest
index e300d02e460a..3d6e7560cebd 100644
--- a/dev-games/recastnavigation/Manifest
+++ b/dev-games/recastnavigation/Manifest
@@ -1 +1,2 @@
DIST recastnavigation-1.5.1_p20200511.tar.gz 1541540 BLAKE2B 3878294247e26421c33019c05a8d70f9ae04ce046d1e503b2df8297e5c390c592e0222c445c9a7798c2e3eb7090b6c32d18b94015dce0a248ab17198d3054dda SHA512 bc48d9195c1ce4422359d850ad422e53c2599ff575b8c7a0ce6b7dc42720d7edd99781a1efa7bee49a00cd4ce6734f34ce9d434421471cb0cbf8e5207bbebebc
+DIST recastnavigation-1.5.1_p20210305.tar.gz 1542880 BLAKE2B f1066a48c7269fe67deba17768187522db9c0ece11293a3ff54311a6400cd38f32340985729bb38109bc1262099b44b7bf92974dfeb80c47953e58e6eeab73ea SHA512 7c3a8ce3e38de81eeb31332584896af9f234826c7f7f831eccb36972746c8b528ffde7ae4ee0d25baf814ece030a4b029101e07ea89aacc33c6d44f1ae2cf265
diff --git a/dev-games/recastnavigation/recastnavigation-1.5.1_p20210305.ebuild b/dev-games/recastnavigation/recastnavigation-1.5.1_p20210305.ebuild
new file mode 100644
index 000000000000..879d46837a6b
--- /dev/null
+++ b/dev-games/recastnavigation/recastnavigation-1.5.1_p20210305.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="Navigation mesh construction toolset for games"
+HOMEPAGE="https://github.com/recastnavigation/recastnavigation"
+MY_COMMIT="c5cbd53024c8a9d8d097a4371215e3342d2fdc87"
+SRC_URI="https://github.com/recastnavigation/recastnavigation/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_COMMIT}"
+
+LICENSE="ZLIB"
+SLOT="0/1.5.1"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( dev-cpp/catch )"
+
+src_prepare() {
+ rm Tests/catch.hpp || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ append-cppflags "-I${ESYSROOT}/usr/include/catch2"
+
+ local mycmakeargs=(
+ -DRECASTNAVIGATION_DEMO=OFF
+ -DRECASTNAVIGATION_EXAMPLES=OFF
+ -DRECASTNAVIGATION_TESTS=$(usex test)
+ )
+
+ cmake_src_configure
+}