summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-go/go-snappy
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-go/go-snappy')
-rw-r--r--dev-go/go-snappy/Manifest1
-rw-r--r--dev-go/go-snappy/go-snappy-0_pre20150729.ebuild59
-rw-r--r--dev-go/go-snappy/go-snappy-9999.ebuild26
-rw-r--r--dev-go/go-snappy/metadata.xml10
4 files changed, 96 insertions, 0 deletions
diff --git a/dev-go/go-snappy/Manifest b/dev-go/go-snappy/Manifest
new file mode 100644
index 000000000000..9e68da2ff822
--- /dev/null
+++ b/dev-go/go-snappy/Manifest
@@ -0,0 +1 @@
+DIST go-snappy-0_pre20150729.tar.gz 10085 SHA256 7df12835634e18e96cb3239f870404d5c5a6a20ad3706534a43418c23f5c107e SHA512 84f285f34f547f1da6b0fc87b61a699ac3e8b8d762c0aaa3d71b22869c51d76eb5a5fc3d9b8d3571591eb955fdde9a7a293935e1d40f76c5dd01cc02710b209a WHIRLPOOL 74940645fb51ffb3bedae94dd513b3a153f8cf91285a09eca52d1e0861af20872834ea24034c7fb6de1e13169b566ae155f6937cc0b22fba86bfc02dafa2e3c5
diff --git a/dev-go/go-snappy/go-snappy-0_pre20150729.ebuild b/dev-go/go-snappy/go-snappy-0_pre20150729.ebuild
new file mode 100644
index 000000000000..d06f1cc5a80e
--- /dev/null
+++ b/dev-go/go-snappy/go-snappy-0_pre20150729.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+EGO_SRC=github.com/golang/snappy
+EGO_PN=${EGO_SRC}/...
+
+if [[ ${PV} = *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64"
+ EGIT_COMMIT="723cc1e459b8eea2dea4583200fd60757d40097a"
+ SRC_URI="https://${EGO_SRC}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+fi
+inherit golang-build
+
+DESCRIPTION="The Snappy compression format in the Go programming language."
+HOMEPAGE="https://${EGO_SRC}"
+LICENSE="BSD"
+SLOT="0/${PV}"
+IUSE=""
+DEPEND=""
+RDEPEND=""
+
+if [[ ${PV} != *9999* ]]; then
+src_unpack() {
+ local f
+
+ for f in ${A}
+ do
+ case "${f}" in
+ *.tar|*.tar.gz|*.tar.bz2|*.tar.xz)
+ local destdir=${WORKDIR}/${P}/src/${EGO_SRC}
+
+ debug-print "${FUNCNAME}: unpacking ${f} to ${destdir}"
+
+ # XXX: check whether the directory structure inside is
+ # fine? i.e. if the tarball has actually a parent dir.
+ mkdir -p "${destdir}" || die
+ tar -C "${destdir}" -x --strip-components 1 \
+ -f "${DISTDIR}/${f}" || die
+ ;;
+ *)
+ debug-print "${FUNCNAME}: falling back to unpack for ${f}"
+
+ # fall back to the default method
+ unpack "${f}"
+ ;;
+ esac
+ done
+}
+fi
+
+src_install() {
+ rm -rf src/${EGO_SRC}/.git* || die
+ golang-build_src_install
+}
diff --git a/dev-go/go-snappy/go-snappy-9999.ebuild b/dev-go/go-snappy/go-snappy-9999.ebuild
new file mode 100644
index 000000000000..eb2196bbefb8
--- /dev/null
+++ b/dev-go/go-snappy/go-snappy-9999.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+EGO_SRC=github.com/golang/snappy
+EGO_PN=${EGO_SRC}/...
+
+if [[ ${PV} = *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64"
+ EGIT_COMMIT="723cc1e459b8eea2dea4583200fd60757d40097a"
+ SRC_URI="https://${EGO_SRC}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
+fi
+inherit golang-build
+
+DESCRIPTION="The Snappy compression format in the Go programming language."
+HOMEPAGE="https://${EGO_SRC}"
+LICENSE="BSD"
+SLOT="0/${PV}"
+IUSE=""
+DEPEND=""
+RDEPEND=""
diff --git a/dev-go/go-snappy/metadata.xml b/dev-go/go-snappy/metadata.xml
new file mode 100644
index 000000000000..f36062738a6c
--- /dev/null
+++ b/dev-go/go-snappy/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>zmedico@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">golang/snappy</remote-id>
+ </upstream>
+</pkgmetadata>