summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-05-29 14:04:08 -0400
committerAnthony G. Basile <blueness@gentoo.org>2016-05-29 14:04:20 -0400
commita31c1fdac2f410bf22c9fb388f5e094d8776a973 (patch)
tree5a7ca81c8b6a55ac533aaf1206a9cb8793d299fa /dev-go/goptlib/goptlib-0.6.ebuild
parentx11-drivers/xf86-video-omapfb: fix building against glibc-2.20 (diff)
downloadgentoo-a31c1fdac2f410bf22c9fb388f5e094d8776a973.tar.gz
gentoo-a31c1fdac2f410bf22c9fb388f5e094d8776a973.tar.bz2
gentoo-a31c1fdac2f410bf22c9fb388f5e094d8776a973.zip
dev-go/goptlib: bump to version 0.6
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-go/goptlib/goptlib-0.6.ebuild')
-rw-r--r--dev-go/goptlib/goptlib-0.6.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-go/goptlib/goptlib-0.6.ebuild b/dev-go/goptlib/goptlib-0.6.ebuild
new file mode 100644
index 000000000000..3d2eaba8a8bb
--- /dev/null
+++ b/dev-go/goptlib/goptlib-0.6.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit golang-build golang-vcs-snapshot
+
+EGO_SRC=git.torproject.org/pluggable-transports/goptlib.git
+EGO_PN=${EGO_SRC}/...
+EGIT_COMMIT="${PV}"
+
+DESCRIPTION="Go Tor pluggable transports library"
+HOMEPAGE="https://gitweb.torproject.org/pluggable-transports/goptlib.git"
+# No official tarballs; see https://trac.torproject.org/projects/tor/ticket/18504
+SRC_URI="mirror://debian/pool/main/g/golang-${PN}/golang-${P/-/_}.orig.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64"
+
+LICENSE="CC0-1.0"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""