summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2020-07-29 11:42:20 +1000
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-01 09:00:00 +0100
commitd36be498eb56d94b83b727bcbc54b178117f1b55 (patch)
treec6cdc12da4a231f0bbaef7e328e1914e89310b9c /dev-haskell/ansi-terminal/ansi-terminal-0.10.3.ebuild
parentdev-haskell/aeson: bump up to 1.4.7.1 (diff)
downloadgentoo-d36be498eb56d94b83b727bcbc54b178117f1b55.tar.gz
gentoo-d36be498eb56d94b83b727bcbc54b178117f1b55.tar.bz2
gentoo-d36be498eb56d94b83b727bcbc54b178117f1b55.zip
dev-haskell/ansi-terminal: bump up to 0.10.3
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/ansi-terminal/ansi-terminal-0.10.3.ebuild')
-rw-r--r--dev-haskell/ansi-terminal/ansi-terminal-0.10.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-haskell/ansi-terminal/ansi-terminal-0.10.3.ebuild b/dev-haskell/ansi-terminal/ansi-terminal-0.10.3.ebuild
new file mode 100644
index 000000000000..98a4b995a5ea
--- /dev/null
+++ b/dev-haskell/ansi-terminal/ansi-terminal-0.10.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.4
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Simple ANSI terminal support, with Windows compatibility"
+HOMEPAGE="https://github.com/feuerbach/ansi-terminal"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="example"
+
+RDEPEND=">=dev-haskell/colour-2.1.0:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag example example)
+}