summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2020-07-30 10:44:34 +1000
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-01 09:02:12 +0100
commit2e7ed3c94bcfd9648eb162ee0b75af6936b6666e (patch)
tree294fbba375f36be6601370d300e0f275309e25df /dev-haskell/aws
parentdev-haskell/network-bsd: add package (diff)
downloadgentoo-2e7ed3c94bcfd9648eb162ee0b75af6936b6666e.tar.gz
gentoo-2e7ed3c94bcfd9648eb162ee0b75af6936b6666e.tar.bz2
gentoo-2e7ed3c94bcfd9648eb162ee0b75af6936b6666e.zip
dev-haskell/aws: bump up to 0.22
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/aws')
-rw-r--r--dev-haskell/aws/Manifest1
-rw-r--r--dev-haskell/aws/aws-0.22-r1.ebuild79
-rw-r--r--dev-haskell/aws/metadata.xml3
3 files changed, 83 insertions, 0 deletions
diff --git a/dev-haskell/aws/Manifest b/dev-haskell/aws/Manifest
index a32037608ec8..b0ee06ca1980 100644
--- a/dev-haskell/aws/Manifest
+++ b/dev-haskell/aws/Manifest
@@ -1,3 +1,4 @@
DIST aws-0.11.3.tar.gz 90102 BLAKE2B 4a22b5fe3cabdaeda68229ac9bd653221242a17c259245c650a9e92fed87ee8d58ed3cef4cbc732d0c5f8e92481b42d4a3be4a5b3ecb5c183e52e9e922941938 SHA512 0343d8ef17ad06525c7c131eb97408d3298c46f4dd472604bd4b3a20c2bb1e880e12f9a0e345ee2fe9bfe56b684fd653e9a99b7919e8d97fce4ca0cdd720afb5
DIST aws-0.12.1.tar.gz 90763 BLAKE2B ef33803420a163c51386165e3d3b94efb61d1e8d4983ab7c23e6c94b09b4f8638e2663657587a1b1ed381446e01a9bc120ca4a3ef9057114698ab870332961e2 SHA512 8c89a982196b654ad4f001d30cb415a9272aacb582c8879173babc4183ca4eb21c025399f1bb5e2624a77a1c38da9b4637bf1dfa0a5bbccb888808a5e654bbf9
DIST aws-0.14.1.tar.gz 95017 BLAKE2B eab2eccdfc160b16ccd35e6028854e8bcaebf3309269199be752a240a2757a69be496eae0e6d757a814d1d0f6b30f0d3f6cd87954a95a5aaf2d8347245956b29 SHA512 0616d085291748d3ec1ef24d7914562f85fde0577f8100b0dd7f8bc2c817fffb4945372fb80aad98dce652fbf1f063a55afe3ba7aff89ddd5bcd2ba43047ad8c
+DIST aws-0.22.tar.gz 106122 BLAKE2B b4ff46e2742d53323c80952c303a4605d13600fd60085a2e0501af2fc0a74f0c2769c6bf0692710bbfd972c474b9cab26fd97e9126fdcfb3eaff90afbab1d9ae SHA512 e7ff376c47a7ca7a65c8f10f19e591d4a4b4d2cfa333b4727f88f0b170d7acb0aff402617f2d617c522fe5d16ce92b249a23f1fb0a8bfe5bbefaef2931b786bd
diff --git a/dev-haskell/aws/aws-0.22-r1.ebuild b/dev-haskell/aws/aws-0.22-r1.ebuild
new file mode 100644
index 000000000000..d5a5b18362a0
--- /dev/null
+++ b/dev-haskell/aws/aws-0.22-r1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.4.9999
+#hackport: flags: networkbsd:network-3
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Amazon Web Services (AWS) for Haskell"
+HOMEPAGE="https://github.com/aristidb/aws"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+network-3 examples"
+
+RESTRICT=test # requires aws account
+
+RDEPEND=">=dev-haskell/aeson-0.6:=[profile?]
+ >=dev-haskell/attoparsec-0.11:=[profile?] <dev-haskell/attoparsec-0.14:=[profile?]
+ >=dev-haskell/base16-bytestring-0.1:=[profile?] <dev-haskell/base16-bytestring-0.2:=[profile?]
+ >=dev-haskell/base64-bytestring-1.0:=[profile?] <dev-haskell/base64-bytestring-1.1:=[profile?]
+ >=dev-haskell/blaze-builder-0.2.1.4:=[profile?] <dev-haskell/blaze-builder-0.5:=[profile?]
+ >=dev-haskell/byteable-0.1:=[profile?] <dev-haskell/byteable-0.2:=[profile?]
+ >=dev-haskell/case-insensitive-0.2:=[profile?] <dev-haskell/case-insensitive-1.3:=[profile?]
+ >=dev-haskell/cereal-0.3:=[profile?] <dev-haskell/cereal-0.6:=[profile?]
+ >=dev-haskell/conduit-1.3:=[profile?] <dev-haskell/conduit-1.4:=[profile?]
+ >=dev-haskell/conduit-extra-1.3:=[profile?] <dev-haskell/conduit-extra-1.4:=[profile?]
+ >=dev-haskell/cryptonite-0.11:=[profile?]
+ >=dev-haskell/data-default-0.5.3:=[profile?] <dev-haskell/data-default-0.8:=[profile?]
+ >=dev-haskell/exceptions-0.8:=[profile?] <dev-haskell/exceptions-0.11:=[profile?]
+ >=dev-haskell/http-client-tls-0.3:=[profile?] <dev-haskell/http-client-tls-0.4:=[profile?]
+ >=dev-haskell/http-conduit-2.3:=[profile?] <dev-haskell/http-conduit-2.4:=[profile?]
+ >=dev-haskell/http-types-0.7:=[profile?] <dev-haskell/http-types-1.0:=[profile?]
+ >=dev-haskell/lifted-base-0.1:=[profile?] <dev-haskell/lifted-base-0.3:=[profile?]
+ dev-haskell/memory:=[profile?]
+ >=dev-haskell/monad-control-0.3:=[profile?]
+ >=dev-haskell/mtl-2:=[profile?] <dev-haskell/mtl-3:=[profile?]
+ >=dev-haskell/old-locale-1:=[profile?] <dev-haskell/old-locale-2:=[profile?]
+ >=dev-haskell/resourcet-1.2:=[profile?] <dev-haskell/resourcet-1.3:=[profile?]
+ >=dev-haskell/safe-0.3:=[profile?] <dev-haskell/safe-0.4:=[profile?]
+ >=dev-haskell/scientific-0.3:=[profile?]
+ >=dev-haskell/semigroups-0.18:=[profile?] <dev-haskell/semigroups-0.19:=[profile?]
+ >=dev-haskell/tagged-0.7:=[profile?] <dev-haskell/tagged-0.9:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ >=dev-haskell/unordered-containers-0.2:=[profile?]
+ >=dev-haskell/utf8-string-0.3:=[profile?] <dev-haskell/utf8-string-1.1:=[profile?]
+ >=dev-haskell/vector-0.10:=[profile?]
+ >=dev-haskell/xml-conduit-1.8:=[profile?] <dev-haskell/xml-conduit-2.0:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+ examples? ( >=dev-haskell/errors-2.0:=[profile?] )
+ network-3? ( >=dev-haskell/network-3:=[profile?] <dev-haskell/network-4:=[profile?]
+ >=dev-haskell/network-bsd-2.8:=[profile?] <dev-haskell/network-bsd-2.9:=[profile?] )
+ !network-3? ( >=dev-haskell/network-2:=[profile?] <dev-haskell/network-3:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( >=dev-haskell/aeson-0.7
+ >=dev-haskell/http-client-0.3 <dev-haskell/http-client-0.7
+ >=dev-haskell/lifted-base-0.2
+ >=dev-haskell/mtl-2.1
+ >=dev-haskell/quickcheck-2.7
+ >=dev-haskell/quickcheck-instances-0.3
+ >=dev-haskell/tasty-0.8
+ >=dev-haskell/tasty-hunit-0.8
+ >=dev-haskell/tasty-quickcheck-0.8
+ >=dev-haskell/text-1.1
+ >=dev-haskell/transformers-base-0.4
+ !examples? ( >=dev-haskell/errors-2.0 ) )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag examples examples) \
+ $(cabal_flag network-3 networkbsd)
+}
diff --git a/dev-haskell/aws/metadata.xml b/dev-haskell/aws/metadata.xml
index f05125d63240..de6f465da317 100644
--- a/dev-haskell/aws/metadata.xml
+++ b/dev-haskell/aws/metadata.xml
@@ -5,6 +5,9 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
+ <use>
+ <flag name="network-3">Use network-3</flag>
+ </use>
<longdescription>
Bindings for Amazon Web Services (AWS), with the aim of supporting all AWS services. To see a high level overview of the library, see the README at &lt;https://github.com/aristidb/aws/blob/master/README.org&gt;.
</longdescription>