summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/cmdargs
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/cmdargs')
-rw-r--r--dev-haskell/cmdargs/Manifest3
-rw-r--r--dev-haskell/cmdargs/cmdargs-0.10.12.ebuild32
-rw-r--r--dev-haskell/cmdargs/cmdargs-0.10.13.ebuild32
-rw-r--r--dev-haskell/cmdargs/cmdargs-0.10.7.ebuild32
-rw-r--r--dev-haskell/cmdargs/metadata.xml29
5 files changed, 128 insertions, 0 deletions
diff --git a/dev-haskell/cmdargs/Manifest b/dev-haskell/cmdargs/Manifest
new file mode 100644
index 000000000000..a7add43469a3
--- /dev/null
+++ b/dev-haskell/cmdargs/Manifest
@@ -0,0 +1,3 @@
+DIST cmdargs-0.10.12.tar.gz 63723 SHA256 5e66581205cb76a2621a7bf5cb42411a8cc1d37fe3b8a266803266c2991fb62b SHA512 0936fea732dc8771a54e3dce75e9068ebfd3ca8791f1bec8e0ce564c55973d93b91d98505bca2c7e5a9984b166f472deda3c71beeef92ce800acec5ac1584319 WHIRLPOOL a8fc831dca830634454d6e15436b3912ee64395add7e514b4441942f5de431ce9f4f2e30aeb5c375adb0e1d7d7f648570a8fb2b2da52742703bf92b54443636d
+DIST cmdargs-0.10.13.tar.gz 64008 SHA256 66117c1fadaa2a79be07998287ca7cee334c249615b0fab9b91467ad813bbf6e SHA512 d4d0b93ca19b9ecdcea472b38b836c254a5e8a5ffe488c95d98f16395579483993fe0f7266d80771b85f1ed4683e34a6a3b493fe8e23595c1ba4db68a8daa0df WHIRLPOOL 595c3d27a48810fd435a99048ca2d3096d40216ca9275a70a7184c63ef331f660e9354af5e032eb53427e4580992a61855f26abe880815b58e7d0abe18da24ae
+DIST cmdargs-0.10.7.tar.gz 61526 SHA256 d4dd12902a89c1d505fd25f49834ce7ae681461eebb6d779bd345abf8f901a56 SHA512 b9091e4f708db1e7c8bac367c4faad5c311a3194aefbf2776316b4ecc559314f01ceb0102df007819996b00200c5300e5b56e1035d45561e924bbfc3b38b656a WHIRLPOOL 5624e9672d28a2ac1805d5b28aed63aaaac9a4f1f97527a0f324e55f72e3c0e4409dda7daa42bee9afde9aa4ac4e0f874d17bacb3c28de2918b1969673d41767
diff --git a/dev-haskell/cmdargs/cmdargs-0.10.12.ebuild b/dev-haskell/cmdargs/cmdargs-0.10.12.ebuild
new file mode 100644
index 000000000000..29ae0bdfebd0
--- /dev/null
+++ b/dev-haskell/cmdargs/cmdargs-0.10.12.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Command line argument processing"
+HOMEPAGE="http://community.haskell.org/~ndm/cmdargs/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+quotation testprog"
+
+RDEPEND=">=dev-haskell/transformers-0.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag quotation quotation) \
+ $(cabal_flag testprog testprog)
+}
diff --git a/dev-haskell/cmdargs/cmdargs-0.10.13.ebuild b/dev-haskell/cmdargs/cmdargs-0.10.13.ebuild
new file mode 100644
index 000000000000..ca962aebc4e4
--- /dev/null
+++ b/dev-haskell/cmdargs/cmdargs-0.10.13.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Command line argument processing"
+HOMEPAGE="http://community.haskell.org/~ndm/cmdargs/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+quotation testprog"
+
+RDEPEND=">=dev-haskell/transformers-0.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag quotation quotation) \
+ $(cabal_flag testprog testprog)
+}
diff --git a/dev-haskell/cmdargs/cmdargs-0.10.7.ebuild b/dev-haskell/cmdargs/cmdargs-0.10.7.ebuild
new file mode 100644
index 000000000000..37b6ef56a9c9
--- /dev/null
+++ b/dev-haskell/cmdargs/cmdargs-0.10.7.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.5.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Command line argument processing"
+HOMEPAGE="http://community.haskell.org/~ndm/cmdargs/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE="+quotation testprog"
+
+RDEPEND=">=dev-haskell/transformers-0.2:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6.0.3
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag quotation quotation) \
+ $(cabal_flag testprog testprog)
+}
diff --git a/dev-haskell/cmdargs/metadata.xml b/dev-haskell/cmdargs/metadata.xml
new file mode 100644
index 000000000000..30d92e9f032d
--- /dev/null
+++ b/dev-haskell/cmdargs/metadata.xml
@@ -0,0 +1,29 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ This library provides an easy way to define command line parsers. Most users
+ will want to use the &quot;System.Console.CmdArgs.Implicit&quot; module, whose
+ documentation contains an example.
+
+ * &quot;System.Console.CmdArgs.Explicit&quot; provides a way to write command line
+ parsers for both single mode programs (most programs) and multiple
+ mode programs (e.g. darcs or cabal). Parsers are defined by constructing
+ a data structure.
+
+ * &quot;System.Console.CmdArgs.Implicit&quot; provides a way to concisely define
+ command line parsers, up to three times shorter than getopt. These parsers
+ are translated into the Explicit data type.
+
+ * &quot;System.Console.CmdArgs.GetOpt&quot; provides a wrapper allowing compatiblity
+ with existing getopt parsers, mapping to the Explicit data type.
+
+ For a general reference on what command line flags are commonly used,
+ see &lt;http://www.faqs.org/docs/artu/ch10s05.html&gt;.
+ </longdescription>
+ <use>
+ <flag name="testprog">Build the test program</flag>
+ <flag name="quotation">Build quote module</flag>
+ </use>
+</pkgmetadata>