summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-10 23:02:54 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-11 00:22:38 +0100
commit064af661d0c9a31cecdf348632bc5603333a9149 (patch)
tree2202373a7cafcb8a761d32747d4f62263aed64d5 /dev-haskell/scientific
parentdev-python/passlib: keyworded 1.7.1-r2 for hppa, bug #700918 (diff)
downloadgentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.gz
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.bz2
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.zip
*/*: [QA] Fix trivial cases of MissingTestRestrict
The result was achieved via the following pipeline: pkgcheck scan -c RestrictTestCheck -R FormatReporter \ --format '{category}/{package}/{package}-{version}.ebuild' | xargs -n32 grep -L RESTRICT | xargs -n32 sed -i -e '/^IUSE=.*test/aRESTRICT="!test? ( test )"' The resulting metadata was compared before and after the change. Few Go ebuilds had to be fixed manually due to implicit RESTRICT=strip added by the eclass. Two ebuilds have to be fixed because of multiline IUSE. Suggested-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13942 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-haskell/scientific')
-rw-r--r--dev-haskell/scientific/scientific-0.3.3.8.ebuild1
-rw-r--r--dev-haskell/scientific/scientific-0.3.4.4.ebuild1
-rw-r--r--dev-haskell/scientific/scientific-0.3.4.6.ebuild1
3 files changed, 3 insertions, 0 deletions
diff --git a/dev-haskell/scientific/scientific-0.3.3.8.ebuild b/dev-haskell/scientific/scientific-0.3.3.8.ebuild
index 3b544c4e6cda..7b5860057005 100644
--- a/dev-haskell/scientific/scientific-0.3.3.8.ebuild
+++ b/dev-haskell/scientific/scientific-0.3.3.8.ebuild
@@ -16,6 +16,7 @@ LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="amd64 x86"
IUSE="+bytestring-builder"
+RESTRICT="!test? ( test )"
RDEPEND=">=dev-haskell/hashable-1.1.2:=[profile?] <dev-haskell/hashable-1.3:=[profile?]
>=dev-haskell/text-0.8:=[profile?] <dev-haskell/text-1.3:=[profile?]
diff --git a/dev-haskell/scientific/scientific-0.3.4.4.ebuild b/dev-haskell/scientific/scientific-0.3.4.4.ebuild
index 651786af93af..63d0143a8536 100644
--- a/dev-haskell/scientific/scientific-0.3.4.4.ebuild
+++ b/dev-haskell/scientific/scientific-0.3.4.4.ebuild
@@ -16,6 +16,7 @@ LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE="+bytestring-builder"
+RESTRICT="!test? ( test )"
RDEPEND=">=dev-haskell/binary-0.4.1:=[profile?] <dev-haskell/binary-0.8:=[profile?]
>=dev-haskell/hashable-1.1.2:=[profile?] <dev-haskell/hashable-1.3:=[profile?]
diff --git a/dev-haskell/scientific/scientific-0.3.4.6.ebuild b/dev-haskell/scientific/scientific-0.3.4.6.ebuild
index fea0e594f622..e812a36edaf3 100644
--- a/dev-haskell/scientific/scientific-0.3.4.6.ebuild
+++ b/dev-haskell/scientific/scientific-0.3.4.6.ebuild
@@ -16,6 +16,7 @@ LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE="+bytestring-builder"
+RESTRICT="!test? ( test )"
RDEPEND=">=dev-haskell/binary-0.4.1:=[profile?] <dev-haskell/binary-0.9:=[profile?]
>=dev-haskell/hashable-1.1.2:=[profile?] <dev-haskell/hashable-1.3:=[profile?]