summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormatoro <matoro@users.noreply.github.com>2022-07-11 21:05:47 -0400
committerSam James <sam@gentoo.org>2022-07-22 22:15:46 +0000
commitabef21421fec599183c6fee935328abf38c0c19f (patch)
tree3cdb45a1aa35e6f7e37043839b6ef40998f3ce35 /dev-haskell/tasty
parentdev-haskell/tagsoup: keyword 0.14.8 for ~ppc64 (diff)
downloadgentoo-abef21421fec599183c6fee935328abf38c0c19f.tar.gz
gentoo-abef21421fec599183c6fee935328abf38c0c19f.tar.bz2
gentoo-abef21421fec599183c6fee935328abf38c0c19f.zip
dev-haskell/tasty: add 1.4.2.3
Signed-off-by: matoro <matoro@users.noreply.github.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/tasty')
-rw-r--r--dev-haskell/tasty/Manifest1
-rw-r--r--dev-haskell/tasty/tasty-1.4.2.3.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-haskell/tasty/Manifest b/dev-haskell/tasty/Manifest
index 13870b85d4e9..c4f8be1e1066 100644
--- a/dev-haskell/tasty/Manifest
+++ b/dev-haskell/tasty/Manifest
@@ -1 +1,2 @@
DIST tasty-1.2.3.tar.gz 49148 BLAKE2B 8de7436bca740e55a6592e833326b03f001823c74c8678ae5d38c2c836249a9af08321df6245573e5d060a25e9512c1f601a62978f2b3f22ee846d3cef72a829 SHA512 3922fc19c3ed74b1a39f8e6dc5fe243a955ab55d2e9d08d68b0932dfa0d16cb1efbc73bb2d793c1226d56986141494ce0490c9af70e7e612d07da64d5e2ee472
+DIST tasty-1.4.2.3.tar.gz 58549 BLAKE2B 7e806ef62a455a9bd71782800e0a53b327963ea12e7dff7bc508560457dc84c6b94aa8a8b67524b3ea8b7629d5d78bd63a56790e9bbdb356393f306b271b97a8 SHA512 c5f03406e4a7b0c8ff98de285cc778a7751c535d62bb69da962f78ad4eadaf76a74d3bd2c81b1c7553b5de4a527be964c568a8311929a0dce44389c3fcaf521e
diff --git a/dev-haskell/tasty/tasty-1.4.2.3.ebuild b/dev-haskell/tasty/tasty-1.4.2.3.ebuild
new file mode 100644
index 000000000000..4f69152fb684
--- /dev/null
+++ b/dev-haskell/tasty/tasty-1.4.2.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.1.1.9999
+#hackport: flags: +clock,+unix
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Modern and extensible testing framework"
+HOMEPAGE="https://github.com/UnkindPartition/tasty"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND=">=dev-haskell/ansi-terminal-0.9:=[profile?]
+ >=dev-haskell/clock-0.4.4.0:=[profile?]
+ >=dev-haskell/optparse-applicative-0.14:=[profile?]
+ >=dev-haskell/stm-2.3:=[profile?]
+ >=dev-haskell/tagged-0.5:=[profile?]
+ >=dev-haskell/unbounded-delays-0.1:=[profile?]
+ dev-haskell/wcwidth:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=clock \
+ --flag=unix
+}