summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormatoro <matoro@users.noreply.github.com>2022-07-11 23:41:08 -0400
committerSam James <sam@gentoo.org>2022-07-22 22:15:58 +0000
commit2f189af621f6253d9b153e83334eedc7c6e7ef7e (patch)
tree89116432c231a5ccad23fbd7f7b639c894b5e009 /dev-haskell/uniplate
parentdev-haskell/unicode-transforms: revbump 0.3.7.1-r1 (diff)
downloadgentoo-2f189af621f6253d9b153e83334eedc7c6e7ef7e.tar.gz
gentoo-2f189af621f6253d9b153e83334eedc7c6e7ef7e.tar.bz2
gentoo-2f189af621f6253d9b153e83334eedc7c6e7ef7e.zip
dev-haskell/uniplate: add 1.6.13
Signed-off-by: matoro <matoro@users.noreply.github.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/uniplate')
-rw-r--r--dev-haskell/uniplate/Manifest1
-rw-r--r--dev-haskell/uniplate/uniplate-1.6.13.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-haskell/uniplate/Manifest b/dev-haskell/uniplate/Manifest
index cb5afe6aa775..f81e8bbe92cf 100644
--- a/dev-haskell/uniplate/Manifest
+++ b/dev-haskell/uniplate/Manifest
@@ -1 +1,2 @@
DIST uniplate-1.6.12.tar.gz 30055 BLAKE2B 557c3eeb14c0b292d4e0325a711babec39a76829822aee07e38ee49f7a4c3f82e72e6231c00fad1c7831864a7df4a9e12b3e913b60fe0e227d651d39c73300af SHA512 049b07e8a57db7e44d91fc9c8dcfb5c49b78a692a730061763cb8bcc4fbc3ed1065bd7a4c337e3d344693df882a0718b6d3bb6a6ea1e7d520a36d252d7038b07
+DIST uniplate-1.6.13.tar.gz 29787 BLAKE2B 345b5c523469ccc4d98ebdf7498fbdfe9ae183af46c4cc1e1fcdc0782d6dd31d40f53e5ee04d652beb048c62c0d0241d6336eefd87cbfc10d4c0d7bb647b29ad SHA512 8cab820d40b318c7483319de4174bdbd3637e1c93f42bc6b796c6a8a1fa93331c0a2ff3b7c77f6a2ec0509fb48bb922ef732c7d79e8e6bcf7987bde949459310
diff --git a/dev-haskell/uniplate/uniplate-1.6.13.ebuild b/dev-haskell/uniplate/uniplate-1.6.13.ebuild
new file mode 100644
index 000000000000..fc1036f70164
--- /dev/null
+++ b/dev-haskell/uniplate/uniplate-1.6.13.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.7.9999
+#hackport: flags: +separate_syb,+typeable_fingerprint
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Help writing simple, concise and fast generic operations"
+HOMEPAGE="https://github.com/ndmitchell/uniplate#readme"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/hashable-1.1.2.3:=[profile?]
+ dev-haskell/syb:=[profile?]
+ >=dev-haskell/unordered-containers-0.2.1:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=separate_syb \
+ --flag=typeable_fingerprint
+}