summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/commons-jxpath
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/commons-jxpath')
-rw-r--r--dev-java/commons-jxpath/Manifest1
-rw-r--r--dev-java/commons-jxpath/commons-jxpath-1.3-r1.ebuild61
-rw-r--r--dev-java/commons-jxpath/commons-jxpath-1.3.ebuild60
-rw-r--r--dev-java/commons-jxpath/metadata.xml5
4 files changed, 127 insertions, 0 deletions
diff --git a/dev-java/commons-jxpath/Manifest b/dev-java/commons-jxpath/Manifest
new file mode 100644
index 000000000000..4917a3bb4618
--- /dev/null
+++ b/dev-java/commons-jxpath/Manifest
@@ -0,0 +1 @@
+DIST commons-jxpath-1.3-src.tar.gz 285339 SHA256 da314198d75c6da660e2603bd1543a8f5d0b640c5144b748e62e59afc278efe6 SHA512 a0ad0b90c9aa4c732c47c8f38f036990438f526295b782fbdc00fd67e4c0e92643c7850429eb5263f9d322aff7cb7000b8ff2bffcdcfa88fa3ba5354dce7e152 WHIRLPOOL de683fa0e2d985cb57b434af224d2cca73d215d9429b97dc940933fb4a042638227b8fb342d81a1407faf740d1a42c3d5869fc2f78307e558fffb6dd97f36e97
diff --git a/dev-java/commons-jxpath/commons-jxpath-1.3-r1.ebuild b/dev-java/commons-jxpath/commons-jxpath-1.3-r1.ebuild
new file mode 100644
index 000000000000..2cf74452bf68
--- /dev/null
+++ b/dev-java/commons-jxpath/commons-jxpath-1.3-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Applies XPath expressions to graphs of objects of all kinds"
+HOMEPAGE="http://commons.apache.org/jxpath/"
+SRC_URI="mirror://apache/commons/jxpath/source/${P}-src.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+S="${WORKDIR}/${P}-src"
+
+CDEPEND="dev-java/commons-beanutils:1.7
+ java-virtuals/servlet-api:2.5
+ dev-java/jdom:1.0"
+RDEPEND=">=virtual/jre-1.6
+ ${CDEPEND}"
+DEPEND=">=virtual/jdk-1.6
+ test? (
+ dev-java/commons-collections:0
+ dev-java/commons-logging:0
+ )
+ ${CDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ mkdir -p "${S}/target/lib"
+ cd "${S}/target/lib"
+ java-pkg_jar-from commons-beanutils-1.7
+ java-pkg_jar-from servlet-api-2.5
+ java-pkg_jar-from jdom-1.0
+}
+
+src_prepare() {
+ # Don't automatically run tests
+ sed 's/depends="compile,test"/depends="compile"/' -i build.xml || die
+}
+
+src_test() {
+ # this one needs mockrunner #259027
+ rm src/test/org/apache/commons/jxpath/servlet/JXPathServletContextTest.java || die
+ java-pkg_jar-from --into target/lib \
+ commons-collections,commons-logging,junit
+ ANT_TASKS="ant-junit" eant test
+}
+
+src_install() {
+ java-pkg_dojar target/${PN}.jar
+ use doc && java-pkg_dojavadoc dist/docs/api
+ use source && java-pkg_dosrc src/java/*
+}
diff --git a/dev-java/commons-jxpath/commons-jxpath-1.3.ebuild b/dev-java/commons-jxpath/commons-jxpath-1.3.ebuild
new file mode 100644
index 000000000000..69d4fe4da459
--- /dev/null
+++ b/dev-java/commons-jxpath/commons-jxpath-1.3.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=1
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Applies XPath expressions to graphs of objects of all kinds"
+HOMEPAGE="http://commons.apache.org/jxpath/"
+SRC_URI="mirror://apache/commons/jxpath/source/${P}-src.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd"
+IUSE=""
+
+S="${WORKDIR}/${P}-src"
+
+COMMON_DEPEND="dev-java/commons-beanutils:1.7
+ dev-java/servletapi:2.4
+ dev-java/jdom:1.0"
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEPEND}"
+DEPEND=">=virtual/jdk-1.4
+ test? (
+ dev-java/ant-junit
+ dev-java/commons-collections
+ dev-java/commons-logging
+ )
+ ${COMMON_DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Don't automatically run tests
+ sed 's/depends="compile,test"/depends="compile"/' -i build.xml || die
+
+ mkdir -p "${S}/target/lib"
+ cd "${S}/target/lib"
+ java-pkg_jar-from commons-beanutils-1.7
+ java-pkg_jar-from servletapi-2.4
+ java-pkg_jar-from jdom-1.0
+}
+
+src_test() {
+ # this one needs mockrunner #259027
+ rm src/test/org/apache/commons/jxpath/servlet/JXPathServletContextTest.java || die
+ java-pkg_jar-from --into target/lib \
+ commons-collections,commons-logging,junit
+ ANT_TASKS="ant-junit" eant test
+}
+
+src_install() {
+ java-pkg_dojar target/${PN}.jar
+ use doc && java-pkg_dojavadoc dist/docs/api
+ use source && java-pkg_dosrc src/java/*
+}
diff --git a/dev-java/commons-jxpath/metadata.xml b/dev-java/commons-jxpath/metadata.xml
new file mode 100644
index 000000000000..838c00a4a448
--- /dev/null
+++ b/dev-java/commons-jxpath/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+</pkgmetadata>