summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2024-05-27 11:58:41 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2024-06-04 18:59:38 +0200
commit322704c5611b09ea0b13b1a4c14c10e6e94e1fcb (patch)
treeef5a061f4917121c216bb62984f12a1562486ffb /dev-java/httpcomponents-client
parentapp-admin/conky: drop 1.21.1 (diff)
downloadgentoo-322704c5611b09ea0b13b1a4c14c10e6e94e1fcb.tar.gz
gentoo-322704c5611b09ea0b13b1a4c14c10e6e94e1fcb.tar.bz2
gentoo-322704c5611b09ea0b13b1a4c14c10e6e94e1fcb.zip
dev-java/httpcomponents-client: handle test failures #923602
Closes: https://bugs.gentoo.org/923602 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java/httpcomponents-client')
-rw-r--r--dev-java/httpcomponents-client/httpcomponents-client-4.5.13-r1.ebuild16
1 files changed, 11 insertions, 5 deletions
diff --git a/dev-java/httpcomponents-client/httpcomponents-client-4.5.13-r1.ebuild b/dev-java/httpcomponents-client/httpcomponents-client-4.5.13-r1.ebuild
index 5c35d1fb5ad7..8f220b157642 100644
--- a/dev-java/httpcomponents-client/httpcomponents-client-4.5.13-r1.ebuild
+++ b/dev-java/httpcomponents-client/httpcomponents-client-4.5.13-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# Skeleton command:
@@ -13,7 +13,7 @@ JAVA_TESTING_FRAMEWORKS="junit-4"
inherit java-pkg-2 java-pkg-simple
DESCRIPTION="Apache HttpComponents Client"
-HOMEPAGE="https://hc.apache.org/httpcomponents-client"
+HOMEPAGE="https://hc.apache.org/httpcomponents-client-5.2.x/"
SRC_URI="mirror://apache/httpcomponents/httpclient/source/httpcomponents-client-${PV}-src.tar.gz"
LICENSE="Apache-2.0"
@@ -68,7 +68,13 @@ JAVA_TEST_EXCLUDES=(
"org.apache.http.conn.ssl.TestSSLSocketFactory"
)
-src_install() {
- default
- java-pkg-simple_src_install
+src_test() {
+ # https://bugs.gentoo.org/923602
+ local vm_version="$(java-config -g PROVIDES_VERSION)"
+ if ver_test "${vm_version}" -ge "17" ; then
+ JAVA_TEST_EXTRA_ARGS+=( --add-opens=java.base/java.lang=ALL-UNNAMED )
+ JAVA_TEST_EXTRA_ARGS+=( --add-opens=java.base/java.net=ALL-UNNAMED )
+ JAVA_TEST_EXTRA_ARGS+=( --add-opens=java.base/java.io=ALL-UNNAMED )
+ fi
+ java-pkg-simple_src_test
}