summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/jaxen
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/jaxen')
-rw-r--r--dev-java/jaxen/Manifest2
-rw-r--r--dev-java/jaxen/files/jaxen-1.1.4_maven1-build.xml200
-rw-r--r--dev-java/jaxen/jaxen-1.1.1.ebuild55
-rw-r--r--dev-java/jaxen/jaxen-1.1.4.ebuild48
-rw-r--r--dev-java/jaxen/metadata.xml5
5 files changed, 310 insertions, 0 deletions
diff --git a/dev-java/jaxen/Manifest b/dev-java/jaxen/Manifest
new file mode 100644
index 000000000000..44cfdde4d18e
--- /dev/null
+++ b/dev-java/jaxen/Manifest
@@ -0,0 +1,2 @@
+DIST jaxen-1.1.1-src.tar.gz 271343 SHA256 f24ae604a20da87e3716bb1d441c483e56479eaef4e99888f41be06059790bca SHA512 095523a1600324a2d2f748717c6af0ffe216120b834c1157912b57ea076c639aa3e47fe87da0316cae491ba838765e5e06bc304cdb610789101a54192d976940 WHIRLPOOL 2fec877f4b3e565304a7cd8bc7b5b391eaa74068c6bf241d8b2ef0fe5973273164247ec1166fedfbf92f082aa1120a4a3f0ce47e0e13a15add75ac00c128810a
+DIST jaxen-1.1.4-src.tar.gz 268493 SHA256 97d039a029ccaddf5ef301cafd1da8549b8360fe3ca0c15d65fc57162cd4433e SHA512 11c1c744af030c50579f872d8c8bf437e48ab4a01e6dd34529f2d9039c154533edaa9b5a367a866e2b57f311f1111717be300db8f80423c5492be38e0cffc031 WHIRLPOOL 44e3449ec8c0c15496c9528c668593d3dde67da67108e5927aee630df6ee3803999f812ab7597f37a68829e95a435fe6699bc9681583f6a500cd55cc51fbd6dc
diff --git a/dev-java/jaxen/files/jaxen-1.1.4_maven1-build.xml b/dev-java/jaxen/files/jaxen-1.1.4_maven1-build.xml
new file mode 100644
index 000000000000..efbdd2074bb2
--- /dev/null
+++ b/dev-java/jaxen/files/jaxen-1.1.4_maven1-build.xml
@@ -0,0 +1,200 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!--build.xml generated by maven from project.xml version 1.1.4
+ on date October 14 2012, time 0755-->
+<project default="jar" name="jaxen" basedir=".">
+ <!--Load local and user build preferences-->
+ <property file="build.properties"></property>
+ <property file="${user.home}/build.properties"></property>
+ <!--Build properties-->
+ <property name="defaulttargetdir" value="${basedir}/target"></property>
+ <property name="libdir" value="${user.home}/.maven/repository"></property>
+ <property name="classesdir" value="${basedir}/target/classes"></property>
+ <property name="testclassesdir" value="${basedir}/target/test-classes"></property>
+ <property name="testreportdir" value="${basedir}/target/test-reports"></property>
+ <property name="distdir" value="${basedir}/dist"></property>
+ <property name="javadocdir" value="${basedir}/dist/docs/api"></property>
+ <property name="final.name" value="jaxen-1.1.4"></property>
+ <property name="proxy.host" value=""></property>
+ <property name="proxy.port" value=""></property>
+ <property name="proxy.username" value=""></property>
+ <property name="proxy.password" value=""></property>
+ <path id="build.classpath">
+ <pathelement location="${libdir}/dom4j/jars/dom4j-1.6.1.jar"></pathelement>
+ <pathelement location="${libdir}/jdom/jars/jdom-1.0.jar"></pathelement>
+ <pathelement location="${libdir}/xml-apis/jars/xml-apis-1.3.02.jar"></pathelement>
+ <pathelement location="${libdir}/xerces/jars/xercesImpl-2.6.2.jar"></pathelement>
+ <pathelement location="${libdir}/xom/jars/xom-1.0.jar"></pathelement>
+ <pathelement location="${libdir}/maven-plugins/plugins/maven-cobertura-plugin-1.3.jar"></pathelement>
+ <pathelement location="${libdir}/maven-plugins/plugins/maven-findbugs-plugin-1.3.1.jar"></pathelement>
+ </path>
+ <target name="init" description="o Initializes some properties">
+ <condition property="noget">
+ <equals arg2="only" arg1="${build.sysclasspath}"></equals>
+ </condition>
+ <!--Test if JUNIT is present in ANT classpath-->
+ <available property="Junit.present" classname="junit.framework.Test"></available>
+ <!--Test if user defined a proxy-->
+ <condition property="useProxy">
+ <and>
+ <isset property="proxy.host"></isset>
+ <not>
+ <equals trim="true" arg2="" arg1="${proxy.host}"></equals>
+ </not>
+ </and>
+ </condition>
+ </target>
+ <target name="compile" description="o Compile the code" depends="get-deps">
+ <mkdir dir="${classesdir}"></mkdir>
+ <javac destdir="${classesdir}" deprecation="true" debug="true" optimize="false" excludes="**/package.html">
+ <src>
+ <pathelement location="${basedir}/src/java/main"></pathelement>
+ </src>
+ <classpath refid="build.classpath"></classpath>
+ </javac>
+ </target>
+ <target name="jar" description="o Create the jar" depends="compile,test">
+ <jar jarfile="${defaulttargetdir}/${final.name}.jar" excludes="**/package.html" basedir="${classesdir}"></jar>
+ </target>
+ <target name="clean" description="o Clean up the generated directories">
+ <delete dir="${defaulttargetdir}"></delete>
+ <delete dir="${distdir}"></delete>
+ </target>
+ <target name="dist" description="o Create a distribution" depends="jar, javadoc">
+ <mkdir dir="dist"></mkdir>
+ <copy todir="dist">
+ <fileset dir="${defaulttargetdir}" includes="*.jar"></fileset>
+ <fileset dir="${basedir}" includes="LICENSE*, README*"></fileset>
+ </copy>
+ </target>
+ <target name="test" description="o Run the test cases" if="test.failure" depends="internal-test">
+ <fail message="There were test failures."></fail>
+ </target>
+ <target name="internal-test" if="Junit.present" depends="junit-present,compile-tests">
+ <mkdir dir="${testreportdir}"></mkdir>
+ <junit dir="${basedir}" failureproperty="test.failure" printSummary="yes" fork="true" haltonerror="true">
+ <sysproperty key="basedir" value="."></sysproperty>
+ <formatter type="xml"></formatter>
+ <formatter usefile="false" type="plain"></formatter>
+ <classpath>
+ <path refid="build.classpath"></path>
+ <pathelement path="${testclassesdir}"></pathelement>
+ <pathelement path="${classesdir}"></pathelement>
+ </classpath>
+ <batchtest todir="${testreportdir}">
+ <fileset dir="${basedir}/src/java/test">
+ <include name="**/*Test.java"></include>
+ </fileset>
+ </batchtest>
+ </junit>
+ </target>
+ <target name="junit-present" unless="Junit.present" depends="init">
+ <echo>================================= WARNING ================================</echo>
+ <echo>Junit isn't present in your ${ANT_HOME}/lib directory. Tests not executed.</echo>
+ <echo>==========================================================================</echo>
+ </target>
+ <target name="compile-tests" if="Junit.present" depends="junit-present,compile">
+ <mkdir dir="${testclassesdir}"></mkdir>
+ <javac destdir="${testclassesdir}" deprecation="true" debug="true" optimize="false" excludes="**/package.html">
+ <src>
+ <pathelement location="${basedir}/src/java/test"></pathelement>
+ </src>
+ <classpath>
+ <path refid="build.classpath"></path>
+ <pathelement path="${classesdir}"></pathelement>
+ </classpath>
+ </javac>
+ </target>
+ <target name="javadoc" description="o Generate javadoc" depends="get-deps">
+ <mkdir dir="${javadocdir}"></mkdir>
+ <tstamp>
+ <format pattern="2001-yyyy" property="year"></format>
+ </tstamp>
+ <property name="copyright" value="Copyright &amp;copy; Codehaus. All Rights Reserved."></property>
+ <property name="title" value="jaxen 1.1.4 API"></property>
+ <javadoc use="true" private="true" destdir="${javadocdir}" author="true" version="true" sourcepath="${basedir}/src/java/main" packagenames="org.jaxen.*">
+ <classpath>
+ <path refid="build.classpath"></path>
+ </classpath>
+ </javadoc>
+ </target>
+ <target name="get-dep-dom4j.jar" description="o Download the dependency : dom4j.jar" unless="dom4j.jar" depends="init,setProxy,noProxy,get-custom-dep-dom4j.jar">
+ <mkdir dir="${libdir}/dom4j/jars/"></mkdir>
+ <get dest="${libdir}/dom4j/jars/dom4j-1.6.1.jar" usetimestamp="true" ignoreerrors="true" src="http://repo1.maven.org/maven/dom4j/jars/dom4j-1.6.1.jar"></get>
+ <get dest="${libdir}/dom4j/jars/dom4j-1.6.1.jar" usetimestamp="true" ignoreerrors="true" src="http://dist.codehaus.org//dom4j/jars/dom4j-1.6.1.jar"></get>
+ </target>
+ <target name="get-custom-dep-dom4j.jar" if="dom4j.jar" depends="init,setProxy,noProxy">
+ <mkdir dir="${libdir}/dom4j/jars/"></mkdir>
+ <get dest="${libdir}/dom4j/jars/dom4j-1.6.1.jar" usetimestamp="true" ignoreerrors="true" src="${dom4j.jar}"></get>
+ </target>
+ <target name="get-dep-jdom.jar" description="o Download the dependency : jdom.jar" unless="jdom.jar" depends="init,setProxy,noProxy,get-custom-dep-jdom.jar">
+ <mkdir dir="${libdir}/jdom/jars/"></mkdir>
+ <get dest="${libdir}/jdom/jars/jdom-1.0.jar" usetimestamp="true" ignoreerrors="true" src="http://repo1.maven.org/maven/jdom/jars/jdom-1.0.jar"></get>
+ <get dest="${libdir}/jdom/jars/jdom-1.0.jar" usetimestamp="true" ignoreerrors="true" src="http://dist.codehaus.org//jdom/jars/jdom-1.0.jar"></get>
+ </target>
+ <target name="get-custom-dep-jdom.jar" if="jdom.jar" depends="init,setProxy,noProxy">
+ <mkdir dir="${libdir}/jdom/jars/"></mkdir>
+ <get dest="${libdir}/jdom/jars/jdom-1.0.jar" usetimestamp="true" ignoreerrors="true" src="${jdom.jar}"></get>
+ </target>
+ <target name="get-dep-xml-apis.jar" description="o Download the dependency : xml-apis.jar" unless="xml-apis.jar" depends="init,setProxy,noProxy,get-custom-dep-xml-apis.jar">
+ <mkdir dir="${libdir}/xml-apis/jars/"></mkdir>
+ <get dest="${libdir}/xml-apis/jars/xml-apis-1.3.02.jar" usetimestamp="true" ignoreerrors="true" src="http://repo1.maven.org/maven/xml-apis/jars/xml-apis-1.3.02.jar"></get>
+ <get dest="${libdir}/xml-apis/jars/xml-apis-1.3.02.jar" usetimestamp="true" ignoreerrors="true" src="http://dist.codehaus.org//xml-apis/jars/xml-apis-1.3.02.jar"></get>
+ </target>
+ <target name="get-custom-dep-xml-apis.jar" if="xml-apis.jar" depends="init,setProxy,noProxy">
+ <mkdir dir="${libdir}/xml-apis/jars/"></mkdir>
+ <get dest="${libdir}/xml-apis/jars/xml-apis-1.3.02.jar" usetimestamp="true" ignoreerrors="true" src="${xml-apis.jar}"></get>
+ </target>
+ <target name="get-dep-xercesImpl.jar" description="o Download the dependency : xercesImpl.jar" unless="xercesImpl.jar" depends="init,setProxy,noProxy,get-custom-dep-xercesImpl.jar">
+ <mkdir dir="${libdir}/xerces/jars/"></mkdir>
+ <get dest="${libdir}/xerces/jars/xercesImpl-2.6.2.jar" usetimestamp="true" ignoreerrors="true" src="http://repo1.maven.org/maven/xerces/jars/xercesImpl-2.6.2.jar"></get>
+ <get dest="${libdir}/xerces/jars/xercesImpl-2.6.2.jar" usetimestamp="true" ignoreerrors="true" src="http://dist.codehaus.org//xerces/jars/xercesImpl-2.6.2.jar"></get>
+ </target>
+ <target name="get-custom-dep-xercesImpl.jar" if="xercesImpl.jar" depends="init,setProxy,noProxy">
+ <mkdir dir="${libdir}/xerces/jars/"></mkdir>
+ <get dest="${libdir}/xerces/jars/xercesImpl-2.6.2.jar" usetimestamp="true" ignoreerrors="true" src="${xercesImpl.jar}"></get>
+ </target>
+ <target name="get-dep-xom.jar" description="o Download the dependency : xom.jar" unless="xom.jar" depends="init,setProxy,noProxy,get-custom-dep-xom.jar">
+ <mkdir dir="${libdir}/xom/jars/"></mkdir>
+ <get dest="${libdir}/xom/jars/xom-1.0.jar" usetimestamp="true" ignoreerrors="true" src="http://repo1.maven.org/maven/xom/jars/xom-1.0.jar"></get>
+ <get dest="${libdir}/xom/jars/xom-1.0.jar" usetimestamp="true" ignoreerrors="true" src="http://dist.codehaus.org//xom/jars/xom-1.0.jar"></get>
+ </target>
+ <target name="get-custom-dep-xom.jar" if="xom.jar" depends="init,setProxy,noProxy">
+ <mkdir dir="${libdir}/xom/jars/"></mkdir>
+ <get dest="${libdir}/xom/jars/xom-1.0.jar" usetimestamp="true" ignoreerrors="true" src="${xom.jar}"></get>
+ </target>
+ <target name="get-dep-maven-cobertura-plugin.jar" description="o Download the dependency : maven-cobertura-plugin.jar" unless="maven-cobertura-plugin.jar" depends="init,setProxy,noProxy,get-custom-dep-maven-cobertura-plugin.jar">
+ <mkdir dir="${libdir}/maven-plugins/plugins/"></mkdir>
+ <get dest="${libdir}/maven-plugins/plugins/maven-cobertura-plugin-1.3.jar" usetimestamp="true" ignoreerrors="true" src="http://repo1.maven.org/maven/maven-plugins/plugins/maven-cobertura-plugin-1.3.jar"></get>
+ <get dest="${libdir}/maven-plugins/plugins/maven-cobertura-plugin-1.3.jar" usetimestamp="true" ignoreerrors="true" src="http://dist.codehaus.org//maven-plugins/plugins/maven-cobertura-plugin-1.3.jar"></get>
+ </target>
+ <target name="get-custom-dep-maven-cobertura-plugin.jar" if="maven-cobertura-plugin.jar" depends="init,setProxy,noProxy">
+ <mkdir dir="${libdir}/maven-plugins/plugins/"></mkdir>
+ <get dest="${libdir}/maven-plugins/plugins/maven-cobertura-plugin-1.3.jar" usetimestamp="true" ignoreerrors="true" src="${maven-cobertura-plugin.jar}"></get>
+ </target>
+ <target name="get-dep-maven-findbugs-plugin.jar" description="o Download the dependency : maven-findbugs-plugin.jar" unless="maven-findbugs-plugin.jar" depends="init,setProxy,noProxy,get-custom-dep-maven-findbugs-plugin.jar">
+ <mkdir dir="${libdir}/maven-plugins/plugins/"></mkdir>
+ <get dest="${libdir}/maven-plugins/plugins/maven-findbugs-plugin-1.3.1.jar" usetimestamp="true" ignoreerrors="true" src="http://repo1.maven.org/maven/maven-plugins/plugins/maven-findbugs-plugin-1.3.1.jar"></get>
+ <get dest="${libdir}/maven-plugins/plugins/maven-findbugs-plugin-1.3.1.jar" usetimestamp="true" ignoreerrors="true" src="http://dist.codehaus.org//maven-plugins/plugins/maven-findbugs-plugin-1.3.1.jar"></get>
+ </target>
+ <target name="get-custom-dep-maven-findbugs-plugin.jar" if="maven-findbugs-plugin.jar" depends="init,setProxy,noProxy">
+ <mkdir dir="${libdir}/maven-plugins/plugins/"></mkdir>
+ <get dest="${libdir}/maven-plugins/plugins/maven-findbugs-plugin-1.3.1.jar" usetimestamp="true" ignoreerrors="true" src="${maven-findbugs-plugin.jar}"></get>
+ </target>
+ <target name="get-deps" unless="noget"></target>
+ <target name="setProxy" if="useProxy" depends="init">
+ <!--Proxy settings works only with a JDK 1.2 and higher.-->
+ <echo>Proxy used :</echo>
+ <echo>Proxy host [${proxy.host}]</echo>
+ <echo>Proxy port [${proxy.port}]</echo>
+ <echo>Proxy user [${proxy.username}]</echo>
+ <setproxy proxyuser="${proxy.username}" proxyport="${proxy.port}" proxypassword="${proxy.password}" proxyhost="${proxy.host}"></setproxy>
+ </target>
+ <target name="noProxy" unless="useProxy" depends="init">
+ <echo>Proxy not used.</echo>
+ </target>
+ <target name="install-maven">
+ <get dest="${user.home}/maven-install-latest.jar" usetimestamp="true" src="${repo}/maven/maven-install-latest.jar"></get>
+ <unjar dest="${maven.home}" src="${user.home}/maven-install-latest.jar"></unjar>
+ </target>
+</project>
diff --git a/dev-java/jaxen/jaxen-1.1.1.ebuild b/dev-java/jaxen/jaxen-1.1.1.ebuild
new file mode 100644
index 000000000000..8b3a95acabd6
--- /dev/null
+++ b/dev-java/jaxen/jaxen-1.1.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+JAVA_PKG_IUSE="doc examples source test"
+
+inherit java-pkg-2 eutils java-ant-2
+
+MY_P=${P/_beta/-beta-}
+DESCRIPTION="A Java XPath Engine"
+HOMEPAGE="http://jaxen.org/"
+SRC_URI="http://dist.codehaus.org/${PN}/distributions/${MY_P}-src.tar.gz"
+
+LICENSE="JDOM"
+SLOT="1.1"
+KEYWORDS=" amd64 ~arm ppc ppc64 x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="doc source test"
+
+COMMON_DEP="~dev-java/jdom-1.0
+ =dev-java/dom4j-1*
+ dev-java/xom"
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEP}"
+
+DEPEND=">=virtual/jdk-1.4
+ test? ( dev-java/ant-junit =dev-java/junit-3* )
+ ${COMMON_DEP}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ java-ant_ignore-system-classes
+
+ mkdir -p "${S}/target/lib"
+ cd "${S}/target/lib"
+ java-pkg_jar-from dom4j-1
+ java-pkg_jar-from jdom-1.0
+ java-pkg_jar-from xom
+}
+
+src_install() {
+ java-pkg_newjar target/${MY_P}.jar
+
+ use doc && java-pkg_dojavadoc dist/docs/api
+ use examples && java-pkg_doexamples src/java/samples
+ use source && java-pkg_dosrc src/java/main/*
+}
+
+src_test() {
+ java-pkg_jar-from --into target/lib junit
+ ANT_TASKS="ant-junit" eant test -DJunit.present=true
+}
diff --git a/dev-java/jaxen/jaxen-1.1.4.ebuild b/dev-java/jaxen/jaxen-1.1.4.ebuild
new file mode 100644
index 000000000000..2503e98ce30d
--- /dev/null
+++ b/dev-java/jaxen/jaxen-1.1.4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc examples source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="A Java XPath Engine"
+HOMEPAGE="http://jaxen.codehaus.org/"
+SRC_URI="http://dist.codehaus.org/${PN}/distributions/${P}-src.tar.gz"
+
+LICENSE="JDOM"
+SLOT="1.1"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+COMMON_DEP="
+ dev-java/dom4j:1
+ dev-java/jdom:1.0
+ dev-java/xom:0"
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEP}"
+DEPEND=">=virtual/jdk-1.4
+ test? ( dev-java/ant-junit:0 )
+ ${COMMON_DEP}"
+
+JAVA_ANT_REWRITE_CLASSPATH="yes"
+EANT_GENTOO_CLASSPATH="dom4j-1,jdom-1.0,xom"
+EANT_TEST_EXTRA_ARGS="-DJunit.present=true"
+
+java_prepare() {
+ cp -v "${FILESDIR}"/${P}_maven1-build.xml build.xml || die
+}
+
+src_test() {
+ java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_newjar target/${P}.jar
+
+ use doc && java-pkg_dojavadoc dist/docs/api
+ use examples && java-pkg_doexamples src/java/samples
+ use source && java-pkg_dosrc src/java/main/*
+}
diff --git a/dev-java/jaxen/metadata.xml b/dev-java/jaxen/metadata.xml
new file mode 100644
index 000000000000..7303cef96964
--- /dev/null
+++ b/dev-java/jaxen/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+</pkgmetadata>