summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/jta
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/jta')
-rw-r--r--dev-java/jta/Manifest2
-rw-r--r--dev-java/jta/jta-1.0.1-r1.ebuild45
-rw-r--r--dev-java/jta/jta-1.1.ebuild46
-rw-r--r--dev-java/jta/metadata.xml5
4 files changed, 98 insertions, 0 deletions
diff --git a/dev-java/jta/Manifest b/dev-java/jta/Manifest
new file mode 100644
index 000000000000..0f61c038465b
--- /dev/null
+++ b/dev-java/jta/Manifest
@@ -0,0 +1,2 @@
+DIST jta-1_0_1B-classes.zip 8812 SHA256 5bc89d0a1caecd25e9323144624fd26df4326c84da8658f08f5cc588ee25cca9
+DIST jta-1_1-classes.zip 13236 SHA256 6202127f8e3fe63ebbaa8c3ddf455bae862d5563b4c210ea29484df52ce505da SHA512 fb8b76223ccdec0ef97b00d7248d74b6316dd67c570667f3a644d03b05cd28af061a191cf71b6624fd4a4195f7bc107281eb847fc4c0ee4606c85c414da79a14 WHIRLPOOL c6b97d35eb09cd027596594ce009c251cc61014ceacd7d49748eb157ddbec6700eb29d07a4f9fd0d6273652cd83e067fc7f2a4d99e584ad13c7f13c2f8a07271
diff --git a/dev-java/jta/jta-1.0.1-r1.ebuild b/dev-java/jta/jta-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..8a3ef8142cd1
--- /dev/null
+++ b/dev-java/jta/jta-1.0.1-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit java-pkg-2
+
+At="jta-1_0_1B-classes.zip"
+DESCRIPTION="The Java Transaction API"
+HOMEPAGE="http://www.oracle.com/technetwork/java/javaee/tech/jta-138684.html"
+SRC_URI="${At}"
+LICENSE="sun-bcla-jta"
+SLOT=0
+KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-macos"
+IUSE=""
+DEPEND=">=app-arch/unzip-5.50-r1
+ >=virtual/jdk-1.3"
+RDEPEND=">=virtual/jre-1.3"
+RESTRICT="fetch"
+
+S=${WORKDIR}
+
+pkg_nofetch() {
+ einfo
+ einfo " Due to license restrictions, we cannot fetch the"
+ einfo " distributables automagically."
+ einfo
+ einfo " 1. Visit ${HOMEPAGE}"
+ einfo " 2. Select 'Java Transaction API Specification 1.0.1B Class Files 1.0.1B'"
+ einfo " 3. Download ${At}"
+ einfo " 4. Move file to ${DISTDIR}"
+ einfo " 5. Restart the emerge process"
+ einfo
+}
+
+src_unpack() {
+ unzip -qq "${DISTDIR}"/${At} || die "failed too unpack"
+}
+
+src_compile() {
+ jar cvf jta.jar javax/ || die "failed to create jar"
+}
+
+src_install() {
+ java-pkg_dojar jta.jar
+}
diff --git a/dev-java/jta/jta-1.1.ebuild b/dev-java/jta/jta-1.1.ebuild
new file mode 100644
index 000000000000..719fa261d9c6
--- /dev/null
+++ b/dev-java/jta/jta-1.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI=5
+
+inherit java-pkg-2
+
+JTA_ZIP="jta-1_1-classes.zip"
+DESCRIPTION="The Java Transaction API"
+HOMEPAGE="http://www.oracle.com/technetwork/java/javaee/jta/index.html"
+SRC_URI="${JTA_ZIP}"
+LICENSE="sun-bcla-jta"
+SLOT=0
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-macos"
+IUSE=""
+DEPEND=">=app-arch/unzip-5.50-r1
+>=virtual/jdk-1.5"
+RDEPEND=">=virtual/jre-1.5"
+RESTRICT="fetch"
+
+S=${WORKDIR}
+
+pkg_nofetch() {
+ einfo
+ einfo " Due to license restrictions, we cannot fetch the"
+ einfo " distributables automagically."
+ einfo
+ einfo " 1. Visit ${HOMEPAGE}"
+ einfo " 2. Select 'Java Transaction API Specification 1.1 Maintenance Release'"
+ einfo " 3. Download ${JTA_ZIP}"
+ einfo " 4. Move file to ${DISTDIR}"
+ einfo " 5. Restart the emerge process"
+ einfo
+}
+
+src_unpack() {
+ unzip -qq "${DISTDIR}"/${JTA_ZIP} || die "failed to unpack"
+}
+
+src_compile() {
+ jar cvf jta.jar javax/ || die "failed to create jar"
+}
+
+src_install() {
+ java-pkg_dojar jta.jar
+}
diff --git a/dev-java/jta/metadata.xml b/dev-java/jta/metadata.xml
new file mode 100644
index 000000000000..838c00a4a448
--- /dev/null
+++ b/dev-java/jta/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+</pkgmetadata>