summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2018-08-22 20:20:35 +0200
committerMike Gilbert <floppym@gentoo.org>2018-08-22 15:01:01 -0400
commit4462548e036774caf8c31e5b4b90f79be03139eb (patch)
tree823e096941b69ca966b0034df427967273ce2027 /dev-java/protobuf-java/protobuf-java-3.6.1.ebuild
parentdev-libs/protobuf: Version bump (3.6.1). (diff)
downloadgentoo-4462548e036774caf8c31e5b4b90f79be03139eb.tar.gz
gentoo-4462548e036774caf8c31e5b4b90f79be03139eb.tar.bz2
gentoo-4462548e036774caf8c31e5b4b90f79be03139eb.zip
dev-java/protobuf-java: Version bump (3.6.1).
Diffstat (limited to 'dev-java/protobuf-java/protobuf-java-3.6.1.ebuild')
-rw-r--r--dev-java/protobuf-java/protobuf-java-3.6.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-java/protobuf-java/protobuf-java-3.6.1.ebuild b/dev-java/protobuf-java/protobuf-java-3.6.1.ebuild
new file mode 100644
index 000000000000..b616b3196431
--- /dev/null
+++ b/dev-java/protobuf-java/protobuf-java-3.6.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Google's Protocol Buffers - Java bindings"
+HOMEPAGE="https://developers.google.com/protocol-buffers/ https://github.com/google/protobuf"
+SRC_URI="https://github.com/google/protobuf/archive/v${PV}.tar.gz -> protobuf-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/17"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~sh ~x86 ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE=""
+
+DEPEND="~dev-libs/protobuf-${PV}
+ >=virtual/jdk-1.7"
+RDEPEND=">=virtual/jre-1.7
+ !<dev-libs/protobuf-3[java(-)]"
+
+S="${WORKDIR}/protobuf-${PV}/java"
+
+src_prepare() {
+ default
+ java-pkg-2_src_prepare
+}
+
+src_compile() {
+ "${EPREFIX}/usr/bin/protoc" --java_out=core/src/main/java -I../src ../src/google/protobuf/descriptor.proto || die
+ JAVA_SRC_DIR="core/src/main/java" JAVA_JAR_FILENAME="protobuf.jar" java-pkg-simple_src_compile
+}
+
+src_install() {
+ JAVA_SRC_DIR="core/src/main/java" JAVA_JAR_FILENAME="protobuf.jar" java-pkg-simple_src_install
+}