summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/txw2-runtime
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/txw2-runtime')
-rw-r--r--dev-java/txw2-runtime/Manifest1
-rw-r--r--dev-java/txw2-runtime/files/build.xml-2007040730
-rw-r--r--dev-java/txw2-runtime/metadata.xml5
-rw-r--r--dev-java/txw2-runtime/txw2-runtime-20070407-r2.ebuild56
4 files changed, 92 insertions, 0 deletions
diff --git a/dev-java/txw2-runtime/Manifest b/dev-java/txw2-runtime/Manifest
new file mode 100644
index 000000000000..161c06ff3e59
--- /dev/null
+++ b/dev-java/txw2-runtime/Manifest
@@ -0,0 +1 @@
+DIST txw2-20070407.zip 1183977 SHA256 e90e7385f42be3a379547e497093e0c5ffd1033e18056ca4df69eb8cdc2108ed SHA512 60c4ea2110e09f4cecd348ef5cb2f75f872479b058870a8ab45eb03578c1cd2efb4db5e028a8090f9c1f46c6fc30985dfb9faa3682055c49c2accb6aa4010081 WHIRLPOOL 8cc5b787394d6f28a9ae1614ee07960e9eb1175ea96c883fef65eae9590d6bd3090b8b106a66f6d3b3b311585a349f5aeb5b758157138efb2bae76d35d573cb3
diff --git a/dev-java/txw2-runtime/files/build.xml-20070407 b/dev-java/txw2-runtime/files/build.xml-20070407
new file mode 100644
index 000000000000..3e1cbaac1024
--- /dev/null
+++ b/dev-java/txw2-runtime/files/build.xml-20070407
@@ -0,0 +1,30 @@
+<?xml version="1.0"?>
+<project name="txw2" basedir=".">
+ <target name="compiler-compile" depends="runtime-jar">
+ <mkdir dir="build-compiler"/>
+ <javac debug="false" srcdir="compiler" destdir="build-compiler">
+ <classpath>
+ <fileset dir="lib" includes="**/*.jar"/>
+ <fileset dir="." includes="txwc2.jar"/>
+ </classpath>
+ </javac>
+ </target>
+ <target name="runtime-compile">
+ <mkdir dir="build-runtime"/>
+ <javac debug="false" srcdir="runtime" destdir="build-runtime">
+ <classpath>
+ <fileset dir="lib" includes="**/*.jar"/>
+ </classpath>
+ </javac>
+ </target>
+ <target name="compiler-jar" depends="compiler-compile">
+ <jar destfile="txwc2.jar">
+ <fileset dir="build-compiler" includes="**/*.class"/>
+ </jar>
+ </target>
+ <target name="runtime-jar" depends="runtime-compile">
+ <jar destfile="txw2.jar">
+ <fileset dir="build-runtime" includes="**/*.class"/>
+ </jar>
+ </target>
+</project>
diff --git a/dev-java/txw2-runtime/metadata.xml b/dev-java/txw2-runtime/metadata.xml
new file mode 100644
index 000000000000..250f2d1940ea
--- /dev/null
+++ b/dev-java/txw2-runtime/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+</pkgmetadata>
diff --git a/dev-java/txw2-runtime/txw2-runtime-20070407-r2.ebuild b/dev-java/txw2-runtime/txw2-runtime-20070407-r2.ebuild
new file mode 100644
index 000000000000..53df77ff76f9
--- /dev/null
+++ b/dev-java/txw2-runtime/txw2-runtime-20070407-r2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+JAVA_PKG_IUSE="doc source"
+
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="TXW is a library that allows you to write XML documents"
+HOMEPAGE="https://txw.dev.java.net/"
+SRC_URI="https://txw.dev.java.net/files/documents/3310/54821/txw2-${PV}.zip"
+
+LICENSE="CDDL"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+IUSE=""
+
+COMMON_DEP="java-virtuals/stax-api"
+
+DEPEND=">=virtual/jdk-1.5
+ app-arch/unzip
+ ${COMMON_DEP}"
+RDEPEND=">=virtual/jre-1.5
+ ${COMMON_DEP}"
+
+S="${WORKDIR}/txw2-${PV}"
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd "${S}"
+ rm -v *.jar || die
+ cd "${S}/lib"
+ rm -v *.jar || die
+
+ java-pkg_jarfrom --build-only ant-core
+ java-pkg_jarfrom --virtual stax-api
+
+ cd "${S}"
+ unzip -qq txw2-src.zip -d runtime || die unzip failed
+ unzip -qq txw2c-src.zip -d compiler || die unzip failed
+
+ cp -i "${FILESDIR}/build.xml-20070407" "${S}/build.xml" || die cp failed
+
+}
+
+EANT_BUILD_TARGET="runtime-jar"
+EANT_DOC_TARGET=""
+
+src_install() {
+ java-pkg_newjar txw2.jar
+
+ use doc && java-pkg_dojavadoc javadoc
+ use source && java-pkg_dosrc runtime/*
+}