summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2021-12-11 17:09:48 +0100
committerJakov Smolić <jsmolic@gentoo.org>2021-12-11 17:09:48 +0100
commitc7c9db1a090cc0f09ee7a1da6ac450aa34a6e902 (patch)
tree55ffab69d3469e6cde2d8acd6ebcde5b3059fdc9 /dev-java
parentdev-java/moshi: treeclean (diff)
downloadgentoo-c7c9db1a090cc0f09ee7a1da6ac450aa34a6e902.tar.gz
gentoo-c7c9db1a090cc0f09ee7a1da6ac450aa34a6e902.tar.bz2
gentoo-c7c9db1a090cc0f09ee7a1da6ac450aa34a6e902.zip
dev-java/okio: treeclean
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/okio/Manifest1
-rw-r--r--dev-java/okio/files/okio-remove-maven-animal-jre.patch44
-rw-r--r--dev-java/okio/metadata.xml11
-rw-r--r--dev-java/okio/okio-1.11.0.ebuild36
4 files changed, 0 insertions, 92 deletions
diff --git a/dev-java/okio/Manifest b/dev-java/okio/Manifest
deleted file mode 100644
index 458c68ce017a..000000000000
--- a/dev-java/okio/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST okio-1.11.0.tar.gz 95398 BLAKE2B 6d31d61f1ac0d34289e601bdf4a35768f81ada35883958d0a7fddd6ba9fcbbe36ca75f87ad1879a207d3b587d22a096b41945102c5c8829b094e9954901fe87e SHA512 12b6d63cf037be2679c01e71bd6318ea1f8bd19f7f2a38f58c210d6bbb4650db6ba5aa527808c109ca02af2ccd663dc31102dd1b8ea6c6ce326dd7be7c1d8071
diff --git a/dev-java/okio/files/okio-remove-maven-animal-jre.patch b/dev-java/okio/files/okio-remove-maven-animal-jre.patch
deleted file mode 100644
index 0e5e5d62880e..000000000000
--- a/dev-java/okio/files/okio-remove-maven-animal-jre.patch
+++ /dev/null
@@ -1,44 +0,0 @@
---- okio/src/main/java/okio/DeflaterSink.java 2016-08-22 12:01:19.828823222 -0500
-+++ okio/src/main/java/okio/DeflaterSink.java 2016-08-22 12:01:25.039823574 -0500
-@@ -17,7 +17,6 @@
-
- import java.io.IOException;
- import java.util.zip.Deflater;
--import org.codehaus.mojo.animal_sniffer.IgnoreJRERequirement;
-
- import static okio.Util.checkOffsetAndCount;
-
-@@ -79,7 +78,6 @@
- }
- }
-
-- @IgnoreJRERequirement
- private void deflate(boolean syncFlush) throws IOException {
- Buffer buffer = sink.buffer();
- while (true) {
---- okio/src/main/java/okio/Okio.java 2016-08-22 12:03:23.819831591 -0500
-+++ okio/src/main/java/okio/Okio.java 2016-08-22 12:03:34.874832337 -0500
-@@ -30,7 +30,6 @@
- import java.nio.file.Path;
- import java.util.logging.Level;
- import java.util.logging.Logger;
--import org.codehaus.mojo.animal_sniffer.IgnoreJRERequirement;
-
- import static okio.Util.checkOffsetAndCount;
-
-@@ -167,7 +166,6 @@
- }
-
- /** Returns a source that reads from {@code path}. */
-- @IgnoreJRERequirement // Should only be invoked on Java 7+.
- public static Source source(Path path, OpenOption... options) throws IOException {
- if (path == null) throw new IllegalArgumentException("path == null");
- return source(Files.newInputStream(path, options));
-@@ -186,7 +184,6 @@
- }
-
- /** Returns a sink that writes to {@code path}. */
-- @IgnoreJRERequirement // Should only be invoked on Java 7+.
- public static Sink sink(Path path, OpenOption... options) throws IOException {
- if (path == null) throw new IllegalArgumentException("path == null");
- return sink(Files.newOutputStream(path, options));
diff --git a/dev-java/okio/metadata.xml b/dev-java/okio/metadata.xml
deleted file mode 100644
index dd9868b67a8e..000000000000
--- a/dev-java/okio/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>java@gentoo.org</email>
- <name>Java</name>
- </maintainer>
- <upstream>
- <remote-id type="github">square/okio</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-java/okio/okio-1.11.0.ebuild b/dev-java/okio/okio-1.11.0.ebuild
deleted file mode 100644
index 743f89f4b4cb..000000000000
--- a/dev-java/okio/okio-1.11.0.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-JAVA_PKG_IUSE="doc source"
-
-inherit java-pkg-2 java-pkg-simple
-
-MY_P="${PN}-parent-${PV}"
-
-DESCRIPTION="A modern I/O API for Java"
-HOMEPAGE="https://github.com/square/okio"
-SRC_URI="https://github.com/square/${PN}/archive/${MY_P}.tar.gz -> ${P}.tar.gz"
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- >=virtual/jre-1.7"
-CDEPEND="
- source? ( app-arch/zip )
- dev-java/jmh-core:0
- dev-java/junit:4"
-DEPEND=">=virtual/jdk-1.7
- ${CDEPEND}"
-RDEPEND=">=virtual/jre-1.7
- ${CDEPEND}"
-
-S="${WORKDIR}/${PN}-${MY_P}"
-
-JAVA_GENTOO_CLASSPATH="jmh-core,junit-4"
-
-src_prepare() {
- epatch "${FILESDIR}/okio-remove-maven-animal-jre.patch"
-}