summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2018-03-01 21:04:26 -0500
committerBrian Evans <grknight@gentoo.org>2018-03-01 21:10:23 -0500
commite4cb484c2c7c5764e6701a00dd6dd1cff414d270 (patch)
treeb4e750de87cb07df4e321990dfe2a09df7e3691b /dev-lang/php
parentdev-lang/php: Version bump for 7.2.3 (diff)
downloadgentoo-e4cb484c2c7c5764e6701a00dd6dd1cff414d270.tar.gz
gentoo-e4cb484c2c7c5764e6701a00dd6dd1cff414d270.tar.bz2
gentoo-e4cb484c2c7c5764e6701a00dd6dd1cff414d270.zip
dev-lang/php: move fpm-systemd specific option to that SAPI
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-lang/php')
-rw-r--r--dev-lang/php/php-7.0.28.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-lang/php/php-7.0.28.ebuild b/dev-lang/php/php-7.0.28.ebuild
index 6757747f0ea6..45b3218e4f64 100644
--- a/dev-lang/php/php-7.0.28.ebuild
+++ b/dev-lang/php/php-7.0.28.ebuild
@@ -301,7 +301,6 @@ src_configure() {
$(use_enable sysvipc sysvmsg)
$(use_enable sysvipc sysvsem)
$(use_enable sysvipc sysvshm)
- $(use_with systemd fpm-systemd)
$(use_with tidy tidy "${EPREFIX}/usr")
$(use_enable tokenizer tokenizer)
$(use_enable wddx wddx)
@@ -457,7 +456,12 @@ src_configure() {
cli|cgi|embed|fpm|phpdbg)
if [[ "${one_sapi}" == "${sapi}" ]] ; then
sapi_conf+=( "--enable-${sapi}" )
- [[ "fpm" == "${sapi}" ]] && sapi_conf+=( $(use_with acl fpm-acl) )
+ if [[ "fpm" == "${sapi}" ]] ; then
+ sapi_conf+=(
+ $(use_with acl fpm-acl)
+ $(use_with systemd fpm-systemd)
+ )
+ fi
else
sapi_conf+=( "--disable-${sapi}" )
fi