summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-28 20:33:52 +0100
committerMichał Górny <mgorny@gentoo.org>2024-10-28 20:44:31 +0100
commitb7ff4bc8b51d0e0c70cad78e6db27b800be913c9 (patch)
tree0cdf79f4f94e6cf4337f1fcf59f02f0aabe28434 /dev-lang
parentdev-libs/userspace-rcu: drop 0.13.2 (diff)
downloadgentoo-b7ff4bc8b51d0e0c70cad78e6db27b800be913c9.tar.gz
gentoo-b7ff4bc8b51d0e0c70cad78e6db27b800be913c9.tar.bz2
gentoo-b7ff4bc8b51d0e0c70cad78e6db27b800be913c9.zip
dev-lang/python: Skip test_gdb on ppc64 & sparc
The gdb tests are failing on devboxes. They were previously covered by the unconditional `-x test_gdb` but that's been narrowed to `-x test_pretty_print`, missing that other tests fail on these architectures. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/python-3.11.10_p1.ebuild2
-rw-r--r--dev-lang/python/python-3.12.7_p1.ebuild2
-rw-r--r--dev-lang/python/python-3.13.0-r100.ebuild2
-rw-r--r--dev-lang/python/python-3.13.0.ebuild2
-rw-r--r--dev-lang/python/python-3.14.0_alpha1-r100.ebuild2
-rw-r--r--dev-lang/python/python-3.14.0_alpha1.ebuild2
6 files changed, 12 insertions, 0 deletions
diff --git a/dev-lang/python/python-3.11.10_p1.ebuild b/dev-lang/python/python-3.11.10_p1.ebuild
index 3fc2272abc67..89a7bd307b68 100644
--- a/dev-lang/python/python-3.11.10_p1.ebuild
+++ b/dev-lang/python/python-3.11.10_p1.ebuild
@@ -255,6 +255,7 @@ src_configure() {
powerpc64-*) # big endian
COMMON_TEST_SKIPS+=(
-x test_descr
+ -x test_gdb
)
;;
riscv*)
@@ -270,6 +271,7 @@ src_configure() {
-x test_ctypes
-x test_descr
+ -x test_gdb
# bug 931908
-x test_exceptions
)
diff --git a/dev-lang/python/python-3.12.7_p1.ebuild b/dev-lang/python/python-3.12.7_p1.ebuild
index 840cc5b45017..57c5914cd26f 100644
--- a/dev-lang/python/python-3.12.7_p1.ebuild
+++ b/dev-lang/python/python-3.12.7_p1.ebuild
@@ -258,6 +258,7 @@ src_configure() {
powerpc64-*) # big endian
COMMON_TEST_SKIPS+=(
-x test_descr
+ -x test_gdb
)
;;
riscv*)
@@ -273,6 +274,7 @@ src_configure() {
-x test_ctypes
-x test_descr
+ -x test_gdb
# bug 931908
-x test_exceptions
)
diff --git a/dev-lang/python/python-3.13.0-r100.ebuild b/dev-lang/python/python-3.13.0-r100.ebuild
index b71dde63eb03..58686dbacc88 100644
--- a/dev-lang/python/python-3.13.0-r100.ebuild
+++ b/dev-lang/python/python-3.13.0-r100.ebuild
@@ -293,6 +293,7 @@ src_configure() {
powerpc64-*) # big endian
COMMON_TEST_SKIPS+=(
-x test_descr
+ -x test_gdb
)
;;
riscv*)
@@ -308,6 +309,7 @@ src_configure() {
-x test_ctypes
-x test_descr
+ -x test_gdb
# bug 931908
-x test_exceptions
)
diff --git a/dev-lang/python/python-3.13.0.ebuild b/dev-lang/python/python-3.13.0.ebuild
index 74cbac81ba9e..3bceddd3d86f 100644
--- a/dev-lang/python/python-3.13.0.ebuild
+++ b/dev-lang/python/python-3.13.0.ebuild
@@ -295,6 +295,7 @@ src_configure() {
powerpc64-*) # big endian
COMMON_TEST_SKIPS+=(
-x test_descr
+ -x test_gdb
)
;;
riscv*)
@@ -310,6 +311,7 @@ src_configure() {
-x test_ctypes
-x test_descr
+ -x test_gdb
# bug 931908
-x test_exceptions
)
diff --git a/dev-lang/python/python-3.14.0_alpha1-r100.ebuild b/dev-lang/python/python-3.14.0_alpha1-r100.ebuild
index 9c556e225cfc..6f5aada1411d 100644
--- a/dev-lang/python/python-3.14.0_alpha1-r100.ebuild
+++ b/dev-lang/python/python-3.14.0_alpha1-r100.ebuild
@@ -294,6 +294,7 @@ src_configure() {
powerpc64-*) # big endian
COMMON_TEST_SKIPS+=(
-x test_descr
+ -x test_gdb
)
;;
riscv*)
@@ -309,6 +310,7 @@ src_configure() {
-x test_ctypes
-x test_descr
+ -x test_gdb
# bug 931908
-x test_exceptions
)
diff --git a/dev-lang/python/python-3.14.0_alpha1.ebuild b/dev-lang/python/python-3.14.0_alpha1.ebuild
index acbfbfe8de8e..7f9f751bb5f4 100644
--- a/dev-lang/python/python-3.14.0_alpha1.ebuild
+++ b/dev-lang/python/python-3.14.0_alpha1.ebuild
@@ -296,6 +296,7 @@ src_configure() {
powerpc64-*) # big endian
COMMON_TEST_SKIPS+=(
-x test_descr
+ -x test_gdb
)
;;
riscv*)
@@ -311,6 +312,7 @@ src_configure() {
-x test_ctypes
-x test_descr
+ -x test_gdb
# bug 931908
-x test_exceptions
)