summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-08-02 14:52:55 +0200
committerMichał Górny <mgorny@gentoo.org>2022-08-02 14:57:22 +0200
commitf0cb3ef221dff35b8b208d8c3a64cdb9bc558d25 (patch)
tree92aa955292d6deccec46d3feeee2b2b0cedfab52 /dev-lang
parentdev-lang/python: Use external ensurepip wheels in 3.11.0_beta5 (diff)
downloadgentoo-f0cb3ef221dff35b8b208d8c3a64cdb9bc558d25.tar.gz
gentoo-f0cb3ef221dff35b8b208d8c3a64cdb9bc558d25.tar.bz2
gentoo-f0cb3ef221dff35b8b208d8c3a64cdb9bc558d25.zip
dev-lang/python: Use external ensurepip wheels in 3.10.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/python-3.10.6.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/dev-lang/python/python-3.10.6.ebuild b/dev-lang/python/python-3.10.6.ebuild
index 3abc36d17c04..92ac47a6d7ec 100644
--- a/dev-lang/python/python-3.10.6.ebuild
+++ b/dev-lang/python/python-3.10.6.ebuild
@@ -24,10 +24,6 @@ SRC_URI="
S="${WORKDIR}/${MY_P}"
LICENSE="PSF-2"
-# ensurepip bundles pip and setuptools, and pip bundles a lot
-LICENSE+="
- ensurepip? ( Apache-2.0 BSD BSD-2 ISC LGPL-2.1+ MIT MPL-2.0 PSF-2 )
-"
SLOT="${PYVER}"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
IUSE="
@@ -50,6 +46,7 @@ RDEPEND="
>=sys-libs/zlib-1.1.3:=
virtual/libcrypt:=
virtual/libintl
+ ensurepip? ( dev-python/ensurepip-wheels )
gdbm? ( sys-libs/gdbm:=[berkdb] )
ncurses? ( >=sys-libs/ncurses-5.2:= )
readline? (
@@ -196,6 +193,7 @@ src_configure() {
ac_cv_header_stropts_h=no
--enable-shared
+ --with-wheel-pkg-dir="${EPREFIX}"/usr/lib/python/ensurepip
--without-static-libpython
--enable-ipv6
--infodir='${prefix}/share/info'
@@ -344,6 +342,7 @@ src_install() {
pax-mark m "${ED}/usr/bin/${abiver}"
fi
+ rm -r "${libdir}"/ensurepip/_bundled || die
if ! use ensurepip; then
rm -r "${libdir}"/ensurepip || die
fi