summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-10-27 09:10:51 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-10-27 09:51:54 +0100
commitff4ad1ea09221b9cb6a9385f42fba9177934b6f5 (patch)
treedba2b7c2025b8cf764ac6018576642f954bcde4b /dev-lang
parentsys-kernel/ugrd: Add python 3.13 compat/testing (diff)
downloadgentoo-ff4ad1ea09221b9cb6a9385f42fba9177934b6f5.tar.gz
gentoo-ff4ad1ea09221b9cb6a9385f42fba9177934b6f5.tar.bz2
gentoo-ff4ad1ea09221b9cb6a9385f42fba9177934b6f5.zip
dev-lang/ats2: patch make sub-call; fix AR
Closes: https://bugs.gentoo.org/942204 Closes: https://bugs.gentoo.org/942050 Closes: https://bugs.gentoo.org/923881 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ats2/ats2-0.4.2-r1.ebuild11
-rw-r--r--dev-lang/ats2/files/ats2-0.4.2-makefile_dist.patch11
2 files changed, 17 insertions, 5 deletions
diff --git a/dev-lang/ats2/ats2-0.4.2-r1.ebuild b/dev-lang/ats2/ats2-0.4.2-r1.ebuild
index 48cf6674525b..1c0702352d71 100644
--- a/dev-lang/ats2/ats2-0.4.2-r1.ebuild
+++ b/dev-lang/ats2/ats2-0.4.2-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit elisp-common flag-o-matic toolchain-funcs
+inherit elisp-common toolchain-funcs
DESCRIPTION="Functional programming language with dependent types"
HOMEPAGE="https://www.cs.bu.edu/~hwxi/atslangweb/
@@ -61,14 +61,15 @@ src_prepare() {
-e "s|ar -r|$(tc-getAR) ${ARFLAGS} -r|g" \
|| die
+ sed -i contrib/CATS-atscc2js/Makefile \
+ -i src/CBOOT/Makefile \
+ -e "/^AR=/s|ar|$(tc-getAR) ${ARFLAGS}|" \
+ || die
+
rm utils/emacs/flycheck-ats2.el || die
}
src_compile() {
- # Not really accurate but need Makefile investigation and patches.
- # See: https://bugs.gentoo.org/941105 and https://bugs.gentoo.org/923881
- filter-lto
-
emake -j1 CC="$(tc-getCC)" GCC="$(tc-getCC)" CCOMP="$(tc-getCC)" all
if use emacs ; then
diff --git a/dev-lang/ats2/files/ats2-0.4.2-makefile_dist.patch b/dev-lang/ats2/files/ats2-0.4.2-makefile_dist.patch
index ce24f44d32fc..94eb787121b7 100644
--- a/dev-lang/ats2/files/ats2-0.4.2-makefile_dist.patch
+++ b/dev-lang/ats2/files/ats2-0.4.2-makefile_dist.patch
@@ -11,3 +11,14 @@
######
#
+--- a/Makefile_dist
++++ b/Makefile_dist
+@@ -78,7 +78,7 @@ LDFLAGS=
+ #
+ src2_patsopt: ; \
+ $(MAKEJ4) -C src/CBOOT patsopt \
+-CCOMP=$(CCOMP) GCFLAG=$(GCFLAG) LDFLAGS=$(LDFLAGS)
++CCOMP="$(CCOMP)" GCFLAG="$(GCFLAG)" LDFLAGS="$(LDFLAGS)"
+ #
+ bin2_patsopt: src2_patsopt ; $(CPF) src/CBOOT/patsopt bin/patsopt
+ #