summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-11 02:26:32 +0000
committerSam James <sam@gentoo.org>2021-12-11 02:34:30 +0000
commitf1bcd1732a3194be1a7f69bf48d3dc42c332ff4f (patch)
treee2b4349e32cda45f6bc25f2b4029806c53c06a1e /dev-libs/aml/aml-9999.ebuild
parentmedia-gfx/scrot: drop junk accidentally committed (diff)
downloadgentoo-f1bcd1732a3194be1a7f69bf48d3dc42c332ff4f.tar.gz
gentoo-f1bcd1732a3194be1a7f69bf48d3dc42c332ff4f.tar.bz2
gentoo-f1bcd1732a3194be1a7f69bf48d3dc42c332ff4f.zip
dev-libs/aml: add 0.2.1, fix musl build
* Add 0.2.1 * Fixes musl build by depending on queue-standalone. Closes: https://bugs.gentoo.org/828806 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/aml/aml-9999.ebuild')
-rw-r--r--dev-libs/aml/aml-9999.ebuild20
1 files changed, 16 insertions, 4 deletions
diff --git a/dev-libs/aml/aml-9999.ebuild b/dev-libs/aml/aml-9999.ebuild
index db62c0b53724..5ff10f20992d 100644
--- a/dev-libs/aml/aml-9999.ebuild
+++ b/dev-libs/aml/aml-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 2020 Gentoo Authors
+# Copyright 2020-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit meson
-DESCRIPTION="event timer executor loop"
+DESCRIPTION="Event timer executor loop"
HOMEPAGE="https://github.com/any1/aml/"
if [[ ${PV} == 9999 ]]; then
@@ -13,16 +13,28 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/any1/aml.git"
else
SRC_URI="https://github.com/any1/aml/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
+ KEYWORDS="~amd64 ~riscv ~x86"
fi
LICENSE="ISC"
SLOT="0"
IUSE="examples"
+DEPEND="elibc_musl? ( sys-libs/queue-standalone )"
+
+src_prepare() {
+ default
+
+ # The bundled copy includes cdefs which breaks on musl and
+ # this header is already available on glibc.
+ # bug #828806
+ rm include/sys/queue.h || die
+}
+
src_configure() {
local emesonargs=(
$(meson_use examples)
)
+
meson_src_configure
}