summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-10-10 00:37:18 +0000
committerSam James <sam@gentoo.org>2020-10-10 04:52:13 +0000
commit363cc16a8592873a519a7479d93a44f2e4fbcdc3 (patch)
tree48bfcae1bf7185b10d89857bfaf0c67d797faad9 /dev-libs/cloog/cloog-9999.ebuild
parentmedia-libs/openimageio: cleanup old (diff)
downloadgentoo-363cc16a8592873a519a7479d93a44f2e4fbcdc3.tar.gz
gentoo-363cc16a8592873a519a7479d93a44f2e4fbcdc3.tar.bz2
gentoo-363cc16a8592873a519a7479d93a44f2e4fbcdc3.zip
dev-libs/cloog: version bump to 0.20.0
all 4 tests are passing Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Aisha Tammy <gentoo@aisha.cc> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/cloog/cloog-9999.ebuild')
-rw-r--r--dev-libs/cloog/cloog-9999.ebuild57
1 files changed, 27 insertions, 30 deletions
diff --git a/dev-libs/cloog/cloog-9999.ebuild b/dev-libs/cloog/cloog-9999.ebuild
index c85bd46b030f..cf8d94e57868 100644
--- a/dev-libs/cloog/cloog-9999.ebuild
+++ b/dev-libs/cloog/cloog-9999.ebuild
@@ -3,47 +3,49 @@
EAPI="7"
-inherit eutils multilib-minimal
+inherit autotools eutils
-if [[ ${PV} == *9999 ]] ; then
- inherit autotools git-r3
- EGIT_REPO_URI="https://repo.or.cz/cloog.git"
+DESCRIPTION="A loop generator for scanning polyhedra"
+HOMEPAGE="http://www.bastoul.net/cloog/
+ https://github.com/periscop/cloog
+"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/periscop/cloog"
else
+ SRC_URI="https://github.com/periscop/cloog/archive/${P}.tar.gz"
+ S="${WORKDIR}"/cloog-${P}
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
- SRC_URI="http://www.bastoul.net/cloog/pages/download/${P}.tar.gz"
fi
-DESCRIPTION="A loop generator for scanning polyhedra"
-HOMEPAGE="http://www.bastoul.net/cloog/"
-
LICENSE="LGPL-2.1"
SLOT="0/4"
IUSE="static-libs"
-RDEPEND=">=dev-libs/gmp-6.0.0[${MULTILIB_USEDEP}]
- >=dev-libs/isl-0.15:0=[${MULTILIB_USEDEP}]"
-DEPEND="${DEPEND}
- virtual/pkgconfig"
+RDEPEND="
+ dev-libs/gmp
+ dev-libs/isl
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.20.0-notex.patch )
DOCS=( README )
src_prepare() {
default
-
- if [[ ${PV} == "9999" ]] ; then
- ./get_submodules.sh
- eautoreconf -i
- else
- # m4/ax_create_pkgconfig_info.m4 includes LDFLAGS
- # sed to avoid eautoreconf
- sed -i -e '/Libs:/s:@LDFLAGS@ ::' configure || die
- fi
+ AT_NO_RECURSIVE=yes eautoreconf -i
+ # m4/ax_create_pkgconfig_info.m4 includes LDFLAGS
+ # sed to avoid eautoreconf
+ sed -i -e '/Libs:/s:@LDFLAGS@ ::' configure || die
# Make sure we always use the system isl.
- rm -rf isl
+ rm -rf isl || die
}
-multilib_src_configure() {
+src_configure() {
ECONF_SOURCE="${S}" econf \
--with-gmp=system \
--with-isl=system \
@@ -52,12 +54,7 @@ multilib_src_configure() {
}
# The default src_test() fails, so we'll just run these directly
-multilib_src_test() {
- echo ">>> Test phase [check]: ${CATEGORY}/${PF}"
+src_test() {
+ elog ">>> Test phase [check]: ${CATEGORY}/${PF}"
emake -j1 check
}
-
-multilib_src_install_all() {
- einstalldocs
- find "${ED}" -type f -name '*.la' -delete
-}